Error message when you open a mail-merge document or template in Word: "<File name> is a mail merge main document"

Article translations Article translations
Article ID: 275934 - View products that this article applies to.
This article was previously published under Q275934
For a Microsoft Word 2000 version of this article, see 241269.
Expand all | Collapse all

On This Page

SYMPTOMS

When you open a mail-merge main document or template, you may receive an error message similar to one of the following messages.

Error message 1
File name is a mail merge main document. Word cannot find its data source, path\file name.
Error message 2
File name is a mail merge main document. Word cannot find its data source, C:\~~\~~~_virtual_file_~~~.olk.
Error message 3
File name is a mail merge main document. Word cannot find its data source, C:\...\~~~_virtual_file_~~~Mailbox - ....
In this error message, file name is the mail-merge main document that you opened and path\file name is the file that is used as the data source (address list) for your Word mail merge.

If you close the error message by clicking Close (the X in the upper-right corner of the dialog box), you receive an error message similar to the following, and your mail-merge main document does not open:
The document name or path is not valid. Try these suggestions.

* Check the file permissions for the document or drive.
* Use the File Open dialog box to locate the document.
(C:\...\filename.doc).

CAUSE

This problem occurs when the data source (address list) that is attached to your mail-merge main document was deleted, renamed, or moved to a different location.

If you use a Microsoft Outlook Contact list as the data source attached to your mail-merge main document, Word creates a temporary file (for example, C:\~~\~~~_virtual_file_~~~.olk) that contains the contacts from your Outlook Contact list as the attached data source. When you close your Word mail-merge main document, the temporary file is deleted. Therefore, when you reopen the Word mail-merge main document, Word cannot locate the temporary file that is attached as the data source.

The data source file may also have been blocked by Attachment Manager. Attachment Manager is a security feature in Microsoft Windows XP Professional Service Pack 2, Microsoft Windows Server 2003 Service Pack 1, and Windows Vista. Microsoft Office Outlook Express, Microsoft Windows Messenger, Microsoft MSN Messenger, and Windows Internet Explorer use Attachment Manager to help protect a computer from potentially unsafe e-mail message attachments and Internet downloads on the NT file system (NTFS). If the data source file originated as an e-mail message attachment or an Internet download, Windows may have saved the file by using a file stream when you saved the file to the hard disk. The file stream contains information about the security zone from which the file was obtained. When you open the mail merge main document, if Windows determines that the data source file might be unsafe, Windows prevents you from accessing the data in the data source file.

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
883260 Description of how the Attachment Manager works in Windows XP Service Pack 2

WORKAROUND

To work around this problem, use one of the following methods, as appropriate for your situation.

Method 1: If the Data Source Still Exists

If the data source mentioned in the error message still exists, and you know where to find it, follow these steps to reattach the data source:
  1. In the error message dialog box, click Find Data Source.
  2. In the Select Data Source dialog box, select the data source mentioned in the error message, and then click Open.
  3. On the File menu, click Save to save the changes that you made to reattach the missing data source.
  4. Complete your mail merge as usual.

Method 2: If the Data Source Does Not Exist

If the data source mentioned in the error message does not exist, or you do not know where to find the data source, follow these steps:
  1. In the error message dialog box, click Options.
  2. Click Remove Data/Header Source when you receive the following message:
    If the mail merge data/header source file name no longer exists, choose Remove Data/Header Source to remove its association with file name or choose Remove All Merge Info to make file name a normal Word document.
    NOTE: Your Word document is no longer a Word mail-merge main document with a data source attached. Instead, it is a normal Word document.
To reattach a data source and make your document a mail-merge main document again, use one of the following methods depending on the version of Word that you are using.

Word 2003 and Word 2002

  1. In Word 2002, point to Letters and Mailings on the Tools menu, and then click Mail Merge Wizard.

    In Word 2003, point to Letters and Mailings on the Tools menu, and then click Mail Merge.
  2. In the Select recipients section of the Mail Merge Wizard (Step 3 of 6), do one of the following:
    • If you are performing a merge with a file that is saved as your address list (data source), follow these steps:
      1. Click Use an existing list, and then click Browse.
      2. In the Select Data Source dialog box, select the file that contains the address list (data source) that you want to use, and then click Open.
    • If you are performing a merge with a Microsoft Outlook Contact list, follow these steps:
      1. Click Select from Outlook contacts. In the Select from Outlook contacts section, click Choose Contacts Folder.
      2. In the Select Contact List folder dialog box, select the contact list (address list) that you want to use, and then click OK.
  3. Complete your mail merge as usual.

Wrod 2007

  1. On the Mailings tab, click Select Recipients in the Start Mail Merge group.
  2. Do one of the following:
    • To select data from a data source:
      1. Click Using Existing List.
      2. In the Select Data Source dialog box, select the file that contains the address list that you want to use, and then click Open.
    • To select data from Outlook:
      1. Click Select from Outlook contacts.
      2. In the Select Contact dialog box, select the contact list that you want to use, and then click OK.
  3. Complete your mail merge as usual.

Method 3: If the Data Source Not Found Is "~~~_virtual_file_~~~"

To work around this problem when you are using a Microsoft Outlook Contact list as your mail-merge data source, follow these steps:
  1. When you receive the error message described in the "Symptoms" section of this article, click Options in the error message dialog box.
  2. A message similar to the following appears:
    If the mail merge data/header source ~~~_virtual_file_~~~.olk no longer exists, choose Remove Data/Header Source to remove its association with file name or choose Remove All Merge Info to make file name a normal Word document.
    Click Remove Data/Header Source.
NOTE: Your Word document will no longer be a Word mail-merge main document with a data source attached. Instead, it is a normal Word document.

To reattach the Microsoft Outlook Contact list as the data source, use one of the following methods depending on the version of Word that you are using.

Word 2003 and Word 2002

  1. In Word 2002, point to Letters and Mailings on the Tools menu, and then click Mail Merge Wizard.

    In Word 2003, point to Letters and Mailings on the Tools menu, and then click Mail Merge.
  2. In the Select recipients section of the Mail Merge Wizard, click Select from Outlook contacts. In the Select from Outlook contacts section, click Choose Contacts Folder.
  3. In the Select Contact List folder dialog box, select the address book that you want to use, and then click OK.

    This creates a new virtual file (~~~_virtual_file_~~~), based on the current contact list information.
  4. Complete your mail merge as usual.
Wrod 2007
  1. On the Mailings tab, click Select Recipients in the Start Mail Merge group.
  2. Click Select from Outlook contacts.
  3. In the Select Contact dialog box, select the contact list that you want to use, and then click OK.

    When you do this, a new virtual file (~~~_virtual_file_~~~) that is based on the current contact list information is created.
  4. Complete your mail merge as usual.
NOTE: You must repeat these steps each time that you restart Word and open the mail-merge main document that is attached to this data source.

Properties

Article ID: 275934 - Last Review: August 13, 2007 - Revision: 3.0
APPLIES TO
  • Microsoft Office Word 2007
  • Microsoft Office Word 2003
  • Microsoft Word 2002 Standard Edition
Keywords: 
kberrmsg kbtshoot kbnofix kbinterop kbmerge kbprb KB275934

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com