Súbor Hosts je detekovaný ako malware v programe Windows Defender

Preklady článku Preklady článku
ID článku: 2764944 - Zobraziť produkty, ktorých sa tento článok týka.
Rozbaliť všetko | Zbaliť všetko

Priznaky

Uvažujme o nasledujúcom prípade:
  • Nainštalujete Windows 8.
  • Zmeníte súbor Hosts sa uvedie vlastné IP adresu na hostiteľský názov priradenia používateľom zabrániť prehliadania na niektoré webové stránky.
  • Spustiť v Microsoft Windows Defender.
V takomto prípade je Hosts súbor detekovaný akoSettingsModifier:Win32 / PossibleHostsFileHijackmalware hrozba programom Windows Defender.

Pricina

Tento problém sa vyskytuje, pretože program Windows Defender môže určiť nesprávne, že Hosts súbor bol zmenený malware, adware alebo spyware. Typicky, malware programy zmeniť súbor Hosts na presmerovanie používateľov na škodlivé webové stránky. Preto program Windows Defender môže rozpoznať súbor Hosts ako bezpečnostná hrozba.

Riesenie

Ak chcete vyriešiť tento problém, vylúčiť súbor Hosts zo skenovania v programe Windows Defender. Chcete urobiť, postupujte nasledovne:
  1. Otvorte program Windows Defender.
  2. Na nastavenia karte, kliknite na tlačidlo Vylúčené súbory a umiestnenia.
  3. Pod Umiestnenia súborov, kliknite na Prehľadávať.
  4. Vyhľadajte a kliknite na tlačidlo súbor Hosts.

    Poznámka Štandardne sa súbor Hosts sa nachádza v %systemroot%\system32\drivers\etc priečinok.
  5. Kliknite na tlačidlo Pridať, a potom kliknite Uložiť zmeny.

    Zbaliť tento obrázokRozbaliť tento obrázok
    2765289
  6. Ukončiť program Windows Defender.

ODKAZY

Ďalšie informácie o SettingsModifier:Win32 / PossibleHostsFileHijack malware hrozba, prejdite na nasledovnú položku encyklopédii Microsoft Malware Protection Center:

SettingsModifier:Win32 / PossibleHostsFileHijack

Ďalšie informácie o resetovaní Hosts súbor predvolené nastavenia, kliknite na nasledovné číslo článku zobrazíte článok v databáze Microsoft Knowledge Base:
972034 Obnovenie súboru Hosts späť na predvolené?

Vlastnosti

ID článku: 2764944 - Posledná kontrola: 5. októbra 2012 - Revízia: 1.0
Informácie v tomto článku sa týkajú nasledujúcich produktov:
  • Windows 8
  • Windows 8 Pro
  • Windows 8 Enterprise
Kľúčové slová: 
kbsurveynew kbprb kbtshoot kbmt KB2764944 KbMtsk
Strojovo preložené
DÔLEŽITÉ: Tento článok bol preložený pomocou softvéru na strojový preklad od spoločnosti Microsoft, nie prekladateľom. Spoločnosť Microsoft ponúka články preložené prekladateľmi aj strojovo preložené články, vďaka čomu máte možnosť prístupu ku všetkým článkom databázy Knowledge Base vo svojom jazyku. Strojovo preložený článok však nie je vždy perfektný. Môže obsahovať chyby týkajúce sa slovnej zásoby, syntaxe alebo gramatiky, podobne ako cudzinec môže robiť chyby, keď rozpráva vašim jazykom. Spoločnosť Microsoft nenesie zodpovednosť za akékoľvek nepresnosti, chyby alebo škody spôsobené akýmkoľvek nepresným prekladom obsahu alebo jeho použitím zo strany zákazníkov. Spoločnosť Microsoft softvér na strojový preklad pravidelne aktualizuje.
Pokiaľ chcete vidieť anglickú verziu článku, kliknite sem: 2764944

Odošlite odozvu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com