Windows 8 upgrade process fails on a computer has a large volume without a drive letter

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Article ID: 2771571 - View products that this article applies to.
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Symptoms

Consider the following scenario:
  • You have a computer that is running Windows 7.
  • The computer has a volume that is larger than the system drive on which Windows 7 is installed.
  • The volume has no drive letter assigned.
  • You try to upgrade the computer to Windows 8.
In this scenario, the upgrade process fails after the first restart. Additionally, you receive the following error message:
Setup can’t continue. Your computer will now restart, and your previous version of Windows will be restored.
For example, the computer is partitioned as follows:

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Disk partitioning


You may configure a computer in this manner for various reasons. For example, you have a dual-boot system, and you do not want to assign a drive letter to the second system drive. Or, the computer manufacturer configures this volume to store recovery data.

Cause

This issue occurs when the largest volume on the disk is not assigned a drive letter. In this situation, the upgrade process temporarily assigns a drive letter to that volume and saves temporary files ($Windows.~BT)to the volume. However, the temporary drive letter is later removed. This behavior effectively removes the temporary file location, and the upgrade process fails. 

Note This issue does not occur when you perform a clean installation of Windows 8.

When this issue occurs, the following information is logged in the Setupact.log file in the C:\windows\panther directory:
2010-12-10 10:57:33, Info [0x0806e7] MIG Entering Callback_Rollback_ReinitializeAfterReboot 
2010-12-10 10:57:33, Info IBSLIB RollbackReinitialize in progress... 
2010-12-10 10:57:33, Error [0x06421a] IBSLIB RollbackReinitialize: threw exception.: ArgumentException: Directory "F:\$WINDOWS.~BT\Sources\Rollback" doesn't exists. __thiscall OSRollbackService::CCheckpointImpressario::CCheckpointImpressario(const unsigned short *,class OSRollbackService::CCheckpointSequence *,int)[gle=0x00000003] 
2010-12-10 10:57:33, Info IBSLIB RollbackReinitialize finished. 
2010-12-10 10:57:33, Error MIG Callback_Rollback_ReinitializeAfterReboot: Failed to re-initialize rollback[gle=0x00000003] 
2010-12-10 10:57:33, Info MIG PublishCriticalError: Setup can't continue. Your computer will now restart, and your previous version of Windows will be restored.

Resolution

To resolve this issue, assign the largest volume a drive letter.

Properties

Article ID: 2771571 - Last Review: October 31, 2012 - Revision: 1.0
Applies to
  • Windows 8
  • Windows 8 Enterprise
  • Windows 8 Pro
Keywords: 
kbprb kbexpertiseinter kbsurveynew KB2771571

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