Processo de atualização falha em um computador do Windows 8 tem um grande volume sem uma letra de unidade

ID do artigo: 2771571 - Exibir os produtos aos quais esse artigo se aplica.
Expandir tudo | Recolher tudo

Sintomas

Considere o seguinte cenário:
  • Você tem um computador que esteja executando o Windows 7.
  • O computador tem um volume maior que a unidade do sistema no qual o Windows 7 está instalado.
  • O volume não tem nenhuma letra de unidade atribuída.
  • Tente atualizar o computador para o Windows 8.
Nesse cenário, o processo de atualização falha após a primeira reinicialização. Além disso, você recebe a seguinte mensagem de erro:
A instalação não pode continuar. O computador será reiniciado agora e sua versão anterior do Windows será restaurada.
Por exemplo, o computador é particionado da seguinte maneira:

Recolher esta imagemExpandir esta imagem
Particionamento de disco


Você pode configurar um computador dessa maneira por vários motivos. Por exemplo, você tem um sistema de dupla inicialização e você deseja atribuir uma letra de unidade para a segunda unidade do sistema. Ou o fabricante do computador configura esse volume para armazenar dados de recuperação.

Causa

Esse problema ocorre quando o maior volume de disco não é atribuído uma letra de unidade. Nessa situação, o processo de atualização temporariamente atribui uma letra de unidade ao volume e salva os arquivos temporários ($ Windows. ~ BT) para o volume. No entanto, a letra de unidade temporária posterior é removida. Esse comportamento efetivamente remove o local do arquivo temporário e o processo de atualização falha.

Observação Esse problema não ocorre quando você executar uma instalação limpa do Windows 8.

Quando esse problema ocorre, as informações a seguir são registradas o arquivo setupact log no diretório C:\windows\panther:
2010-12-10 10:57:33, Info [0x0806e7] MIG Entering Callback_Rollback_ReinitializeAfterReboot 
2010-12-10 10:57:33, Info IBSLIB RollbackReinitialize in progress... 
2010-12-10 10:57:33, Error [0x06421a] IBSLIB RollbackReinitialize: threw exception.: ArgumentException: Directory "F:\$WINDOWS.~BT\Sources\Rollback" doesn't exists. __thiscall OSRollbackService::CCheckpointImpressario::CCheckpointImpressario(const unsigned short *,class OSRollbackService::CCheckpointSequence *,int)[gle=0x00000003] 
2010-12-10 10:57:33, Info IBSLIB RollbackReinitialize finished. 
2010-12-10 10:57:33, Error MIG Callback_Rollback_ReinitializeAfterReboot: Failed to re-initialize rollback[gle=0x00000003] 
2010-12-10 10:57:33, Info MIG PublishCriticalError: Setup can't continue. Your computer will now restart, and your previous version of Windows will be restored.

Resolução

Para resolver esse problema, atribua o maior volume uma letra de unidade.

Propriedades

ID do artigo: 2771571 - Última revisão: quarta-feira, 31 de outubro de 2012 - Revisão: 1.0
A informação contida neste artigo aplica-se a:
  • Windows 8
  • Windows 8 Enterprise
  • Windows 8 Pro
Palavras-chave: 
kbprb kbexpertiseinter kbsurveynew kbmt KB2771571 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 2771571

Submeter comentários