Conectați-vă cu Microsoft
Conectați-vă sau creați un cont
Salut,
Selectați un alt cont.
Aveți mai multe conturi
Alegeți contul cu care doriți să vă conectați.
Engleză
Ne pare rău. Acest articol nu este disponibil în limba dvs.

Symptoms

When you open the SNA Manager MMC snap-in in a Microsoft Host Integration Server 2010 or Microsoft Host Integration Server 2009 environment, you receive a message that resembles the following:

Link Services 'link_service_name' on server server_name have been deleted.When you receive this message, the host or peer connections that are defined on the specified Host Integration Server system are reset to use a Link service setting of None. When this occurs, the host and peer connections that are reset cannot be enabled, and users on those connections cannot obtain a host session.

Cause

This problem occurs because SNA Manager deletes link service records from the Host Integration Server configuration file when it detects that the link services are no longer installed on the Host Integration Server system.

Resolution

To resolve this problem, apply either the cumulative update or hotfix that is mentioned in this article.

Cumulative update information

Host Integration Server 2010

The fix that resolves this issue is included in cumulative update package 6 for Host Integration Server 2010. To obtain Cumulative Update 6, see the following Microsoft Knowledge Base article:

2752426 Cumulative update package 6 for Host Integration Server 2010

Host Integration Server 2009

The fix that resolves this problem is included in cumulative update package 7 for Host Integration Server 2009. To obtain Cumulative Update 7, see the following Microsoft Knowledge Base article:

2975320 Cumulative Update 7 for Host Integration Server 2009

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, go to the following Microsoft website:

http://support.microsoft.com/contactus/?ws=supportNote The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

Host Integration Server 2010

You must have Microsoft Host Integration Server 2010 Cumulative Update 5 (CU5) installed to apply this hotfix. For more information about Cumulative Update 5, see the following Microsoft Knowledge Base article:

2728515 Cumulative update package 5 for Host Integration Server 2010

Restart information

You may have to restart the computer after you apply this hotfix.

Replacement information

This hotfix does not replace a previously released hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

For all supported x86-based versions of Host Integration Server 2010

File name

File version

File size

Date

Time

Platform

Snaadmin.dll

8.5.4611.2

346,288

23-Oct-2012

18:49

x86

For all supported x64-based versions of Host Integration Server 2010

File name

File version

File size

Date

Time

Platform

Snaadmin.dll

8.5.4611.2

346,288

23-Oct-2012

18:51

x86

Snaadmin.dll

8.5.4611.2

500,400

23-Oct-2012

18:51

x64



Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

After this update is applied, SNA Manager no longer deletes the link service records from the Host Integration Server configuration file when it detects that a link service is not installed on the system. The updated behavior includes a warning message that the link service is not installed. The warning message is intended to let the Host Integration Server administrator know that a link service may be missing.

Aveți nevoie de ajutor suplimentar?

Doriți mai multe opțiuni?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.

Au fost utile aceste informații?

Ce v-a afectat experiența?
Apăsând pe Trimitere, feedbackul dvs. va fi utilizat pentru a îmbunătăți produsele și serviciile Microsoft. Administratorul dvs. IT va avea posibilitatea să colecteze aceste date. Angajamentul de respectare a confidențialității.

Vă mulțumim pentru feedback!

×