Ouverture de session Internet Explorer échoue en raison d'une mémoire tampon insuffisante pour Kerberos

Traductions disponibles Traductions disponibles
Numéro d'article: 277741 - Voir les produits auxquels s'applique cet article
Important Cet article contient des informations sur la façon de modifier le Registre. Veillez à sauvegarder le Registre avant de le modifier. Assurez-vous que vous savez le restaurer en cas de problème. Pour plus d'informations sur la façon de sauvegarder, restaurer et modifier le Registre, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la base de connaissances Microsoft :
256986Description du Registre Microsoft Windows
Agrandir tout | Réduire tout

Sommaire

Symptômes

Au cours du processus de connexion à un serveur Internet Information Server (IIS) configuré pour l'authentification Windows 2000, l'utilisateur voit s'afficher la boîte de dialogue Saisie du mot de passe réseau. L'utilisateur tente d'ouvrir une session. Les informations d'identification sont demandées et fournies, et puis la page d'erreur suivant s'affiche, même si les informations d'identification sont valides :
Vous n'êtes pas autorisé à afficher cette page. Vous êtes pas autorisé à afficher ce répertoire ou cette page à l'aide des informations d'identification que vous avez fournies.

Cause

Les informations d'identification sont valides et peuvent être utilisées pour accéder au même système via le service Windows NT Server via la commande net use. Toutefois, WinInet peut ne pas allouer une mémoire tampon suffisante pour contenant le jeton Kerberos de l'utilisateur. Cela peut se produire si l'utilisateur est membre des groupes de plus de 100, par exemple.

Résolution

Ce problème implique un wininet de Internet Explorer problème de mise en mémoire tampon. Pour résoudre ce problème, appliquer soit le correctif suivant, Windows 2000 Service Pack 2 (SP2) ou une mise à jour de Internet Explorer et définissez le paramètre de Registre MaxTokenSize (décrit dans la section "Informations supplémentaires" de cet article) sur tous les ordinateurs clients.

Un correctif pris en charge est disponible auprès de Microsoft. Toutefois, ce correctif est conçu uniquement pour corriger le problème décrit dans cet article. Appliquer ce correctif uniquement aux systèmes rencontrant ce problème spécifique.

Si le correctif est disponible au téléchargement, il existe une section «Téléchargement de correctif logiciel disponible» en haut de cet article de la base de connaissances. Si cette section n'apparaît pas, soumettez une demande service clientèle Microsoft et de support technique pour obtenir le correctif.

Remarque Si des problèmes supplémentaires se produisent ou si des procédures de dépannage sont nécessaires, vous devrez peut-être créer une demande de service distincte. Les coûts habituels du support technique s'appliqueront aux questions supplémentaires et aux problèmes qui ne relèvent pas de ce correctif spécifique. Pour obtenir une liste complète des numéros de téléphone Microsoft auprès des services de support technique ou pour créer une demande de service distincte, reportez-vous au site Web de Microsoft à l'adresse suivante :
http://support.microsoft.com/contactus/?ws=support
Remarque Le formulaire «Téléchargement de correctif logiciel disponible» affiche les langues pour lesquelles le correctif est disponible. Si vous ne voyez pas votre langue, il est, car un correctif n'est pas disponible pour cette langue.La version anglaise de ce correctif doit avoir les attributs de fichier suivants ou ceux d'une version ultérieure :
   Date        Time    Version      Size    File name
   --------------------------------------------------
   10/13/2000  04:35p 5.0.3210.1300 459,536 Wininet.dll

				

Contournement

Réduisez le nombre de groupes auxquels appartient l'utilisateur.

Statut

Microsoft a confirmé l'existence de ce problème dans Microsoft Windows 2000.

Plus d'informations

Pour plus d'informations sur la façon d'installer Windows 2000 et les correctifs Windows 2000 en même temps, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la base de connaissances Microsoft :
249149Installation des correctifs Microsoft Windows 2000 et Windows 2000
Remarque Le correctif décrit dans la section «Résolution» de cet article remplace le correctif fourni à l'origine dans l'article suivant de la base de connaissances Microsoft :
269643Internet Explorer l'authentification Kerberos ne fonctionne pas en raison d'une mémoire tampon insuffisante, connexion à IIS
Avertissement Problèmes graves peuvent se produire si vous modifiez le Registre de façon incorrecte à l'aide de l'Éditeur du Registre ou à une autre méthode. Ces problèmes peuvent obliger à réinstaller votre système d'exploitation. Microsoft ne peut pas garantir que ces problèmes peuvent être résolus. Modifier le Registre à vos risques et périls.
Ce correctif fournit un paramètre de Registre que vous pouvez utiliser pour augmenter la taille de jeton Kerberos. Par exemple, augmenter le jeton de 65 Ko permet à un utilisateur soit présent dans plus de 900 groupes. En raison les informations d'identificateur de sécurité associé, ce nombre peut varier.

Pour définir ce paramètre, exécutez les opérations suivantes :
  1. Démarrez l'Éditeur du Registre (Regedt32.exe).
  2. Recherchez et cliquez sur le paramètre de Registre suivant :
    System\\CurrentControlSet\\Control\\Lsa\\Kerberos\Parameters
  3. Dans le menu Edition, cliquez sur Ajouter une valeur et ajoutez la valeur de Registre suivante :
    Nom de valeur : MaxTokenSize
    Type de données : REG_DWORD
    Radix : decimal
    Données de la valeur : 65535
  4. Quittez l'Éditeur du Registre.
La valeur par défaut pour MaxTokenSize est 12000 décimal. Microsoft vous recommande de configurer cette valeur à 65535 décimal, hexadécimal FFFF. Si vous définissez cette valeur mal à 65535 hexadécimal (une valeur extrêmement grande) opérations de l'authentification Kerberos peuvent échouer et programmes renverra des erreurs. Pour plus d'informations, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la base de connaissances Microsoft :
297869Administrateur SMS problèmes après avoir modifié la valeur de Registre Kerberos MaxTokenSize
Une fois que vous définissez la valeur et l'ordinateur est mis à jour, redémarrez l'ordinateur. Bien que vous devez mettre à jour les contrôleurs de domaine individuellement, vous pouvez utiliser les paramètres de stratégie de groupe pour définir cette valeur pour les ordinateurs clients qui ont également été mis à jour. Vous devez configurer tous les systèmes clients et serveurs dans le domaine avec cette modification du Registre et mettre à jour les systèmes avec Windows 2000 SP2 ou les correctifs.

Pour plus d'informations, cliquez sur les numéros ci-dessous pour afficher les articles correspondants dans la base de connaissances Microsoft :
313661CORRECTIF : Message d'erreur: "Délai expiré" se produit lorsque vous vous connectez à SQL Server sur TCP/IP et le Kerberos MaxTokenSize est supérieur à 0xFFFF
300367DCOM client peut inscrire mémoire sur le réseau
Pour plus d'informations sur la configuration de la taille de jeton Kerberos et la prise en charge dans Windows 2000, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la base de connaissances Microsoft :
263693La stratégie de groupe ne soient pas appliquée aux utilisateurs appartenant à de nombreux groupes

Procédure pour reproduire le problème

  1. Créer un compte Windows NT.
  2. Vérifiez que Active Directory est installé et l'authentification intégrée est configurée.
  3. Ajoutez le compte à environ 100 groupes différents.
  4. Créez un second compte et l'ajouter à trois des groupes.
Résultats :
Impossible de naviguer sur le premier compte via http:// <servername>, mais peut le deuxième compte.
Remarque Le script suivant à l'aide de creategroup.vbs à partir de la reskit a été utilisé pour reproduire le problème :
CreateGroup.vbs from the resource kit is a viable method for doing so.
creategroup LDAP: DC=Domain,DC=Org,DC=Company,DC=com GroupName1
CN=administrator,CN=Users,DC=Domain,DC=Org,dc=Company,dc=com password
creategrp.log
...
					

Propriétés

Numéro d'article: 277741 - Dernière mise à jour: mercredi 21 février 2007 - Version: 5.7
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professionnel
Mots-clés : 
kbmt kbautohotfix kbhotfixserver kbbug kbfix kbqfe KB277741 KbMtfr
Traduction automatique
IMPORTANT : Cet article est issu du système de traduction automatique mis au point par Microsoft (http://support.microsoft.com/gp/mtdetails). Un certain nombre d?articles obtenus par traduction automatique sont en effet mis à votre disposition en complément des articles traduits en langue française par des traducteurs professionnels. Cela vous permet d?avoir accès, dans votre propre langue, à l?ensemble des articles de la base de connaissances rédigés originellement en langue anglaise. Les articles traduits automatiquement ne sont pas toujours parfaits et peuvent comporter des erreurs de vocabulaire, de syntaxe ou de grammaire (probablement semblables aux erreurs que ferait une personne étrangère s?exprimant dans votre langue !). Néanmoins, mis à part ces imperfections, ces articles devraient suffire à vous orienter et à vous aider à résoudre votre problème. Microsoft s?efforce aussi continuellement de faire évoluer son système de traduction automatique.
La version anglaise de cet article est la suivante: 277741
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Envoyer des commentaires

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com