PowerShell cmdlets are not available after installing an App-V v5 component

Article ID: 2778283 - View products that this article applies to.
Expand all | Collapse all

Symptoms

Consider the following scenario:

· A PowerShell command prompt is used to install a Microsoft Application Virtualization (App-V) v5 component (Client, Sequencer, Management Server or Publishing Server).

· After the install completes, you run an App-V cmdlet in the same PowerShell session and the cmdlet is not recognized.

· If a new PowerShell command prompt is opened, the App-V cmdlet is recognized.

Cause

This issue occurs due to a PowerShell limitation.

Resolution

If an App-V v5 component is installed using a PowerShell command prompt, a new PowerShell command prompt session must to be started in order for the App-V cmdlets to be recognized.
Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use for other considerations.

Properties

Article ID: 2778283 - Last Review: November 1, 2012 - Revision: 1.0
Applies to
  • Microsoft Application Virtualization 5.0 for Terminal Services
  • Microsoft Application Virtualization 5.0 for Windows Desktops
  • Microsoft Application Virtualization Hosting 5.0 for Windows Desktops
Keywords: 
KB2778283

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com