"Client Side-Rendering-Druckanbieter" Registry Key Wachstum auf einem Windows Server 2008 R2-basierten Remote Desktop Session Host-server

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Problembeschreibung

Betrachten Sie das folgende Szenario:
  • Die Funktion des Remote Desktop Services (RDS) wird auf einem Windows Server 2008 R2-basierten Computer installieren.
  • Der Server verwendet die Client-seitige Ausgabefeature für Druckaufträge.
  • Clients von unterschiedlichen Positionen mit dem RDS-Server verbinden, und sie verwenden unterschiedliche Drucker basierend auf dem Standort.

In diesem Szenario der Registrierungsschlüssel HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Print\Providers\Client Seite rendern Print Provider kann schnell wachsen, um 1 Gigabyte (GB) oder größer. Darüber hinaus können Sie Leistungsprobleme auf den RDS-Server, wie z. B. lange Anmeldezeiten oder hohe CPU-Auslastung durch den Druckerspooler auftreten. Wenn Sie versuchen, einen Drucker auf dem RDS-Server zuordnen, erhalten Sie außerdem eine Fehlermeldung angezeigt, die der folgenden ähnelt:
Fehler 0 x 00000006

Ursache

Dieses Problem tritt auf, da der RDS-Server Clientinformationen für jeden Benutzer und Drucker in der Client-Seite rendern Druckanbieter Registrierungsschlüssel zwischenspeichert, wenn ein Client-Benutzer mit dem RDS-Server eine Verbindung herstellt, mit Netzwerkdruckerverbindungen. Diese Registrierungseinträge werden nicht gelöscht, wenn der Clientbenutzer trennt die Verbindung des Servers, und sie veralten, wenn der Benutzer nie wieder anmeldet.

Lösung

Hotfix-Informationen

Ein unterstützter Hotfix ist von Microsoft erhältlich. Dieser Hotfix behebt jedoch nur das Problem, welches in diesem Artikel beschrieben wird. Wenden Sie diesen Hotfix nur auf Systemen an, bei denen das in diesem Artikel beschriebene Problem auftritt. Dieser Hotfix wird möglicherweise weiteren Tests unterzogen. Wenn Ihr System durch dieses Problem nicht schwerwiegend beeinträchtigt ist, empfehlen wir, dass für das nächste Softwareupdate zu warten, das diesen Hotfix enthält.

Wenn der Hotfix zum Download zur Verfügung steht, wird es im oberen Bereich dieses Artikels einen Link "Hotfix donwload" geben. Wenn dieser Abschnitt nicht angezeigt wird, wenden Sie sich an den Microsoft Customer Service und Support, um den Hotfix zu erhalten.

Hinweis Falls weitere Probleme auftreten oder andere Schritte zur Problembehandlung erforderlich sind, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Die üblichen Support-Kosten gelten für zusätzliche Supportfragen und Probleme, die für diesen speziellen Hotfix nicht qualifizieren. Eine vollständige Liste von Microsoft Customer Service und Support-Telefonnummern oder eine separate Serviceanfrage erstellen finden Sie auf die folgende Microsoft-Website:
http://support.Microsoft.com/contactus/?WS=Support
Hinweis Das Formular "Hotfixdownload available" zeigt die Sprachen an, in denen der Hotfix verfügbar ist. Wenn Ihre Sprache nicht angezeigt wird, liegt es daran, dass kein Hotfix für diese Sprache verfügbar ist.

Hinweis Dieser Hotfix entfernt keine vorhandenen verlorene Daten aus dem Registrierungsschlüssel. Sie haben die verlorene Registrierungseinträge manuell aus dem Registrierungsschlüssel zu löschen.

Erforderliche Komponenten

Um diesen Hotfix zu installieren, muss Windows Server 2008 R2 oder Windows Server 2008 R2 Service Pack 1 (SP1) ausgeführt werden.Weitere Informationen dazu, wie Sie ein Windows Server 2008 R2 Servicepack zu erhalten, finden im folgenden Artikel der Microsoft Knowledge Base:
976932Informationen zum Servicepack 1 für Windows 7 und Windows Server 2008 R2

Registrierungsinformationen

Um den Hotfix verwenden zu können, müssen Sie keinen die Registrierung ändern.

Ist ein Neustart erforderlich?

Sie müssen den Computer neu starten, nachdem Sie diesen Hotfix anwenden.

Ersetzte Hotfixes

Dieser Hotfix ersetzt keine zuvor veröffentlichten Hotfix.

Dateiinformationen

Die internationale Version dieses Hotfixes installiert Dateien mit den Attributen, die in den folgenden Tabellen aufgeführt sind. Die Datumsangaben und Uhrzeiten für diese Dateien werden in Coordinated Universal Time (UTC) aufgeführt. Die Datums- und Uhrzeitangaben für diese Dateien auf dem lokalen Computer werden in Ihrer lokalen Zeit zusammen mit Berücksichtigung der aktuellen Daylight Saving Time (DST) angezeigt. Darüber hinaus können die Datums- und Uhrzeitangaben ändern, wenn Sie bestimmte Operationen auf die Dateien anwenden.
Hinweise zu den Dateiinformationen für Windows Server 2008 R2
Wichtig Windows 7-Updates und Windows Server 2008 R2-Hotfixes sind im selben Paket enthalten. Allerdings werden Updates auf der Seite Hotfix Anforderung unter beiden Betriebssystemen aufgelistet. Um das Hotfix-Paket anzufordern, das auf eine oder beide Betriebssysteme angewendet wird, wählen Sie den Hotfix, der auf der Seite unter "Windows 7/Windows Server 2008 R2" aufgelistet ist. Bezieht sich immer auf den Abschnitt "Beziehen sich auf" in Artikel, um das aktuelle Betriebssystem bestimmen, dem jeden Hotfix gilt.
  • Die Dateien, die gelten für bestimmte Produkte, Meilensteine (RTM, SPn) und Servicebereiche (LDR, GDR) können identifiziert werden, anhand der Dateiversionsnummern wie in der folgenden Tabelle dargestellt:
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    VersionProduktMeilensteinServicebereich
    6.1.760 0,21XxxWindows Server 2008 R2RTMLDR
    6.1.760 Version 1.22XxxWindows Server 2008 R2SP1LDR
  • Sind die MANIFESTEN-Dateien (. manifest), die installiert werden für jede Umgebung separat aufgeführt im Abschnitt "Weitere Dateiinformationen für Windows Server 2008 R2". MANIFEST-Dateien und die dazugehörigen Sicherheitsupdates Katalogdateien (.cat), sind äußerst wichtig, den Status der aktualisierten Komponenten verwalten. Die Sicherheitskatalogdateien, für die die Attribute nicht aufgelistet sind, sind mit einer digitalen Microsoft-Signatur signiert.
Für alle unterstützten X 64-basierten Versionen von Windows Server 2008 R2
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assets folding start collapsed
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DateinameDateiversionDateigrößeDatumUhrzeitPlattform
Win32spl.dll6.1.7600.21363751,61607-Nov-201205: 52x64
Win32spl.dll6.1.7601.22154756,22407-Nov-201205: 42x64
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assets folding end collapsed
Für alle unterstützten IA-64-basierten Versionen von Windows Server 2008 R2
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assets folding start collapsed
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DateinameDateiversionDateigrößeDatumUhrzeitPlattform
Win32spl.dll6.1.7600.213631,513,47207-Nov-201204: 52IA-64
Win32spl.dll6.1.7601.221541,527,29607-Nov-201204: 51IA-64
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assets folding end collapsed

Status

Microsoft hat bestätigt, dass dieses Problem auf die im Abschnitt "Gilt für" aufgeführten Microsoft-Produkten zutrifft.

Weitere Informationen

Weitere Informationen zur Terminologie für Softwareupdates finden Sie im folgenden Artikel der Microsoft Knowledge Base:
824684Beschreibung der Standardterminologie, die zum Beschreiben von Microsoft-Softwareupdates verwendet wird

Weitere Dateiinformationen

Weitere Dateiinformationen für Windows Server 2008 R2

Weitere Dateien für alle unterstützten X 64-basierten Versionen von Windows Server 2008 R2
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DateinameAmd64_01fe9680c458dc29eca84e1ead48b39a_31bf3856ad364e35_6.1.7600.21363_none_d50bbaa4cbc862df.Manifest
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Weitere Dateien für alle unterstützten IA-64-basierten Versionen von Windows Server 2008 R2
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Zeit (UTC)05: 17
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Datum (UTC)07-Nov-2012
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Eigenschaften

Artikel-ID: 2778831 - Geändert am: Donnerstag, 10. Januar 2013 - Version: 1.0
Die Informationen in diesem Artikel beziehen sich auf:
  • Windows Server 2008 R2 Service Pack 1
  • Windows Server 2008 R2 Datacenter
  • Windows Server 2008 R2 Enterprise
  • Windows Server 2008 R2 for Itanium-Based Systems
  • Windows Server 2008 R2 Foundation
  • Windows Server 2008 R2 Standard
  • Windows Web Server 2008 R2
Keywords: 
kbautohotfix kbqfe kbhotfixserver kbfix kbexpertiseadvanced kbsurveynew kbmt KB2778831 KbMtde
Maschinell übersetzter Artikel
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Den englischen Originalartikel können Sie über folgenden Link abrufen: 2778831
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