Help and Support
 

powered byLive Search

Visio2000: Error 100 When You Open a Drawing After Abnormal Termination

Retired KB ArticleThis article was written about products for which Microsoft no longer offers support. Therefore, this article is offered "as is" and will no longer be updated.
Article ID:278261
Last Review:February 22, 2007
Revision:2.6
This article was previously published under Q278261

SYMPTOMS

When you have a drawing file open in Microsoft Visio 2000, if either Visio 2000 or the operating system (or both) experience an abnormal termination, the drawing file could be placed in an inconsistent state. The next time that you try to open the drawing file in Visio, you may receive the following error message:
An error (100) occurred during the action Open File. - Visio cannot open the file because it's not a Visio file.

Back to the top

CAUSE

Visio 2000 files use COM/OLE Structured Storage mechanisms to ensure the greatest file integrity possible. However, because of the architecture of COM/OLE structured storage, there are situations when sections of an open file are buffered by the operating system, even when not in use by the program. This delay in the data being flushed out to disk makes it possible that portions of the data within the file could be compromised or lost if an unexpected shutdown, such as a power failure, occurs before the data is flushed to disk.

NOTE: This problem does not occur when you perform a typical, clean shutdown of either Visio 2000 or the operating system (or both).

Back to the top

RESOLUTION

A supported, post-Visio 2000 SR-1 fix that corrects the potential for this problem is now available from Microsoft. The following file is available for download from the Microsoft Download Center:
DownloadDownload q278261.exe now (http://download.microsoft.com/download/visio2000std/update/2000/win98/en-us/q278261.exe)
Once you have downloaded the update, close all instances of Visio before you install the update. To install the update, double-click q278261.exe in Windows Explorer.

IMPORTANT: A Microsoft Visio U.S. English or International English edition of SR-1 must be present on each computer to which you apply this update.

NOTE: The installation file has an option to be run from a command prompt silently. The /Q:A switch enables silent mode and assumes that the person running this installation package is either an admin or SMS. This installation performs no checking for admin rights or disk space, and no prompts or errors are reported. The following command is an example of how to run this installation package from a command prompt in silent mode. The command assumes that the file is in the root directory of drive C or can be located in the Path environment variable:
q278261.exe /Q:A

The q278261.exe file contains the following file:
Date       Time     Version      Size      File name
-------------------------------------------------------
10/26/00   9:39AM   6.1.0.1023   5107712   VisLib32.dll
				
For additional information about how to download Microsoft Support files, click the following article number to view the article in the Microsoft Knowledge Base:
119591 (http://support.microsoft.com/kb/119591/EN-US/) How to Obtain Microsoft Support Files from Online Services
Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help to prevent any unauthorized changes to the file.

Back to the top

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Back to the top

MORE INFORMATION

This update addresses one potential cause of Error 100. Further instances of Error 100 could occur if there are hardware or other issues present. However, to protect from the potential problem noted in the "Cause" section of this article, Microsoft recommends that you apply the update noted in this article.

For further information, please refer to the topics on "Structured Storage" in the MSDN Online Library at the following Microsoft Web site:
http://msdn.microsoft.com/library/default.asp (http://msdn.microsoft.com/library/default.asp)

Back to the top

REFERENCES

For additional information about Error 100 when you open a Visio drawing, click the article number below to view the article in the Microsoft Knowledge Base:
264660 (http://support.microsoft.com/kb/264660/EN-US/) Visio2000: Error 100 When You Open a Saved Visio Drawing

Back to the top


APPLIES TO
Microsoft Visio 2000 Service Release 1

Back to the top

Keywords: 
kbhotfixserver kbqfe kbdownload kbdownload kbbug kberrmsg kbfile kbgraphxlink kbqfe KB278261

Back to the top

Article Translations

 

Other Support Options

  • Need More Help?
    Contact a Support professional by Email, Online or Phone.
  • Customer Service
    For non-technical assistance with product purchases, subscriptions, online services, events, training courses, corporate sales, piracy issues, and more.
  • Newsgroups
    Pose a question to other users. Discussion groups and Forums about specific Microsoft products, technologies, and services.