Windows Store apps that use the Remote Desktop ActiveX interface do not connect to remote servers in Windows 8

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Article ID: 2782802
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Symptoms

Consider the following scenario:
  • You upgrade to Windows 8 from Windows 7 or from Windows Vista.
  • During the upgrade process, you migrate your settings to Windows 8.
  • When Windows 8 is installed, you try to use a Windows Store app that uses the Remote Desktop ActiveX interface.

    For example, you try to use the Remote Desktop Windows Store app to connect to a remote PC.
In this scenario, the Windows Store app does not connect to the remote server. Additionally, you receive the following error message:
The remote session was disconnected because license store creation failed with access denied. Please run remote desktop client with elevated privileges.

Cause

This issue occurs because Windows Store apps do not have sufficient permissions to access the MSLicensing registry key or the Store subkey. Therefore, when an app connects to a remote server, the in-process COM object for the Remote Desktop ActiveX interface cannot access the registry and stops the connection process.

Resolution

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall the operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

To have us fix this problem for you, go to the "Fix it for me" section. If you prefer to fix this problem yourself, go to the "Let me fix it myself" section.

Fix it for me

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To fix this problem automatically, click the Fix it button or link. Then click Run in the File Download dialog box, and follow the steps in the Fix it wizard.


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Fix this problem
Microsoft Fix it 55025
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Notes
  • This wizard may be in English only. However, the automatic fix also works for other language versions of Windows.
  • If you are not on the computer that has the problem, save the Fix it solution to a flash drive or a CD and then run it on the computer that has the problem.
  • We would appreciate your feedback. To provide feedback or to report any issues with this solution, please leave a comment on the "Fix it for me" blog or send us an email message.
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Let me fix it myself

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To resolve this issue, follow these steps:
  1. Start Registry Editor. To do this, follow these steps:
    1. Swipe in from the right edge of the screen, and then tap Search. Or, if you are using a mouse, point to the lower-right corner of the screen, and then click Search.
    2. In the search box, type regedit.exe.
    3. Tap or click the displayed regedit.exe icon.
  2. Configure permissions for the MSLicensing registry key. To do this, follow these steps:
    1. Locate the following registry subkey:
      HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSLicensing
    2. Swipe across or right-click the MSLicensing key, and then tap or click Permissions.
    3. Tap or click Add.
    4. In the Select Users or Groups dialog box, tap or click Locations.
    5. Select the local computer at the top of the list, and then tap or click OK.
    6. Type the following value in the Enter the object names to select box:
      ALL APPLICATION PACKAGES
    7. Tap or click OK.
    8. Make sure that the Read permissions are enabled for "All APPLICATION PACKAGES", and then tap or click OK.
  3. Configure permissions for the Store registry key. To do this, follow these steps:
    1. Locate the following registry subkey:
      HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSLicensing\Store
    2. Swipe across or right-click the Store key, and then tap or click Permissions.
    3. Tap or click Add.
    4. In the Select Users or Groups dialog box, tap or click Locations.
    5. Select the local computer at the top of the list, and then tap or click OK.
    6. Type the following value in the Enter the object names to select box:
      ALL APPLICATION PACKAGES
    7. Tap or click OK.
    8. Make sure that the Read permissions are enabled for "All APPLICATION PACKAGES" .
    9. Tap or click Advanced.
    10. Under the Permissions tab, select the entry for ALL APPLICATION PACKAGES, and then tap or click Edit.
    11. In the Permission Entry for Store window, tap or click the Show advance permission link.
    12. Make sure that the following four check boxes are selected:
      • Query Value
      • Set Value
      • Create Subkey
      • Enumerate Subkeys
    13. Tap or click OK three times.
  4. Exit Registry Editor.

Properties

Article ID: 2782802 - Last Review: December 19, 2012 - Revision: 2.1
Keywords: 
kbprb kbexpertisebeginner kbsurveynew kbfixme kbmsifixme KB2782802

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