Proces Store.exe ulega awarii po dodaniu pewnych kluczy rejestru do serwera skrzynki pocztowej programu Exchange Server 2010

Tłumaczenia artykułów Tłumaczenia artykułów
Numer ID artykułu: 2784081 - Zobacz jakich produktów dotyczą zawarte w tym artykule porady.
Rozwiń wszystko | Zwiń wszystko

Symptomy

Rozważmy następujący scenariusz:
  • Pełnomocnik udzielić uprawnienia pełnego dostępu do folderu Kalendarz menedżera w środowisku Microsoft Exchange Server 2010.
  • Dodaj następujące klucze rejestru do serwera skrzynki pocztowej. Klucze te stosuje się do magazynu skrzynek pocztowych, która posiada skrzynek pocztowych zasobów:
    Klucz rejestru: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\msExchangeIS\Nazwa serwera\StoreName
    Nazwa wartości: Wysłane reprezentujących działa jako autor
    Typ wartości: REG_DWORD
    Wartość danych: Dodatnia wartość różną od zera
    Klucz rejestru: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\msExchangeIS\Nazwa_serwera\StoreName
    Nazwa wartości: Delegat działa jako autor
    Typ wartości: REG_DWORD
    Wartość danych: Dodatnia wartość różną od zera

    Uwaga Po dodaniu klucza rejestru "Delegować aktów jako autor" Menedżera można zmienić elementy kalendarza, które tworzy pełnomocnika w imieniu menedżera. Jednak zaleca się dodać klucz rejestru, ponieważ może to spowodować problemy z wydajnością.
  • Pełnomocnik tworzy wezwanie na spotkanie w imieniu menedżera. Następnie Menedżer próbuje zmienić element kalendarza.
W tym scenariuszu proces Store.exe rozbija się na serwerze skrzynek pocztowych programu Exchange Server 2010. Ponadto następujące zdarzenie jest rejestrowane w dzienniku aplikacji:

Rejestrowanie nazwy: aplikacji
Źródło: Wspólne MSExchange
Data: Data
Identyfikator zdarzenia: 4999
Zadanie kategoria: Ogólne
Poziom: błąd
Słowa kluczowe: klasyczne
Użytkownik: Brak
Komputer: Komputer
Opis:
Raport programu Watson zostaną wysłane na identyfikator procesu: Identyfikator procesu, z parametrami: E12N, Typ kompilacji, Numer wersji, store.exe EXCHMEM.dll, XXXX, c0000005, XXXX, Numer wersji.
ErrorReportingEnabled: FAŁSZ

Przyczyna

Ten problem występuje, ponieważ klucze rejestru Wysyłane reprezentujących działa jako autor i Pełnomocnik działa jako autor doprowadzić do uszkodzenia pamięci podczas deskryptora zabezpieczeń sprawdza poprawność magazynu programu Exchange.

Rozwiązanie

Aby rozwiązać ten problem, należy zainstalować następujący pakiet zbiorczy aktualizacji:
2746164 Opis pakietu zbiorczego aktualizacji 6 dla programu Exchange Server 2010 z dodatkiem Service Pack 2

Stan

Firma Microsoft potwierdziła, że jest to problem występujący w produktach firmy Microsoft, które są wymienione w sekcji "Informacje zawarte w tym artykule dotyczą".

Właściwości

Numer ID artykułu: 2784081 - Ostatnia weryfikacja: 12 lutego 2013 - Weryfikacja: 1.0
Informacje zawarte w tym artykule dotyczą:
  • Microsoft Exchange Server 2010 Service Pack 2 na następujących platformach
    • Microsoft Exchange Server 2010 Enterprise
    • Microsoft Exchange Server 2010 Standard
Słowa kluczowe: 
kbsurveynew kbqfe kbexpertiseinter kbfix kbmt KB2784081 KbMtpl
Przetłumaczone maszynowo
WAŻNE: Ten artykuł nie został przetłumaczony przez człowieka, tylko przez oprogramowanie do tłumaczenia maszynowego firmy Microsoft. Firma Microsoft oferuje zarówno artykuły tłumaczone przez ludzi, jak i artykuły tłumaczone maszynowo, dzięki czemu każdy użytkownik może uzyskać dostęp do całej zawartości bazy wiedzy Knowledge Base we własnym języku. Prosimy jednak pamiętać, że artykuły przetłumaczone maszynowo nie zawsze są doskonałe. Mogą zawierać błędy słownictwa, składni i gramatyki, przypominające błędy robione przez osoby, dla których język użytkownika nie jest językiem ojczystym. Firma Microsoft nie odpowiada za wszelkie nieścisłości, błędy lub szkody spowodowane nieprawidłowym tłumaczeniem zawartości oraz za wykorzystanie tej zawartości przez klientów. Oprogramowanie do tłumaczenia maszynowego jest często aktualizowane przez firmę Microsoft.
Anglojęzyczna wersja tego artykułu to: 2784081

Przekaż opinię

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com