« L’URL de synchronisation active était dans un format non valide » lors de l’utilisation de l’outil Analyseur de connectivité à distance

Remarque

Ce scénario s’applique uniquement aux clients Microsoft 365 disposant d’un déploiement hybride d’Exchange Online et d’Exchange Server sur site.

PROBLÈME

Lorsque vous essayez d’utiliser l’outil Microsoft Remote Connectivity Analyzer pour résoudre les problèmes liés à Microsoft Exchange ActiveSync (EAS) dans votre organisation, le message d’erreur suivant s’affiche :

L’URL ActiveSync était dans un format non valide. Cela devrait être https://host/Microsoft-Server-ActiveSync.. L’URL était votre URL.

Remarque

Lorsque vous exécutez le test, une requête HTTP est envoyée au fournisseur de découverte automatique MobileSync sur le serveur d’accès au client. Cette demande est faite pour obtenir une URL externe pour les périphériques ActiveSync à utiliser lorsque les périphériques ActiveSync se connectent au serveur Exchange.

CAUSE

Ce problème se produit si l’URL externe n’est pas au format suivant :

https://hostname/Microsoft-Server-ActiveSyncNote

Remarque

Dans cette URL, l’espace réservé du nom d’hôte représente le nom de domaine complet (FQDN) du système de noms de domaine externe (DNS) que les périphériques ActiveSync utilisent pour se connecter à EAS.

SOLUTION

Pour résoudre ce problème, vérifiez le paramètre de la propriété ExternalURL pour le répertoire virtuel Microsoft-Server-ActiveSync sur le serveur Exchange local. Pour cela, procédez comme suit :

  1. Ouvrez Exchange Management Console (EMC) sur le serveur Exchange local.

  2. Développez Configuration du serveur, sélectionnez Accès au client, sélectionnez le serveur d’accès au client approprié, puis cliquez sur l’onglet Synchronisation Exchange Active.

  3. Sélectionnez le répertoire virtuel Microsoft-Server-ActiveSync, puis cliquez sur Propriétés.

  4. Assurez-vous que la propriété ExternalURL utilise le format suivant :

    https://hostname//Microsoft-Server-ActiveSync

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