Aucune boîte aux lettres de dossier public active n’a été trouvée lors de la création d’un dossier public

Numéro de la base de connaissances d’origine : 2786607

Symptômes

Supposons que vous créez la première boîte aux lettres de dossiers publics avec le HoldForMigration paramètre dans Exchange Server 2013 ou Microsoft Exchange Server 2016. Vous effectuez l’une des actions suivantes dans l’environnement :

  • Vous essayez d’accéder à la hiérarchie des dossiers publics en exécutant l’applet Get-PublicFolder de commande dans Exchange Management Shell (EMS) ou en utilisant le Centre d’administration Exchange (EAC).
  • Vous essayez de créer un dossier public sur le serveur Exchange.

Dans ce cas, le message d’erreur ci-dessous s’affiche :

Aucune boîte aux lettres de dossier public active n’a été trouvée. Cela se produit lorsqu’aucune boîte aux lettres de dossier public n’est configurée ou qu’elle est provisionnée en mode HoldForMigration. Si vous n’effectuez pas actuellement de migration, créez une boîte aux lettres de dossiers publics.

Voici un exemple de capture d’écran du message d’erreur dans EMS :

Capture d’écran du message d’erreur dans E M S.

Voici un exemple de capture d’écran du message d’erreur dans le centre d’administration Exchange :

Capture d’écran du message d’erreur dans E A C.

Remarque

La boîte aux lettres de dossiers publics doit être créée avec le HoldForMigration paramètre uniquement si vous effectuez une migration de dossiers publics hérités vers des dossiers publics modernes dans Exchange Server 2013 ou Exchange Server 2016. La spécification du HoldForMigration paramètre verrouille la hiérarchie de dossiers publics dans Exchange Server 2013 ou Exchange Server 2016 afin qu’aucun dossier public ne puisse être créé par les utilisateurs tant que la migration n’est pas terminée.
La commande Exchange PowerShell suivante est un exemple de sortie qui peut être utilisée pour vérifier que la première boîte aux lettres de dossier public est créée avec le HoldForMigration paramètre :

[PS] C:\>(Get-OrganizationConfig).RootPublicFolderMailbox
IsValid : True
CanUpdate : True
HierarchyMailboxGuid : dba08a32-d51f-4c21-ae31-8f7d678ccfb1
HierarchySmtpAddress :
LockedForMigration : True

La valeur True du champ LockedForMigration indique que la hiérarchie des dossiers publics est verrouillée.

Cause

Ce problème se produit car le HoldForMigration paramètre est spécifié lorsque vous créez la première boîte aux lettres de dossiers publics. Ce comportement est inhérent au produit.

Résolution

Si vous avez créé la première boîte aux lettres de dossiers publics avec le HoldForMigration paramètre pour la migration des dossiers publics hérités, terminez la migration. Pour plus d’informations sur l’utilisation du paramètre pour la HoldForMigration migration de dossiers publics, consultez Comment migrer des dossiers publics de Exchange Server 2010 SP3 vers Microsoft Exchange Server 2013.

Si vous n’avez pas de dossiers publics hérités dans le organization et que vous avez créé accidentellement la première boîte aux lettres de dossiers publics avec le HoldForMigration paramètre , vous devez supprimer toutes les boîtes aux lettres de dossiers publics présentes dans le organization. Ensuite, vous devez créer une boîte aux lettres de dossiers publics sans spécifier le HoldForMigration paramètre . Pour ce faire, utilisez l’une de ces méthodes.

Méthode 1 : Supprimer la boîte aux lettres de dossiers publics à l’aide du Centre d’administration Exchange

  1. Accédez au site web Microsoft suivant pour ouvrir le centre d’administration Exchange : Https://CASServerName/ecp.
  2. Connectez-vous au CAE à l’aide du compte d’administrateur.
  3. Sélectionnez Dossiers publics, puis boîtes aux lettres de dossiers publics.
  4. Supprimez toutes les boîtes aux lettres de dossiers publics du type Hiérarchie secondaire .
  5. Supprimez la boîte aux lettres de dossiers publics du type Hiérarchie primaire .
  6. Sélectionnez l’icône Nouvelle boîte aux lettres de dossier public pour créer une boîte aux lettres de dossiers publics.
  7. La nouvelle boîte aux lettres s’affiche sous la forme d’une boîte aux lettres de hiérarchie principale.

Méthode 2 : Supprimer la boîte aux lettres de dossiers publics à l’aide d’EMS

  1. Exécutez l’applet de commande suivante pour retourner et supprimer les boîtes aux lettres de dossiers publics du type hiérarchie secondaire :

    Get-Mailbox -PublicFolder | where {$_.IsRootPublicFolderMailbox -eq $False} | Remove-Mailbox -PublicFolder
    
  2. Exécutez l’applet de commande suivante pour retourner et supprimer la boîte aux lettres de dossiers publics du type hiérarchie principale :

    Get-Mailbox -PublicFolder | where {$_.IsRootPublicFolderMailbox -eq $true} | Remove-Mailbox -PublicFolder
    
  3. Créez une boîte aux lettres de dossiers publics sans spécifier le HoldForMigration paramètre en exécutant l’applet de commande suivante :

    New-Mailbox -PublicFolder -Database "Mailbox Database Name" -Name "Public Folder Mailbox Name"
    

Informations supplémentaires

Pour plus d’informations sur la suppression de dossiers publics dans un environnement Exchange Server 2013, consultez Comment supprimer des dossiers publics.

Pour plus d’informations sur le HoldForMigration paramètre, consultez Informations générales sur l’applet de commande New-Mailbox avec le paramètre HoldForMigration.