Erreur « Impossible de supprimer ce domaine » lorsque vous essayez de supprimer un domaine à partir d'Office 365

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Sommaire

PROBLÈME

Lorsque vous essayez de supprimer un domaine de Microsoft Office 365 à l'aide de Windows PowerShell, youget le message d'erreur suivant :
Supprimer-MsolDomain : Impossible de supprimer ce domaine. Utiliser Get-MsolUser - DomainNamenom de domaine> pour récupérer une liste d'objets qui bloquent suppression.
À la ligne: 1 char : 18
+ Supprimer-MsolDomain< -domainname=""><DomainName></DomainName>
+ CategoryInfo : OperationStopped: (:) [Supprimer-MsolDomain], MicrosoftOnlineException
+ FullyQualifiedErrorId : Microsoft.Online.Administration.Automation.DomainNotEmptyException,Microsoft.Online.Administration.Automation.RemoveDomain

CAUSE

Ce problème se produit si une ou plusieurs des conditions suivantes sont remplies :
  • Comptes d'utilisateurs ou de groupes sont associés avec le domaine.
  • Les serveurs proxy qui correspondent au domaine pour tous les utilisateurs sous licence de courrier et pour tous les groupes à extension messagerie ne sont pas supprimés. Office 365 bloque la suppression d'un domaine jusqu'à ce que les serveurs proxy qui correspondent au domaine sont supprimés.
  • Adresses de Lync Online Session Initiation Protocol (SIP) sont utilisées par le domaine.

SOLUTION

Utilisez le centre d'administration Office 365 pour supprimer le domaine. Le Gestionnaire de domaine dans Office 365 aidera les administrateurs de supprimer toutes les dépendances qui empêchent la suppression du domaine sans avoir à utiliser Windows PowerShell.

Pour plus d'informations sur la façon de supprimer un domaine dans le centre d'administration Office 365, accédez au Supprimer un domaine.

Résoudre les problèmes de suppression du domaine à l'aide de Windows PowerShell

Notez que la procédure suivante nécessite que les administrateurs d'utiliser Windows PowerShell.

Étape 1: Vérifier si les noms d'utilisateur contiennent le nom de domaine

Remarque : Vous pouvez également créer une vue de l'utilisateur et puis définissez le domaine sur le domaine que vous essayez de supprimer. Utilisez cette vue pour noter les noms d'utilisateur et modifiez les noms d'utilisateur pour que le domaine en question ne fait pas partie du nom d'utilisateur.

Pour vérifier si les noms d'utilisateur contiennent le nom de domaine, procédez comme suit :
  1. Se connecter à Active Directory de Windows Azure à l'aide du Windows Azure Active Directory Module pour Windows PowerShell. Pour ce faire, ouvrir le Windows Azure Active Directory Modules de Windows PowerShell, tapez l'applet de commande suivante et appuyez sur ENTRÉE.
    Connect-MsolService
    Entrez vos informations d'identification d'administration lorsque vous êtes invité à les installer.

    Pour plus d'informations sur la façon de se connecter à Active Directory de Windows Azure, accédez à Se connecter à Active Directory de Windows Azure.
  2. Exécutez l'applet de commande suivante :
    Get-MsolUser -DomainName [Domain] | fl UserPrincipalName
    Par exemple, exécutez ce qui suit, où l'espace réservé de contoso.com représente le domaine en question :
    Get-MsolUser -DomainName contoso.com | fl UserPrincipalName
  3. Examiner les résultats et modifiez le nom d'utilisateur principal (UPN) afin que le domaine n'est pas utilisé. L'UPN est le même que le nom d'utilisateur et la propriété d'ID utilisateur. Vous pouvez utiliser le portail Office 365 ou Windows PowerShell pour modifier l'UPN. L'objectif est de n'avoir aucun résultats renvoyés.
  4. Effectuez l'une des opérations suivantes :
    • Si vous avez Exchange Online et la sortie continue d'afficher une liste des utilisateurs et l'UPN ne contient pas le nom de domaine, passez à l'étape 2.
    • Si vous ne le faites pas avoir Exchange Online et la sortie continue d'afficher une liste des utilisateurs et l'UPN ne contient pas le nom de domaine, passez à l'étape 3.

Étape 2: Adresses de courriel à cocher

Remarque : Cette étape s'applique uniquement si vous avez un abonnement qui inclut Exchange Online.

Remarque : Si vous exécutez l'outil de synchronisation d'annuaire actif Windows Azure, vous pouvez mettre à jour les adresses e-mail à partir de l'environnement local.

Pour vérifier les adresses de messagerie, procédez comme suit :
  1. Se connecter à Exchange Online à l'aide du PowerShell distant. Pour plus d'informations sur la procédure à suivre, consultez le site Web Microsoft suivant :
    Se connecter à Exchange Online à l'aide de PowerShell distant
  2. Rechercher tous les utilisateurs et les groupes qui utilisent le domaine que vous essayez de supprimer. Pour ce faire, exécutez l'applet de commande suivante. (Dans cette applet de commande, contoso.com représente le domaine en question).
    get-recipient | where {$_.EmailAddresses -match "contoso.com"} | fl Name, RecipientType, EmailAddresses
  3. Dans la sortie, notez la valeur de la propriété EmailAddresses et la propriété RecipientType . Par exemple, la sortie peut ressembler au suivant
    Name : John Smith RecipientType : UserMailbox EmailAddresses : {SIP:john@contoso.com, SMTP:john@contoso.com, smtp:john@contoso.onmicrosoft.com}
  4. Effectuez l'une des valeurs suivantes, selon votre situation :
    • Si la valeur RecipientTypeUserMailbox, vous pouvez utiliser la cmdlet Set-Mailbox avec le paramètre EmailAddresses pour modifier le protocole smtp, SMTP et SIP adresses. Pour en savoir plus sur cette applet de commande, accédez au site Web de Microsoft suivant :
      Set-Mailbox
      Ou bien, vous pouvez supprimer l'utilisateur ou la licence. Toutefois, nous ne recommandons cette opération.

      Remarque : Si c'est le dernier utilisateur de l'administrateur, créer un nouvel administrateur global, connectez-vous et puis supprimez l'utilisateur du problème.
    • Si RecipientType est défini sur MailUniversalDistributionGroup ou MailUniversalSecurityGroup, vous pouvez utiliser la cmdlet Set-groupe de distribution avec le paramètre EmailAddresses pour modifier les adresses SMTP smtp. Pour en savoir plus sur cette applet de commande, accédez au site Web de Microsoft suivant :
      Groupe de Distribution de jeu
      Ou bien, vous pouvez supprimer le groupe. Toutefois, nous ne recommandons cette opération. Si vous ne pouvez pas supprimer le groupe, suivez les étapes décrites dans l'article suivant de la Base de connaissances Microsoft :
      2731947 « Vous ne disposez des autorisations nécessaires » erreur lorsque vous essayez de supprimer ou d'apporter une modification à un groupe de distribution dans Office 365 »
    • Si le RecipientType est définie sur DynamicDistributionGroup, vous pouvez utiliser le Jeu-DynamicDistributionGrouptraite de l'applet de commande avec le paramètre EmailAddresses pour modifier les smtp et SMTP. Pour en savoir plus sur cette applet de commande, accédez au site Web de Microsoft suivant :
      Set-DynamicDistributionGroup
      Ou bien, vous pouvez supprimer le groupe. Toutefois, nous ne recommandons cette opération. Si vous ne pouvez pas supprimer le groupe, suivez les étapes décrites dans l'article suivant de la Base de connaissances Microsoft :
      2731947 « Vous ne disposez des autorisations nécessaires » erreur lorsque vous essayez de supprimer ou d'apporter une modification à un groupe de distribution dans Office 365 »

PLUS D'INFORMATIONS

Pour plus d'informations, consultez l'article suivant de la Base de connaissances Microsoft :
2284755 Vous obtenez un message d'erreur lorsque vous essayez de supprimer un domaine à partir d'Office 365
Besoin d'aide ? Accédez à la Communauté Office 365 (site Web).

Propriétés

Numéro d'article: 2787210 - Dernière mise à jour: vendredi 4 avril 2014 - Version: 15.0
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Office 365
  • Microsoft Office 365 for enterprises (pre-upgrade)
  • Microsoft Office 365 for education  (pre-upgrade)
  • Microsoft Office 365 for small businesses  (pre-upgrade)
Mots-clés : 
o365 o365e o365p o365a o365022013 after upgrade o365062011 pre-upgrade o365m kbmt KB2787210 KbMtfr
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