Errore "Impossibile rimuovere questo dominio" quando si tenta di rimuovere un dominio da Office 365

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PROBLEMA

Quando si tenta di rimuovere un dominio di Microsoft Office 365 con Windows PowerShell, youget il seguente messaggio di errore:
Rimuovi-MsolDomain: Impossibile rimuovere questo dominio. Utilizzare Get-MsolUser - DomainNamenome di dominio> per recuperare un elenco di oggetti che bloccano la rimozione.
In linea: 1 char: 18
+ Remove-MsolDomain< -domainname=""><DomainName></DomainName>
+ CategoryInfo: OperationStopped: (:) [Remove-MsolDomain] MicrosoftOnlineException
+ FullyQualifiedErrorId: Microsoft.Online.Administration.Automation.DomainNotEmptyException,Microsoft.Online.Administration.Automation.RemoveDomain

CAUSA

Questo problema si verifica se uno o pi¨ delle seguenti condizioni sono vere:
  • Account utente o gruppi associati al dominio.
  • I proxy che corrispondono al dominio per tutti gli utenti con licenza della posta e per tutti i gruppi abilitati alla posta elettronica non vengono rimossi. Office 365 blocca l'eliminazione di un dominio fino a quando non vengono rimossi i proxy che corrispondono al dominio.
  • Gli indirizzi di Lync Online protocollo SIP (Session Initiation) vengono utilizzati dal dominio.

SOLUZIONE

Utilizzare il centro di amministrazione di Office 365 per rimuovere il dominio. Il gestore del dominio in Office 365 consentirÓ admins di rimuovere eventuali dipendenze che bloccano la rimozione del dominio senza dover utilizzare Windows PowerShell.

Per ulteriori informazioni su come rimuovere un dominio nel centro di amministrazione di Office 365, Vai a Rimuovere un dominio.

Risoluzione dei problemi di rimozione del dominio utilizzando Windows PowerShell

Si noti che le operazioni seguenti richiedono agli amministratori di utilizzare Windows PowerShell.

Passaggio 1: Verificare se i nomi utente contengono il nome di dominio

Nota. ╚ possibile inoltre creare una vista dell'utente e quindi impostare il dominio al dominio che si sta tentando di rimuovere. Utilizzare questa visualizzazione per osservare i nomi utente e quindi modificare i nomi utente in modo che il dominio in questione non fa parte del nome utente.

Per verificare se i nomi utente contengono il nome di dominio, attenersi alla seguente procedura:
  1. Connettersi a Windows Azure Active Directory utilizzando il Windows Azure Active Directory Module per Windows PowerShell. A tale scopo, aprire il Windows Azure Active Directory moduli per Windows PowerShell, digitare il seguente cmdlet e quindi premere INVIO.
    Connect-MsolService
    Immettere le credenziali di amministratore quando viene richiesto per loro.

    Per ulteriori informazioni su come connettersi a Windows Azure Active Directory, visitare il Connessione a Active Directory di Windows Azure.
  2. Eseguire il seguente cmdlet:
    Get-MsolUser -DomainName [Domain] | fl UserPrincipalName
    Ad esempio, eseguire il comando seguente, dove il segnaposto contoso.com rappresenta il dominio in questione:
    Get-MsolUser -DomainName contoso.com | fl UserPrincipalName
  3. Esaminare i risultati e quindi modificare il nome principale utente (UPN) in modo che il dominio non Ŕ utilizzato. L'UPN Ŕ lo stesso, come il nome utente e la proprietÓ ID dell'utente. ╚ possibile utilizzare il portale di Office 365 o di Windows PowerShell per modificare il nome principale utente. L'obiettivo Ŕ non stato restituito alcun risultato.
  4. Effettuare una delle seguenti operazioni:
    • Se si utilizza Exchange Online e l'output continua a mostrare un elenco di utenti e l'UPN non contiene il nome di dominio, andare al passaggio 2.
    • In questo caso non sono in linea di Exchange e l'output continua a mostrare un elenco di utenti e l'UPN non contiene il nome di dominio, andare al passaggio 3.

Passaggio 2: Indirizzi di posta elettronica di controllo

Nota. Questo passaggio si applica solo se si dispone di una sottoscrizione che include Exchange Online.

Nota. Se si esegue lo strumento di sincronizzazione di Active Directory di Windows Azure, Ŕ possibile aggiornare gli indirizzi di posta elettronica dall'ambiente locale.

Per verificare gli indirizzi di posta elettronica, attenersi alla seguente procedura:
  1. Connettersi a Exchange Online tramite PowerShell remoto. Per ulteriori informazioni su come eseguire questa operazione, visitare il seguente sito Web Microsoft:
    Connettersi a Exchange Online tramite PowerShell remoto
  2. Trovare tutti gli utenti e gruppi che utilizzano il dominio che si sta tentando di rimuovere. A tale scopo, eseguire il seguente cmdlet. (In questo cmdlet contoso.com rappresenta il dominio in questione).
    get-recipient | where {$_.EmailAddresses -match "contoso.com"} | fl Name, RecipientType, EmailAddresses
  3. Nell'output, prendere nota del valore della proprietÓ EmailAddresses e la proprietÓ RecipientType . Ad esempio, l'output analoghe alle seguenti
    Name : John Smith RecipientType : UserMailbox EmailAddresses : {SIP:john@contoso.com, SMTP:john@contoso.com, smtp:john@contoso.onmicrosoft.com}
  4. Effettuare una delle seguenti, a seconda della situazione:
    • Se RecipientType Ŕ impostato su UserMailbox, Ŕ possibile utilizzare il cmdlet Set-Mailbox con il parametro EmailAddresses per modificare il protocollo smtp, SMTP e gli indirizzi di SIP. Per ulteriori informazioni su questo cmdlet, vedere il seguente sito Web Microsoft:
      Set-Mailbox
      In alternativa, Ŕ possibile rimuovere l'utente o una licenza. Tuttavia, non Ŕ consigliabile eseguire questa operazione.

      Nota. Se si tratta dell'ultimo utente administrator, creare un nuovo amministratore globale, l'accesso e quindi rimuovere l'utente in questione.
    • Se RecipientType Ŕ impostato su MailUniversalDistributionGroup o MailUniversalSecurityGroup, Ŕ possibile utilizzare il cmdlet Set-DistributionGroup con il parametro EmailAddresses per modificare il smtp e gli indirizzi SMTP. Per ulteriori informazioni su questo cmdlet, vedere il seguente sito Web Microsoft:
      Gruppo di distribuzione insieme
      In alternativa, Ŕ possibile rimuovere il gruppo. Tuttavia, non Ŕ consigliabile eseguire questa operazione. Se non Ŕ possibile rimuovere il gruppo, attenersi alla procedura nel seguente articolo della Microsoft Knowledge Base:
      2731947 Errore "Non si dispone delle autorizzazioni sufficienti" quando si tenta di rimuovere o apportare una modifica a un gruppo di distribuzione di Office 365 "
    • Se il RecipientType Ŕ impostata su DynamicDistributionGroup, Ŕ possibile utilizzare il Set-DynamicDistributionGrouprisolve cmdlet con il parametro EmailAddresses per modificare il smtp e SMTP. Per ulteriori informazioni su questo cmdlet, vedere il seguente sito Web Microsoft:
      Set-DynamicDistributionGroup
      In alternativa, Ŕ possibile rimuovere il gruppo. Tuttavia, non Ŕ consigliabile eseguire questa operazione. Se non Ŕ possibile rimuovere il gruppo, attenersi alla procedura nel seguente articolo della Microsoft Knowledge Base:
      2731947 Errore "Non si dispone delle autorizzazioni sufficienti" quando si tenta di rimuovere o apportare una modifica a un gruppo di distribuzione di Office 365 "

ULTERIORI INFORMAZIONI

Per ulteriori informazioni, vedere il seguente articolo della Microsoft Knowledge Base:
2284755 Viene visualizzato un messaggio di errore quando si tenta di rimuovere un dominio da Office 365
Ulteriore assistenza? Vai al Community di Office 365 .

ProprietÓ

Identificativo articolo: 2787210 - Ultima modifica: venerdý 4 aprile 2014 - Revisione: 14.0
Le informazioni in questo articolo si applicano a:
  • Microsoft Office 365
  • Microsoft Office 365 for enterprises (pre-upgrade)
  • Microsoft Office 365 for educationá (pre-upgrade)
  • Microsoft Office 365 for small businessesá (pre-upgrade)
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