"Nie je možné odstrániť túto doménu" chyba pri pokuse odstrániť domény z Office 365

Preklady článku Preklady článku
ID článku: 2787210 - Zobraziť produkty, ktorých sa tento článok týka.
Rozbaliť všetko | Zbaliť všetko

Na tejto stránke

PROBLÉM

Pri pokuse odstrániť domény z Microsoft Office 365 pomocou prostredia Windows PowerShell, youget nasledovné chybové hlásenie:
Odstrániť-MsolDomain: Nepodarilo sa odstrániť túto doménu. Použiť Get-MsolUser - DomainNamedoménové meno> načítať zoznam objektov, ktoré sú blokuje odstránenie.
V riadku: 1 char: 18
+ Odstrániť-MsolDomain< -domainname=""><DomainName></DomainName>
+ CategoryInfo: OperationStopped: (:) [Odstrániť-MsolDomain], MicrosoftOnlineException
+ FullyQualifiedErrorId: Microsoft.Online.Administration.Automation.DomainNotEmptyException,Microsoft.Online.Administration.Automation.RemoveDomain

PRÍČINA

Tento problém sa vyskytuje, ak jeden alebo viac z nasledujúcich podmienok sú pravdivé:
  • Používateľské kontá a skupiny sú spojené s doménou.
  • Proxy servery, ktoré zodpovedajú doméne pre všetkých používateľov pošty-licencované a všetky poštové skupiny nie sú odstránené. Úrad 365 blokuje odstránenie domény až proxy servery, ktoré zodpovedajú domény sú odstránené.
  • Lync Online Session Initiation Protocol (SIP) adresy sú používané pre doménu.

RIEŠENIE

Office 365 admin centrum sa používa na odstránenie oblasti. Správcovi domény Office 365 pomôže admins odstrániť akékoľvek závislostí, ktoré blokujú doménových odstránení bez nutnosti použiť prostredie Windows PowerShell.

Pre viac informácií o tom, ako odstrániť domény Office 365 admin Center, prejdite na Odstránenie domény.

Riešenie doménových odstránení pomocou prostredia Windows PowerShell

Upozorňujeme, že tieto kroky vyžadovať správcovia použiť prostredie Windows PowerShell.

Krok 1: Skontrolujte, či užívateľské mená obsahujú názov domény

Poznámka: Môžete tiež vytvoriť zobrazenie používateľa a potom nastaviť doménu pre domény, ktoré sa snažíte odstrániť. Toto zobrazenie slúži na vedomie, mená používateľov, a potom zmeňte mená používateľov tak, že v doméne nie je súčasťou meno používateľa.

Skontrolujte, či užívateľské mená obsahujú názov domény, postupujte nasledovne:
  1. Pripojiť k Microsoft Azure služby Active Directory pomocou Azure Active Directory modul pre Windows PowerShell. Na tento účel otvorte Azure Active Directory moduly pre prostredie Windows PowerShell zadajte nasledovné cmdlet a stlačte kláves Enter.
    Connect-MsolService
    Keď sa zobrazí výzva, zadajte poverenia admin.

    Pre viac informácií o tom, ako sa pripojiť k azúrovo reklamy, prejdite naPripojiť k azúrovo reklamy.
  2. Spustiť nasledovné cmdlet:
    Get-MsolUser -DomainName [Domain] | fl UserPrincipalName
    Napríklad, spustite nasledujúce, kde contoso.com zástupný symbol predstavuje doménu:
    Get-MsolUser -DomainName contoso.com | fl UserPrincipalName
  3. Preskúmať výsledky, a potom zmeniť hlavné meno používateľa (UPN) tak, že doména sa nepoužíva. UPN je rovnaké ako meno používateľa a vlastnosť ID používateľa. V Office 365 portál alebo prostredia Windows PowerShell môžete použiť zmeniť UPN. Cieľom je mať vrátené žiadne výsledky.

Krok 2: Kontrola e-mailových adries

Poznámka: Tento krok sa vzťahuje len vtedy, ak máte predplatené služby, ktoré zahŕňajú Exchange Online.

Poznámka: Ak máte spustenú Azure aktívny adresár synchronizácia nástroj, môžete aktualizovať e-mailové adresy z lokálneho prostredia.

Ak chcete skontrolovať e-mailovej adresy, postupujte nasledovne:
  1. Pripojenie k službe Exchange Online pomocou vzdialeného PowerShell. Ďalšie informácie o tom, ako to urobiť, nájdete na nasledujúcej webovej lokalite spoločnosti Microsoft:
    Pripojiť na Exchange Online pomocou vzdialeného PowerShell
  2. Nájsť všetkých používateľov a skupiny, ktoré používajú domény, ktoré sa snažíte odstrániť. Vykonáte to spustiť nasledovné cmdlet. (V tejto rutiny typu cmdlet, contoso.com predstavuje doménu).
    get-recipient | where {$_.EmailAddresses -match "contoso.com"} | fl Name, RecipientType, EmailAddresses
  3. Vo výstupe, sa zapíše hodnota EmailAddresses nehnuteľnosti a RecipientType majetku. Napríklad, môže výstup podobný nasledujúcemu
    Name : John Smith RecipientType : UserMailbox EmailAddresses : {SIP:john@contoso.com, SMTP:john@contoso.com, smtp:john@contoso.onmicrosoft.com}
  4. Vykonajte jeden z nasledovných údajov, ako je vhodné pre vašu situáciu:
    • Ak RecipientType je nastavená na UserMailbox, môžete použiť rutinu cmdlet Set-Mailbox s parametrom EmailAddresses zmeniť smtp, SMTP, a SIP adresy. Sa dozvedieť viac o tejto rutiny typu cmdlet, nájdete na nasledujúcej webovej lokalite spoločnosti Microsoft:
      Súbor schránky
      Alebo môžete odstrániť používateľa alebo licenciu. Avšak, čo neodporúčame to.

      Poznámka: Ak je to posledný používateľ administrátor, vytvoriť nový globálny správca, prihláste sa a potom odstrániť problém užívateľa.
    • Ak RecipientType je nastavená na MailUniversalDistributionGroup alebo MailUniversalSecurityGroup, môžete použiť rutinu cmdlet Set-DistributionGroup spolu s EmailAddresses parameter zmeniť smtp a adresy SMTP. Sa dozvedieť viac o tejto rutiny typu cmdlet, nájdete na nasledujúcej webovej lokalite spoločnosti Microsoft:
      Sada-distribučná skupina
      Alebo môžete odstrániť skupine. Avšak, čo neodporúčame to. Ak nemôžete odstrániť skupinu, postupujte podľa krokov v nasledujúcom článku databázy Microsoft Knowledge Base:
      2731947 "Nemáte dostatočné oprávnenia" chyba pri pokuse o odstránenie alebo zmenu distribučnej skupine v Office 365 "
    • Ak RecipientType je nastavená na DynamicDistributionGroup, môžete použiť Set-DynamicDistributionGroupcmdlet s parameter EmailAddresses zmeniť smtp a SMTP adresy. Sa dozvedieť viac o tejto rutiny typu cmdlet, nájdete na nasledujúcej webovej lokalite spoločnosti Microsoft:
      Set-DynamicDistributionGroup
      Alebo môžete odstrániť skupine. Avšak, čo neodporúčame to. Ak nemôžete odstrániť skupinu, postupujte podľa krokov v nasledujúcom článku databázy Microsoft Knowledge Base:
      2731947 "Nemáte dostatočné oprávnenia" chyba pri pokuse o odstránenie alebo zmenu distribučnej skupine v Office 365 "

ĎALŠIE INFORMÁCIE

Pre viac informácie, pozri nasledujúci článok Microsoft Knowledge Base:
2284755 Dostanete chybové hlásenie pri pokuse odstrániť domény z Office 365
Potrebujete ešte pomoc? Prejdite na Komunita používateľov balíka Office 365 .

Vlastnosti

ID článku: 2787210 - Posledná kontrola: 20. júna 2014 - Revízia: 15.0
Informácie v tomto článku sa týkajú nasledujúcich produktov:
  • Microsoft Office 365
  • Microsoft Office 365 for enterprises (pre-upgrade)
  • Microsoft Office 365 for education  (pre-upgrade)
  • Microsoft Office 365 for small businesses  (pre-upgrade)
  • Office 365 User and Domain Management
Kľúčové slová: 
o365 o365e o365p o365a o365022013 after upgrade o365062011 pre-upgrade o365m kbmt KB2787210 KbMtsk
Strojovo preložené
DÔLEŽITÉ: Tento článok je preložený pomocou softvéru na strojový preklad od spoločnosti Microsoft a možno ho opraviť prostredníctvom technológie Community Translation Framework (CTF). Microsoft ponúka strojovo preložené články, články upravené komunitou aj články preložené prekladateľmi, aby zabezpečil prístup ku všetkým článkom databázy Knowledge Base vo viacerých jazykoch. Strojovo preložené články aj upravené články môžu obsahovať chyby týkajúce sa slovnej zásoby, syntaxe alebo gramatiky. Microsoft nenesie zodpovednosť za akékoľvek nepresnosti, chyby alebo škody spôsobené neprávnym prekladom obsahu alebo jeho použitím zo strany našich zákazníkov. Ďalšie informácie o technológii CTF nájdete na lokalite http://support.microsoft.com/gp/machine-translation-corrections/sk.
Pokiaľ chcete vidieť anglickú verziu článku, kliknite sem: 2787210

Odošlite odozvu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com