Impossibile spostare o accedere alla cassetta postale di una risorsa di Exchange

Traduzione articoli Traduzione articoli
Identificativo articolo: 278966 - Visualizza i prodotti a cui si riferisce l?articolo.
Espandi tutto | Chiudi tutto

Sintomi

Quando si sposta una cassetta postale da un computer con Microsoft Exchange Server 5.5 a un computer con Microsoft Exchange 2000 o Microsoft Exchange Server 2003, Ŕ possibile che venga visualizzato il seguente messaggio di errore:
Errore: Apertura della cassetta postale di destinazione in corso.
CN=DDD R1,OU=Recipients,DC=dune,DC=com:
Impossibile aprire l'archivio informazioni.
Errore del provider MAPI.
MAPI 1.0
ID: 8004011d-0289-00000000
Inoltre, Ŕ possibile che nel registro eventi applicazioni vengano registrati messaggi di ID evento analoghi ai seguenti:
Tipo evento: Informazione
Origine evento: MSExchangeAdmin
Categoria evento: Spostamento cassetta postale
ID evento: 1006
Data: 11/3/2000
Ora: 16:24:53
Utente: N/D
Computer: ALIA
Descrizione:
Avvio spostamento della cassetta postale "DDD R1".
Database di origine: /o=Microsoft/ou=AdminGroup/cn=Configuration/cn=Servers/cn=SERVER1/cn=Microsoft Private MDB
Database di destinazione:
/o=Microsoft/ou=AdminGroup/cn=Configuration/cn=Servers/cn=SERVER2/cn=Microsoft Private MDB
DN in Exchange: /o=Microsoft/ou=AdminGroup/cn=Recipients/cn=Alias
Tipo evento: Avviso
Origine evento: MSExchangeIS
Categoria evento: Generale
ID evento: 9548
Data: 11/3/2000
Ora: 16.24.54
Utente: N/D
Computer: ALIA
Descrizione:
L'utente disabilitato /o=Microsoft/ou=AdminGroup/cn=Recipients/cn=Alias non dispone di un identificatore di protezione (SID, Security Identifier) di account principale. Utilizzare l'MMC di Active Directory per impostare un account attivo come account principale di questo utente.
Tipo evento: Errore
Origine evento: MSExchangeIS Mailbox Store
Categoria evento: Accessi
ID evento: 1022
Data: 11/3/2000
Ora: 16.24.55
Utente: N/D
Computer: ALIA
Descrizione:
Accesso non riuscito sul database "First Storage Group\Private Information Store (ALIA)": account di Windows 2000 account DOMAIN\administrator, cassetta postale /o=Microsoft/ou=AdminGroup/cn=Recipients/cn=ALIAS. Errore: -2147221231
Il messaggio di errore con ID 0x8004011d fa riferimento a MAPI_E_FAILONEPROVIDER. Gli eventi di errore con ID 0x80040111 e -2147221231 corrispondono a MAPI_E_LOGON_FAILED.

Una sequenza di errori analoga pu˛ essere visualizzata quando si tenta di accedere a una cassetta postale in un computer con Exchange 2000 o Exchange 2003.

Cause

Questo problema pu˛ verificarsi se l'account utente del servizio directory Active Directory disabilitato associato alla cassetta postale non dispone di un attributo msExchMasterAccountSID.

Workaround

Le procedure indicate in questa sezione consentono di disabilitare gli account utente di Active Directory che dispongono di cassette postali di Exchange 2000 o Exchange 2003. Se si segue questa procedura quando si disattiva l'account, l'evento 9548 non viene registrato. Se il problema si verifica solo su un numero limitato di cassette postali, Ŕ possibile creare un attributo msExchMasterAccountSID. Per effettuare questa operazione, attenersi alla seguente procedura:
  1. Nello snap-in Utenti e computer di Active Directory, scegliere Caratteristiche avanzate dal menu Visualizza.
  2. Nelle proprietÓ avanzate di Exchange relative all'oggetto utente disabilitato proprietario della cassetta postale, fare clic su Autorizzazioni cassetta postale, quindi nell'elenco di account cercare un utente che disponga dell'autorizzazione Account esterno associato.
  3. Se tale autorizzazione non Ŕ associata ad alcun account, concedere le autorizzazioni Account esterno associato e Accesso completo alle cassette postali all'account SELF.

    Nota: l'account SELF Ŕ disponibile in tutti i domini di Windows 2000. Tutti gli account SELF condividono un identificatore SID (Security Identifier) noto, che Ŕ identico in tutti i domini. Se l'account SELF non Ŕ presente nell'elenco nella finestra di dialogo Autorizzazioni, Ŕ possibile aggiungerlo digitando SELF come nome dell'account.

    L'autorizzazione Account esterno associato non pu˛ essere concessa a pi¨ account contemporaneamente. Se questa autorizzazione Ŕ associata a un account non desiderato o non valido, dovrÓ essere rimossa da tale account prima di applicarla a SELF.

    Dopo avere eliminato l'autorizzazione Account esterno associato da un account, chiudere tutte le finestre di proprietÓ relative all'oggetto utente disabilitato. A questo scopo, scegliere OK, non Annulla, ad ogni livello. Questa operazione Ŕ necessaria perchÚ le modifiche alle autorizzazioni non vengono applicate immediatamente ma solo dopo la chiusura delle proprietÓ dell'oggetto utente. Il proprietario dell'autorizzazione Account esterno associato potrÓ essere modificato solo dopo avere chiuso e riaperto le proprietÓ dell'oggetto.
  4. Reimpostare l'autorizzazione Account esterno associato su SELF.
Per visualizzare gli attributi dell'oggetto utente e assicurarsi che sia stato creato l'attributo msExchMasterAccountSID, Ŕ possibile utilizzare strumenti LDAP quali lo snap-in Modifica ADSI (Active Directory Service Interfaces), l'utilitÓ LDP o Ldifde. Dati gli intervalli di latenza per la replica di directory e l'aggiornamento della cache di Exchange Server, pu˛ essere necessario attendere fino a due ore dalla modifica prima di poter spostare la cassetta postale.

Per impostare l'attributo msExchMasterAccountSID per un numero elevato di account utente disabilitati, Ŕ possibile utilizzare l'interfaccia Microsoft CDO per la gestione di Exchange (CDOEXM) per modificare il descrittore di protezione della cassetta postale. Mediante l'avvio di Service Pack 2 (SP2) per Exchange 2000 Server, Ŕ disponibile una nuova interfaccia in CDOEXM. Questa interfaccia Ŕ denominata MailboxRights. Questa esposizione consente di modificare il descrittore di protezione della cassetta postale a livello di programmazione.

Per ulteriori informazioni su come inserire una modifica collettiva dell'attributo msExchMasterAccountSid nello script, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
322890 Associazione di un account esterno a cassette postali di Exchange 2000 esistenti
Per ulteriori metodi che consentano l'impostazione dell'attributo msExchMasterAccountSid per un numero elevato di account utente disabilitati, contattare il Servizio Supporto Tecnico Clienti Microsoft. Per ulteriori informazioni sulle opzioni di supporto disponibili da Microsoft, visitare il seguente sito Web Microsoft:
http://support.microsoft.com/default.aspx?scid=fh;IT;CNTACTMS
Per determinare il numero di utenti disabilitati che non dispongono dell'attributo msExchMasterAccountSid Ŕ possibile generare un file di esportazione in formato LDIF. Per effettuare questa operazione, eseguire il seguente il comando di Ldifde.exe:
ldifde -f file.txt -d "dc=domain,dc=com" -l nothing -r "(&(objectcategory=person)(objectclass=user)(msexchuseraccountcontrol=2)(!(msexchmasteraccountsid=*)))"
Nell'elenco riportato di seguito sono descritti i parametri di Ldifde:
  • -f: Questo parametro indica il file di destinazione dell'esportazione.
  • -d: Questo parametro indica il dominio di Microsoft Windows da cui esportare gli oggetti utente. Ad esempio, se la console di gestione Utenti e computer di Active Directory per il dominio riportasse il dominio comecorp.company.com, questo diventerebbe "dc=corp,dc=company,dc=com".
  • -l: Quando questo parametro Ŕ utilizzato, nel file di esportazione vengono inseriti solo gli attributi enumerati. In questo caso Ŕ utilizzato l'attributo nothing, che indica l'inesistenza, affinchÚ vengano generati solo nomi di oggetti e non attributi.
  • -r: Questo parametro indica il filtro di ricerca LDAP utilizzando la sintassi standard per le query di LDAP. Questa stringa di ricerca pu˛ essere utilizzata anche con Ldp.exe e altri strumenti LDAP. In questo caso, la ricerca riguarda tutti gli oggetti utente disabilitati (valore 2 di msExchMasterAccountControl) e privi dell'attributo msExchMasterAccountSID.
Il testo riportato di seguito Ŕ un esempio di file di output:
dn: CN=AAA R1,OU=Recipients,DC=domain,DC=com
changetype: add
 
dn: CN=AAA R2,OU=Recipients,DC=domain,DC=com
changetype: add

. . . . .
				
Per ulteriori informazioni su come utilizzare Ldifde in Active Directory, fare clic sul numero dell'articolo della Knowledge Base riportato di seguito:
237677 Utilizzo di LDIFDE per importare/esportare oggetti directory in Active Directory
Nota: si sconsiglia l'utilizzo dell'utilitÓ della riga di comando LDIFDE oppure dello strumento ADSIEDIT per creare, modificare oppure eliminare l'attributo msExchMasterAccountSid.

Status

Microsoft ha confermato che questo problema si verifica con i prodotti elencati nella sezione "Le informazioni in questo articolo si applicano a".

ProprietÓ

Identificativo articolo: 278966 - Ultima modifica: lunedý 26 novembre 2007 - Revisione: 4.2
Le informazioni in questo articolo si applicano a
  • Microsoft Exchange 2000 Server Standard Edition
  • Microsoft Exchange Server 2003 Enterprise Edition
  • Microsoft Exchange Server 2003 Standard Edition
Chiavi:á
kberrmsg kbbug kbpending KB278966
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com