The Distributed Link Tracking Server service may cause extra DNS queries in Windows 2000 Server

Article translations Article translations
Article ID: 279117 - View products that this article applies to.
This article was previously published under Q279117
This article has been archived. It is offered "as is" and will no longer be updated.
Expand all | Collapse all

On This Page

SYMPTOMS

A computer that is running the Distributed Link Tracking Server service regularly issues a Domain Name System (DNS) query for the following Service Location (SRV) record:
_ldap._tcp.[Site name]._sites.dc._msdcs.ServerName
. In this SRV record, ServerName is the NetBIOS name of the local computer. For example, you may see a query on a new installation for the following record:
_ldap._tcp.Default-First-Site-Name._sites.dc._msdcs
The DNS query occurs approximately every four hours. If your DNS server is located over a dial-up connection, the DNS query may cause your server to automatically connect over the dial-up connection to complete the query.

CAUSE

This problem occurs because the Lightweight Directory Access Protocol (LDAP) interprets the local server name as a domain name.

For additional information about the Distributed Link Tracking Server service, click the following article number to view the article in the Microsoft Knowledge Base:
312403 Distributed Link Tracking on Windows-based domain controllers

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Windows 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
260910 How to obtain the latest Windows 2000 service pack

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   11-Nov-2000  02:43  5.0.2195.2706      53,520  Trksvr.dll  

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows 2000 Service Pack 2.

REFERENCES

For additional information about standard terminology used to describe software updates, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
For additional information about functions that may generate DNS queries, click the following article number to view the article in the Microsoft Knowledge Base:
258507 ADsOpenObject(), ADsGetObject(), OpenDSObject() functions may generate incorrect DNS queries

Properties

Article ID: 279117 - Last Review: October 21, 2013 - Revision: 1.5
APPLIES TO
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Server
Keywords: 
kbnosurvey kbarchive kbautohotfix kbhotfixserver kbqfe kbwin2000presp2fix kbservice kbdns kbnetwork kbmisctools kbqfe kbbug kbfix KB279117

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com