FIX: OLE Automation Created with VSS 5.0 Does Not Work on a VSS 6.0 Computer

Article translations Article translations
Article ID: 279228 - View products that this article applies to.
This article was previously published under Q279228
This article has been archived. It is offered "as is" and will no longer be updated.
Expand all | Collapse all

On This Page

SYMPTOMS

If Visual SourceSafe (VSS) OLE Automation code is created on a computer that has VSS 5.0 installed and is then run on a computer that has VSS 6.0 installed, the code does not work.

STATUS

Microsoft has confirmed that this is a bug in the Microsoft products that are listed at the beginning of this article. This bug was corrected in the latest service pack for Visual Studio 6.0.

For additional information about Visual Studio service packs, click the following article numbers to view the articles in the Microsoft Knowledge Base:
194022 INFO: Visual Studio 6.0 Service Packs, What, Where, Why

194295 HOWTO: Tell That a Visual Studio Service Pack Is Installed
To download the latest Visual Studio service pack, visit the following Microsoft Web site:
http://msdn2.microsoft.com/en-us/vstudio/Aa718353.aspx

MORE INFORMATION

Steps to Reproduce Behavior

  1. Create a Microsoft Visual C++ OLE Automation program, such as the one located on the following Microsoft Web site at:
    http://msdn.microsoft.com/ssafe/downloads/vsstree.zip
  2. Compile this program on a computer that has version 5.0 of SourceSafe (ssapi.dll) installed.
  3. Run the executable file on another computer that has VSS 6.0 installed.

Properties

Article ID: 279228 - Last Review: October 21, 2013 - Revision: 1.2
APPLIES TO
  • Microsoft Visual SourceSafe 6.0 Standard Edition
Keywords: 
kbnosurvey kbarchive kbautomation kbbug kbfix kbssafe600fix kbvs600sp5fix KB279228

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com