Jak wyświetlić okno dialogowe pliku w programie Access 2002 i korzystać z tego okna

Tłumaczenia artykułów Tłumaczenia artykułów
Numer ID artykułu: 279508 - Zobacz jakich produktów dotyczą zawarte w tym artykule porady.
Ten artykuł został opublikowany wcześniej pod numerem PL279508
Wersja tego artykułu dla programu Microsoft Office Access 2003: 824272.
Poziom zaawansowany: wymaga zaawansowanej znajomości pisania kodu i zagadnień związanych ze współdziałaniem i obsługą wielu użytkowników.

Informacje zawarte w tym artykule dotyczą bazy danych programu Microsoft Access (.mdb) i projektu programu Microsoft Access (.adp).

Rozwiń wszystko | Zwiń wszystko

Streszczenie

W tym artykule przedstawiono krok po kroku sposób używania nowej metody FileDialog w programie Microsoft Access do wyświetlania wbudowanego okna dialogowego pliku i ustalania, które pliki zostały wybrane przez użytkownika.

Uwaga: Metoda FileDialog działa tylko w pełnej wersji programu Microsoft Access przeznaczonej do sprzedaży detalicznej. Ta metoda nie działa w aplikacji w czasie wykonywania programu Microsoft Access.

Więcej informacji

W starszych wersjach programu Microsoft Access okno dialogowe pliku było wyświetlane tylko przy użyciu formantu ActiveX Microsoft Common Dialog lub wywołań interfejsu API systemu Windows.

W programie Microsoft Access 2002 metoda FileDialog umożliwia wyświetlenie okna dialogowego pliku używanego przez program Microsoft Access i ustalenie, które pliki zostały wybrane przez użytkownika. Kolekcja SelectedItems obiektu FileDialog zawiera ścieżki do plików wybranych przez użytkownika. Korzystając z pętli For...Each, można wyliczać tę kolekcję i wyświetlać poszczególne pliki. W następującym przykładzie kolekcja ItemsSelected jest przeglądana w pętli i wyświetlane są pliki uwzględnione w polu listy.

Firma Microsoft podaje przykłady programowania tylko dla celów ilustracyjnych, nie udzielając żadnej rękojmi, wyrażonej wprost lub domyślnie, w tym także, bez ograniczeń, ustawowej rękojmi co do przydatności handlowej lub do określonych celów. W tym artykule zakłada się, że czytelnik zna demonstrowany język programowania oraz narzędzia używane do tworzenia i debugowania procedur. Wykwalifikowani pracownicy Pomocy technicznej firmy Microsoft mogą pomóc w wyjaśnieniu zasad działania określonej procedury, ale nie będą modyfikować tych przykładów ani dodawać żadnej funkcji i konstruować nowych procedur w celu dostosowania ich do określonych potrzeb użytkownika.
  1. Otwórz przykładową bazę danych Northwind.mdb.
  2. Utwórz nowy pusty formularz w widoku projektu.
  3. Dodaj następujące formanty do formularza.
    
       Przycisk polecenia
       --------------------------
       Name (nazwa): cmdFileDialog
       Caption (etykieta): Dodaj pliki
       OnClick: [Event Procedure] (procedura zdarzenia)
    
       Pole listy
       -------------------------
       Name (nazwa): FileList
       RowSourceType (typ źródła wierszy): Value List (lista wartości)
    					
  4. W menu View (Widok) kliknij polecenie Code (Kod źródłowy), aby otworzyć moduł formularza w Edytorze Visual Basic.
  5. W menu Tools (Narzędzia) kliknij polecenie References (Odwołania).
  6. Kliknij, aby zaznaczyć pole wyboru Microsoft Office 10.0 Object Library.
  7. Kliknij przycisk OK, aby zamknąć okno dialogowe References.
  8. Dodaj następujący kod źródłowy do modułu formularza:
    Option Compare Database
    Option Explicit
          
    Private Sub cmdFileDialog_Click()
    
    'Wymagane jest odwołanie do biblioteki Microsoft Office 10.0 Object Library.
    
       Dim fDialog As Office.FileDialog
       Dim varFile As Variant
    
       'Czyszczenie zawartości pola listy.
       Me.FileList.RowSource = ""
    
       'Konfiguracja okna dialogowego pliku.
       Set fDialog = Application.FileDialog(msoFileDialogFilePicker)
       With fDialog
          'Umożliwienie zaznaczania przez użytkownika wielu pozycji w oknie dialogowym.
          .AllowMultiSelect = True
                
          'Ustawienie tytułu okna dialogowego.
          .Title = "Wybierz jeden lub kilka plików"
    
          'Czyszczenie bieżących filtrów i dodanie własnych filtrów.
          .Filters.Clear
          .Filters.Add "Bazy danych programu Access", "*.MDB"
          .Filters.Add "Projekty programu Access", "*.ADP"
          .Filters.Add "Wszystkie pliki", "*.*"
    
          'Wyświetlenie okna dialogowego. Jeżeli metoda .Show zwróci wynik True, oznacza to, że
          'użytkownik wybrał co najmniej jeden plik. Jeżeli metoda .Show zwróci wynik
          'False, oznacza to, że użytkownik kliknął przycisk Cancel (Anuluj).
          If .Show = True Then
             'Przeglądanie w pętli poszczególnych wybranych plików i dodanie ich do utworzonego pola listy.
             For Each varFile In .SelectedItems
                Me.FileList.AddItem varFile
             Next
          Else
             MsgBox "Kliknięto przycisk Cancel (Anuluj) w oknie dialogowym pliku."
          End If
       End with
    End Sub
    					
  9. Zapisz formularz, korzystając z nazwy Form1, a następnie zamknij go.
  10. Otwórz formularz Form1 w widoku projektu.
  11. Kliknij przycisk Dodaj pliki. Pojawia się okno dialogowe Wybierz jeden lub kilka plików.
  12. Wybierz jeden lub kilka plików, a następnie kliknij przycisk OK lub kliknij przycisk Cancel (Anuluj).
Jeżeli wybrano jeden lub kilka plików, odpowiednie nazwy plików pojawiają się w polu listy. Jeżeli użytkownik kliknął przycisk Cancel (Anuluj), wyświetlany jest komunikat o błędzie informujący o kliknięciu przycisku Cancel.

Materiały referencyjne

Aby uzyskać więcej informacji dotyczących zastosowań okna dialogowego pliku, w Edytorze Visual Basic kliknij polecenie Microsoft Visual Basic Help (Microsoft Visual Basic – Pomoc) w menu Help (Pomoc), wpisz filedialog object (obiekt filedialog) w Asystencie pakietu Office lub Kreatorze odpowiedzi, a następnie kliknij przycisk Wyszukaj, aby wyświetlić odpowiedni temat.

Właściwości

Numer ID artykułu: 279508 - Ostatnia weryfikacja: 12 października 2006 - Weryfikacja: 4.2
Informacje zawarte w tym artykule dotyczą:
  • Microsoft Access 2002 Standard Edition
Słowa kluczowe: 
kbprogramming kbhowto KB279508

Przekaż opinię

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com