Como visualizar e utilizar a caixa de diálogo de ficheiro no Microsoft Access 2002

Traduções de Artigos Traduções de Artigos
Artigo: 279508 - Ver produtos para os quais este artigo se aplica.
Este artigo foi publicado anteriormente em PT279508
Este artigo poderá conter hiperligações para conteúdo em inglês (ainda não traduzido).

Para obter uma versão deste artigo referente ao Microsoft Office Access 2003, consulte 824272.
Avançado: requer conhecimentos avançados de programação, interoperabilidade e ambientes multiutilizador.

Este artigo aplica-se a uma base de dados do Microsoft Access (.mdb) e a um projecto do Microsoft Access (.adp).

Expandir tudo | Reduzir tudo

Sumário

Este artigo mostra como utilizar o novo método FileDialog no Microsoft Access para visualizar a caixa de diálogo de ficheiro incorporada e determinar os ficheiros que foram seleccionados pelo utilizador.

NOTA: o método FileDialog funciona apenas na versão de revenda completa do Microsoft Access. Este método não funciona numa aplicação de tempo de execução do Microsoft Access.

Mais Informação

Em versões mais antigas do Microsoft Access, não era possível visualizar a caixa de diálogo de ficheiro sem utilizar o controlo ActiveX Microsoft Common Dialog ou sem efectuar chamadas à API do Windows.

No Microsoft Access 2002, o método FileDialog permite-lhe visualizar a caixa de diálogo de ficheiro utilizada pelo Microsoft Access e determinar os ficheiros que foram seleccionados pelo utilizador. A colecção SelectedItems do objecto FileDialog contém os caminhos para os ficheiros seleccionados pelo utilizador. Utilizando um ciclo For...Each poderá enumerar este conjunto e visualizar cada um dos ficheiros. O exemplo que se segue efectua um ciclo no conjunto ItemsSelected e apresenta os ficheiros numa caixa de listagem.

A Microsoft fornece exemplos de programação apenas a título informativo, sem garantia expressa ou implícita, incluindo, sem limitação, as garantias implícitas de comercialização e/ou adequação a um fim específico. Este artigo pressupõe que o utilizador conhece a linguagem de programação apresentada e as ferramentas utilizadas para criar e depurar procedimentos. Os técnicos de suporte da Microsoft podem ajudar a explicar a funcionalidade de um determinado procedimento, mas não modificarão estes exemplos para proporcionarem funcionalidades adicionais nem criarão procedimentos adaptados às necessidades específicas do utilizador.
  1. Abra a base de dados de exemplo Adamastor.mdb.
  2. Crie um formulário em branco na vista de estrutura.
  3. Adicione os seguintes controlos ao formulário:
    
       Botão de comando
       ---------------------------------
       Nome: Ficheiro
       Rótulo: Adicionar ficheiros
       OnClick: [Procedimento de evento]
    
       Caixa de lista
       -------------------------------------
       Nome: ListaFicheiros
       TipoDeOrigemDaLinha: Lista de valores
    					
  4. No menu Ver , clique em Código para abrir o módulo do formulário no editor do Visual Basic.
  5. No menu Tools, clique em References.
  6. Clique para seleccionar a caixa de verificação Microsoft Office 10.0 Object Library.
  7. Clique em OK para fechar a caixa de diálogo References.
  8. Adicione o seguinte código ao módulo do formulário:
    Option Compare Database
    Option Explicit
          
    Private Sub cmdFileDialog_Click()
    
    'Requires reference to Microsoft Office 10.0 Object Library.
    
       Dim fDialog As Office.FileDialog
       Dim varFile As Variant
    
       'Clear listbox contents.
       Me.FileList.RowSource = ""
    
       'Set up the File Dialog.
       Set fDialog = Application.FileDialog(msoFileDialogFilePicker)
       With fDialog
          'Allow user to make multiple selections in dialog box
          .AllowMultiSelect = True
                
          'Set the title of the dialog box.
          .Title = "Please select one or more files"
    
          'Clear out the current filters, and add our own.
          .Filters.Clear
          .Filters.Add "Access Databases", "*.MDB"
          .Filters.Add "Access Projects", "*.ADP"
          .Filters.Add "All Files", "*.*"
    
          'Show the dialog box. If the .Show method returns True, the
          'user picked at least one file. If the .Show method returns
          'False, the user clicked Cancel.
          If .Show = True Then
             'Loop through each file selected and add it to our list box.
             For Each varFile In .SelectedItems
                Me.FileList.AddItem varFile
             Next
          Else
             MsgBox "You clicked Cancel in the file dialog box."
          End If
       End With
    End Sub
    					
  9. Guarde o formulário como Formulário1 e feche-o.
  10. Abra o formulário Formulário1 na vista de formulário.
  11. Clique em Adicionar ficheiros. Note que é apresentada a caixa de diálogo Seleccione um ou mais ficheiros.
  12. Seleccione um ou mais ficheiros e clique em OK ou clique em Cancelar.
Se seleccionou um ou mais ficheiros, repare que esses nomes de ficheiro aparecem na caixa de listagem. Se clicou em Cancelar, note que recebe uma mensagem indicando que clicou em Cancelar.

Referências

Para obter mais informações sobre o que pode fazer com a caixa de diálogo de ficheiro, no editor do Visual Basic clique em Ajuda do Microsoft Visual Basic no menu Help, escreva Object Selection no Assistente do Office ou no Assistente de respostas e clique em Procurar para visualizar o tópico.

Propriedades

Artigo: 279508 - Última revisão: 23 de novembro de 2006 - Revisão: 4.2
A informação contida neste artigo aplica-se a:
  • Microsoft Access 2002 Standard Edition
Palavras-chave: 
kbprogramming kbhowto KB279508

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com