Como exibir e usar a caixa de diálogo de arquivo no Access 2002

Traduções deste artigo Traduções deste artigo
ID do artigo: 279508 - Exibir os produtos aos quais esse artigo se aplica.
Para uma versão deste artigo do Microsoft Office Access 2003, consulte 824272.
Avançadas: Requer especialista de codificação, interoperabilidade e habilidades de multiusuário.

Este artigo se aplica a um banco de dados do Microsoft Access (.mdb) e para um projeto Microsoft Access (.adp).

Expandir tudo | Recolher tudo

Sumário

Este artigo mostra como usar o novo método FileDialog no Microsoft Access para exibir a caixa de diálogo arquivos internos e para determinar quais arquivos o usuário selecionado.

Observação : O método FileDialog funciona apenas na versão comercial completa do Microsoft Access. Esse método não funciona em um aplicativo de tempo de execução do Microsoft Access.

Mais Informações

Em versões anteriores do Microsoft Access, você não pode exibir a caixa de diálogo de arquivo sem usando tanto o Microsoft Common Dialog ActiveX controle ou fazendo chamadas para a API do Windows.

No Microsoft Access 2002, o método FileDialog permite que você para exibir a caixa de diálogo arquivo usada pelo Microsoft Access e para determinar quais arquivos foram selecionados pelo usuário. A coleção SelectedItems do objeto FileDialog contém os caminhos para os arquivos selecionados pelo usuário. Usando um for... Each loop, você pode enumerar essa coleção e exibir cada arquivo. O exemplo a seguir circula a coleção ItemsSelected e exibe os arquivos em uma caixa de listagem.

Microsoft fornece exemplos de programação apenas para ilustração, sem garantia expressa ou implícita. Isso inclui, mas não está limitado a, garantias implícitas de comercialização ou adequação para uma finalidade específica. Este artigo presume que você está familiarizados com a linguagem de programação que está sendo demonstrada e com as ferramentas que são usadas para criar e depurar procedimentos. Engenheiros de suporte podem ajudar a explicar a funcionalidade de um determinado procedimento, mas eles não modificarão esses exemplos para fornecer funcionalidades adicionais ou construir procedimentos para atender às suas necessidades.
  1. Abra o banco de dados de exemplo Northwind.mdb.
  2. Criar um novo formulário em branco no modo de design.
  3. Adicione os seguintes controles ao formulário:
    
       Command button
       --------------------------
       Name: cmdFileDialog
       Caption: Add Files
       OnClick: [Event Procedure]
    
       List box
       -------------------------
       Name: FileList
       RowSourceType: Value List
    					
  4. No menu Exibir , clique em código para abrir um módulo de formulário no Editor do Visual Basic.
  5. No menu Ferramentas , clique em referências .
  6. Clique para selecionar a caixa de seleção do Microsoft Office 10.0 Object Library .
  7. Clique em OK para fechar a caixa de diálogo referências .
  8. Adicione o seguinte código ao módulo do formulário:
    Option Compare Database
    Option Explicit
          
    Private Sub cmdFileDialog_Click()
    
    'Requires reference to Microsoft Office 10.0 Object Library.
    
       Dim fDialog As Office.FileDialog
       Dim varFile As Variant
    
       'Clear listbox contents.
       Me.FileList.RowSource = ""
    
       'Set up the File Dialog.
       Set fDialog = Application.FileDialog(msoFileDialogFilePicker)
       With fDialog
          'Allow user to make multiple selections in dialog box
          .AllowMultiSelect = True
                
          'Set the title of the dialog box.
          .Title = "Please select one or more files"
    
          'Clear out the current filters, and add our own.
          .Filters.Clear
          .Filters.Add "Access Databases", "*.MDB"
          .Filters.Add "Access Projects", "*.ADP"
          .Filters.Add "All Files", "*.*"
    
          'Show the dialog box. If the .Show method returns True, the
          'user picked at least one file. If the .Show method returns
          'False, the user clicked Cancel.
          If .Show = True Then
             'Loop through each file selected and add it to our list box.
             For Each varFile In .SelectedItems
                Me.FileList.AddItem varFile
             Next
          Else
             MsgBox "You clicked Cancel in the file dialog box."
          End If
       End With
    End Sub
    					
  9. Salve o formulário como Form1 e, em seguida, fechá-lo.
  10. Abra o formulário de Form1 no modo de formulário.
  11. Clique em Adicionar arquivos . Observe que o Selecione um ou mais arquivos caixa de diálogo é exibida.
  12. Selecione um ou mais arquivos e em seguida, clique em OK ou clique em Cancelar .
Se você selecionou um ou mais arquivos, observe que esses nomes de arquivo são exibidos na caixa de listagem. Se você clicou em Cancelar , observe que você recebe uma mensagem indicando que você clicou em Cancelar .

Referências

Para obter mais informações sobre o que você pode fazer com a caixa de diálogo arquivo, no Editor do Visual Basic, clique em Ajuda do Microsoft Visual Basic no menu Ajuda , digite o objeto filedialog no Assistente do Office ou no Assistente de resposta e, em seguida, clique em Pesquisar para exibir o tópico.

Propriedades

ID do artigo: 279508 - Última revisão: quarta-feira, 11 de outubro de 2006 - Revisão: 4.2
A informação contida neste artigo aplica-se a:
  • Microsoft Access 2002 Standard Edition
Palavras-chave: 
kbmt kbprogramming kbhowto KB279508 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 279508

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com