Přihlásit se pomocí účtu Microsoft
Přihlaste se nebo si vytvořte účet.
Dobrý den,
Vyberte jiný účet.
Máte více účtů.
Zvolte účet, pomocí kterého se chcete přihlásit.

Příznaky

Jde o takovouto situaci:

  • Vytvoření clusteru převzetí služeb při selhání založené na systému Windows Server 2012 a používají prostředky dynamického disku jiných výrobců.

  • Prostředek služby Souborový Server je možné konfigurovat v modulu snap-in Správa clusteru převzetí služeb při selhání.

  • Pokusíte se přidat položky sdílení souborů clusteru prostředek služby Souborový Server.

V tomto scénáři dojít k následujícím problémům:

  • Nelze vytvořit položky sdílení souborů clusteru pomocí místní nabídky Přidat sdílení souborů .

    Poznámka: Místní nabídky Přidat sdílení souborů nelze spustit, nainstalujte opravu hotfix popsanou v článku znalostní báze Microsoft Knowledge Base (KB) 2795993 Chcete-li vyřešit tento problém.

  • Při pokusu o vytvoření položky sdílení souborů clusteru pomocí Průzkumníka souborů sdílení blok zprávy serveru (SMB) je vytvořena místo sdílené clusterů na svazku. Předpokládejme, že pokusíte vytvořit sdílení souborů clusteru pomocí Průzkumníka souborů na jednotce s názvem "ThirdPartyDisk" s názvem "ContosoShare" pomocí následující konfigurace:

    Název clusteru: ContosoCluster
    Clusterový server soubor: \\ContosoFileShare
    Thirdparty prostředek úložiště, \\ContosoFileShare závisí na: ThirdPartyDisk
    Název uzlu nebo serveru: ContosoClusterNode1
    Název sdílené položky: ContosoShare

    V této situaci prostřednictvím sdílené cesty "\\ContosoClusterNode1\ContosoShare" namísto "\\ContosoFileShare\ContosoShare" cesty.

  • Nelze vytvořit položky sdílení souborů clusteru pomocí NetShare rozhraní API nebo příkazů prostředí Windows PowerShell. Dále se zobrazí chybová zpráva podobná následující:

    Došlo k systémové chybě 87-parametr je nesprávný

Příčina

K tomuto problému dochází, protože clusteru převzetí služeb při selhání založené na systému Windows Server 2012 nesprávně určí dynamického disku jiných výrobců na disku clusteru.

Řešení

Informace o opravě hotfix

Příklady produktů, které využívají prostředky třídy úložiště třetí strany, která se použijí tuto opravu hotfix, pokud používáte tyto produkty zahrnují (ale není omezen pouze na):

  • Symantec Storage Foundation for Windows

  • Vision Solutions Double-Take dostupnost

  • SIOS DataKeeper Cluster Edition



Chcete-li tyto problémy vyřešit, nainstalujte opravu hotfix popsanou v tomto článku. Navíc nainstalujte opravy hotfix, které jsou popsány v KB 2795993 a KB 2795997 při řešení souvisejících problémů. Další informace o KB 2795993 a KB 2795997 získáte v následujícím článku znalostní báze Microsoft Knowledge Base:

2795993 nové sdílení průvodce nespustí při pokusu o vytvoření položky sdílení souborů clusteru pro prostředek cizí dynamický disk v systému Windows 8 nebo Windows Server 2012

2795997 uživatelské rozhraní je zobrazen nesprávně při klepnutí pravým tlačítkem myši prostředek dynamického disku jiných výrobců v oblasti úložiště k dispozici v systému Windows Server 2012
Společnost Microsoft má k dispozici podporovanou opravu hotfix. Tato oprava hotfix je však určena pouze problému popsanému v tomto článku. Použití této opravy hotfix pouze u systémů, ve kterých dochází k tomuto konkrétnímu problému.

Pokud oprava hotfix je k dispozici ke stažení, je sekce "Oprava Hotfix je k dispozici ke stažení" v horní části tohoto článku znalostní báze Knowledge Base. Pokud tento oddíl není uveden, odešlete požadavek na Microsoft Zákaznický servis a podporu k získání opravy hotfix.

Poznámka: Pokud nastanou další problémy nebo bude nutné další řešení potíží, bude možná třeba vytvořit další samostatný požadavek na služby. Běžná cena za technickou podporu se vztahuje k dodatečným otázkám podpory a k problémům, které se netýkají této konkrétní opravy hotfix. Úplný seznam telefonních čísel služeb zákazníkům společnosti Microsoft a podpoře nebo vytvořit zvláštní požadavek na službu navštivte následující web společnosti Microsoft:

http://support.microsoft.com/contactus/?ws=supportPoznámka: "Hotfix stažení k dispozici" formulář zobrazí jazyky, pro které je oprava hotfix k dispozici. Pokud váš jazyk není zobrazen, to je protože oprava hotfix není k dispozici pro daný jazyk.

Předpoklady

Chcete-li nainstalovat tuto opravu hotfix, musí být spuštěn systém Windows Server 2012.

Informace o registrech

Pro použití tohoto hotfixu nemusíte provádět žádné změny v registrech.

Požadavek na restartování

Po instalaci této opravy hotfix musíte restartovat počítač.

Informace o nahrazení opravy hotfix

Tato oprava hotfix nenahrazuje dříve vydanou opravu hotfix.

Globální verze této opravy hotfix nainstaluje soubory, jejichž atributy jsou uvedeny v následujících tabulkách. Kalendářní data a časy jednotlivých souborů jsou uvedeny v koordinovaném světovém čase (UTC). Kalendářní data a časy těchto souborů v místním počítači jsou zobrazeny dle vašeho místního času a také podle aktuálního letního času (DST). Navíc data a časy se mohou změnit při provádění některých operací se soubory.





Poznámky k informacím o soubor systému Windows Server 2012Důležité: Opravy hotfix pro Windows 8 a Windows Server 2012 opravy hotfix jsou součástí stejné balíčků. Však pouze "Windows 8" je uveden na stránce žádost o opravu Hotfix. Chcete-li požádat o balíčku oprav hotfix, která se vztahuje k jedné nebo obou operačních systémů, vyberte opravu hotfix, která je uvedena v části "Windows 8" na stránce. Vždy se v článcích podívejte v části "Platí pro" na to, pro který operační systém je oprava hotfix určená.

  • Soubory týkající se konkrétního produktu, milníku (RTM, SPn) a složky služby (LDR, GDR) lze identifikovat porovnáním čísel verzí souborů podle následující tabulky:

    Verze

    Výrobek

    Milník

    Složka služby

    6.2.920 xxx 0,20

    Windows Server 2012

    RTM

    LDR

  • Soubory MANIFEST (.manifest) a soubory MUM (.mum) instalované pro každé prostředí jsou uvedeny samostatně v části "Další informace o souborech pro systém Windows Server 2012". MUM a MANIFEST soubory a soubory katalogu (CAT) přidružené zabezpečení, jsou velice důležité k udržení stavu aktualizované součásti. Soubory katalogu zabezpečení, pro něž nejsou uvedeny atributy, jsou podepsané digitálním podpisem společnosti Microsoft.

Pro všechny podporované verze systému Windows Server 2012 x64

Název souboru

Verze souboru

Velikost souboru

Datum

Čas

Platforma

Clusapi.dll

6.2.9200.16384

372,224

26-Jul-2012

03:05

x64

Resutils.dll

6.2.9200.16493

626,688

04-Jan-2013

09:30

x64

Clusapi.dll

6.2.9200.16384

372,224

26-Jul-2012

03:05

x64

Resutils.dll

6.2.9200.20598

626,688

04-Jan-2013

09:22

x64




Stav

Společnost Microsoft potvrdila, že se jedná o problém v produktech společnosti Microsoft, které jsou uvedeny v části "Platí pro".

Další informace

Pro další informace o terminologii používané v aktualizacích softwaru, klepněte na následující číslo článku k zobrazení článku v databázi Microsoft Knowledge Base:

824684 Popis standardní terminologie používané při popisu aktualizací softwaru společnosti MicrosoftProdukty třetích stran, které tento článek popisuje jsou vyráběny společnostmi nezávislými na společnosti Microsoft. Společnost Microsoft neposkytuje žádnou záruku, implicitně předpokládanou ani jinou týkající se výkonu nebo spolehlivosti těchto produktů.

Další informace o souborech

Potřebujete další pomoc?

Chcete další možnosti?

Prozkoumejte výhody předplatného, projděte si školicí kurzy, zjistěte, jak zabezpečit své zařízení a mnohem více.

Komunity vám pomohou klást otázky a odpovídat na ně, poskytovat zpětnou vazbu a vyslechnout odborníky s bohatými znalostmi.

Byly tyto informace užitečné?

Jak jste spokojeni s kvalitou jazyka?
Co ovlivnilo váš názor?
Po stisknutí tlačítka pro odeslání se vaše zpětná vazba použije k vylepšování produktů a služeb Microsoftu. Váš správce IT bude moci tato data shromažďovat. Prohlášení o zásadách ochrany osobních údajů.

Děkujeme vám za zpětnou vazbu.

×