Works : Procédure pour résoudre le blocage d'une installation et l'affichage de messages d'erreur

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Numéro d'article: 279625 - Voir les produits auxquels s'applique cet article
Ancien nº de publication de cet article : F279625
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Sommaire

Symptômes

Lors de l'installation de l'un des produits répertoriés au début de cet article, l'un des messages d'erreur suivants peut s'afficher :
  • Setup.exe n'est pas une application Win32 valide.
  • Setup a causé une exception c0000006h dans le module nom_fichier.
  • <Programme> a causé une exception c0000006h dans le module <nom_fichier>.
  • %1 n'est pas une application Win32 valide.
  • Inconnu a causé une exception dans inconnu.
  • Setup a causé une défaillance de page dans un module inconnu.
Lorsque vous cliquez sur Fermer, votre ordinateur peut cesser de répondre (se bloquer).

Lorsque vous installez l'un des produits répertoriés au début de cet article, votre ordinateur peut cesser de répondre (se bloquer).

Cause

Ce problème peut se produire lorsque l'une des conditions suivantes est remplie :
  • Le CD-ROM d'installation peut être sale ou endommagé.
  • Un programme exécuté en arrière-plan peut interférer avec le processus d'installation.
  • Les composants Microsoft Data Access (MDAC) ne sont peut-être pas installés correctement.
  • Microsoft Internet Explorer peut être endommagé ou incorrectement installé.

Ces erreurs peuvent également être dues à des problèmes de lecture du CD-ROM.

Résolution

Pour résoudre ce problème, appliquez les méthodes suivantes en respectant l'ordre dans lequel elles sont présentées.

Examen et nettoyage du CD-ROM

Nettoyez le CD-ROM du programme. Pour cela, utilisez un kit de nettoyage pour CD-ROM ou essuyez avec soin la face argentée du CD-ROM avec un chiffon en coton doux et non pelucheux. N'utilisez pas de papier qui risque de rayer le plastique et laisser des stries. Lorsque vous nettoyez le CD-ROM, essuyez-le du centre vers l'extérieur. Ne faites pas de mouvements circulaires.

Si le problème persiste, nettoyez le CD-ROM avec un chiffon humide ou avec une solution de nettoyage de CD vendue dans le commerce. Séchez minutieusement le CD-ROM avant de l'insérer dans le lecteur de CD-ROM.

Si le problème persiste, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
218617 Comment faire pour résoudre les problèmes de lecture de CD-ROM
Si le problème persiste, examinez le CD-ROM et recherchez toute présence de rayures ou d'autres dommages. Si le CD-ROM est rayé ou endommagé, contactez le détaillant chez qui vous avez acheté le programme pour négocier un échange ou appelez le 1-800-360-7561 pour demander un remplacement du CD-ROM.

Si le problème persiste, passez à la méthode suivante.

Test du disque dans un lecteur différent.

Si votre ordinateur est équipé de plusieurs lecteurs de CD-ROM, CD-R, CD/RW ou DVD, testez le disque dans l'autre lecteur. Pour les DVD, assurez-vous de la présence du logo DVD sur la face avant du lecteur. Si le disque fonctionne normalement sur un autre lecteur, il est possible que le premier lecteur ne lise pas les disques correctement. Contactez le fabricant de votre ordinateur ou du lecteur pour obtenir de l'assistance.

Si le disque est propre, mais ne peut toujours pas fonctionner sur un autre lecteur, il est fort probable qu'il soit endommagé et doive être remplacé.

Nettoyage du lecteur

Vous pouvez nettoyer le lecteur à l'aide d'un disque de nettoyage de lecteur de CD-ROM ou DVD-ROM ; cet article est en vente dans la plupart des magasins d'électronique ou d'informatique. Avant d'acheter un disque de nettoyage de lecteur, essayez de résoudre le problème à l'aide des étapes restantes de cet article.

Test de lecture du disque à l'aide de Copy ou Xcopy

Copy et Xcopy sont des utilitaires de ligne de commande qui permettent généralement d'identifier un problème de lecture de disque. Si les utilitaires Copy et Xcopy s'exécutent correctement, le problème n'est probablement pas dû à la lecture du disque. Un échec de la copie peut indiquer des problèmes dus au lecteur ou au système et vous devrez alors effectuer des procédures de dépannage supplémentaires.

Pour tester la lecture d'un disque à l'aide de Copy et Xcopy, procédez comme suit :
  1. Cliquez sur Démarrer, puis sur Exécuter.
  2. Dans la boîte de dialogue Ouvrir, tapez cmd, puis appuyez sur ENTRÉE.
  3. À l'invite de commandes, tapez l'une des commandes suivantes : Pour copier un dossier : copylecteur_disque:\ nom_dossierlecteur:\psstest /V

    Pour copier la totalité du disque : xcopylecteur_disque:\*.* lecteur:\psstest /V /E

    REMARQUE : lecteur_disque est la lettre de lecteur du CD-ROM ou de DVD-ROM, nom_dossier est le nom du dossier qui contient des fichiers auxquels vous devez accéder sur le disque et lecteur est la lettre de votre disque dur système.
  4. Appuyez sur ENTRÉE.
  5. Si le message "psstest spécifie-t-il un nom de fichier ou de répertoire ?" apparaît, appuyez sur F.
  6. Si le message Remplacer (Oui/Non/Tout) ? s'affiche, appuyez sur T.

    REMARQUE : bien que son utilisation avec les utilitaires Copy ou Xcopy demande plus de temps, le commutateur /V permet de vérifier les fichiers copiés afin de s'assurer que l'opération s'est effectuée correctement.

Démarrage minimal de l'ordinateur

Les programmes exécutés en arrière-plan peuvent interférer avec le processus d'installation. Pour s'assurer qu'aucun programme non nécessaire ne soit exécuté, démarrez l'ordinateur en mode minimal avant d'installer l'un des programmes répertoriés au début de cet article. Pour cela, appliquez la méthode correspondant à votre version de Microsoft Windows.

Microsoft Windows XP

  1. Cliquez sur Démarrer, puis sur Exécuter.
  2. Dans la zone Ouvrir, tapez msconfig, puis cliquez sur OK.
  3. Cliquez sur l'onglet Général, sur Démarrage sélectif, puis désactivez les cases à cocher suivantes :
    • Exécutez le fichier System.ini
    • Exécutez le fichier Win.ini
    • Chargez les éléments de démarrage
  4. Cliquez sur l'onglet Services, activez la case à cocher Masquer tous les services Microsoft, puis cliquez sur Désactiver tout.
  5. Cliquez sur OK, puis sur Redémarrer pour redémarrer l'ordinateur.
Après avoir redémarré Windows XP en mode minimal, fermez tous les programmes restants en procédant comme suit :
  1. Quittez tous les programmes ouverts.
  2. Cliquez avec le bouton droit sur chaque icône de la zone de notification, puis cliquez sur Quitter.

    REMARQUE : la zone de notification est située à l'extrémité droite de la barre des tâches, près de l'horloge. Certains des programmes répertoriés dans cette zone ne comprennent pas l'option Quitter dans le menu déroulant et vous devrez peut-être cliquer sur Fermer ou Désactiver en fonction des options disponibles pour le programme.
  3. Dans le menu Sécurité de Windows, appuyez sur CTRL+ALT+SUPPR, puis cliquez sur Gestionnaire des tâches.
  4. Dans le Gestionnaire des tâches de Windows, cliquez sur Applications.
  5. Aucune application n'apparaît sous la liste Tâche. Si l'une des applications figure dans cette liste, sélectionnez-la, puis cliquez sur Terminer la tâche.
  6. Répétez l'étape 5 jusqu'à ce que la liste Tâche soit vide.
  7. Fermez le Gestionnaire des tâches.

    REMARQUE : pour restaurer l'ordinateur vers un démarrage normal, sous l'onglet Général de l'utilitaire Configuration du système, cliquez sur Démarrage normal - charge tous les pilotes de périphériques et tous les services, puis sur OK, puis cliquez sur Redémarrer pour redémarrer l'ordinateur.
Pour plus d'informations, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissance Microsoft :
310353 Comment faire pour effectuer un démarrage en mode minimal dans Windows XP

Microsoft Windows Millennium Edition

  1. Cliquez sur Démarrer, sur Exécuter, tapez msconfig dans la zone Ouvrir, puis cliquez sur OK.
  2. Sous l'onglet Général, cliquez sur Démarrage sélectif.
  3. Désactivez toutes les cases à cocher sous Démarrage sélectif.
  4. Sous l'onglet Démarrage, activez la case à cocher *StateMgr.
  5. Cliquez sur OK. Lorsque vous êtes invité à redémarrer votre ordinateur, cliquez sur Oui. Après le redémarrage de l'ordinateur, cliquez sur Démarrer, sur Exécuter, tapez msconfig dans la zone Ouvrir, puis cliquez sur OK.

    IMPORTANT : sous l'onglet Général, vérifiez attentivement que les cases à cocher que vous avez désactivées le sont encore. Passez à l'étape 6 si aucune case à cocher n'est activée. Si une case à cocher est activée ou grisée, votre ordinateur n'a pas effectué correctement le "démarrage en mode minimal" et vous devez peut-être contacter le fabricant du programme pour lequel une coche est replacée dans Msconfig afin d'obtenir de l'assistance.
  6. Après avoir vérifié que votre ordinateur a démarré en mode minimal à l'étape 5, vous pouvez localiser le problème. Si le problème d'origine ne réapparaît plus après le démarrage en mode minimal, sélectionnez un élément à la fois sous Démarrage sélectif, puis redémarrez l'ordinateur pour voir si l'entrée supplémentaire reproduit le problème d'origine.

Microsoft Windows 98

  1. Cliquez sur Démarrer, puis sur Exécuter.
  2. Dans la zone Ouvrir, tapez msconfig, puis cliquez sur OK.
  3. Sous l'onglet Général, cliquez sur Démarrage sélectif, puis désactivez les cases à cocher suivantes :
    • Exécuter le fichier Config.sys
    • Exécuter le fichier Autoexec.bat
    • Exécuter le fichier Winstart.bat (si disponible)
    • Charger les rubriques du groupe Démarrage
  4. Cliquez sur l'onglet Win.ini.
  5. Cliquez sur le signe plus (+) situé en regard de [windows] pour développer l'arborescence.
  6. Sous la branche [windows], désactivez les cases à cocher suivantes :
    • Load=
    • Run=
  7. Cliquez sur OK.

    Redémarrez votre ordinateur lorsque vous y êtes invité.
Pour plus d'informations sur la procédure à suivre pour redémarrer Windows 98 en mode minimal, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
192926 Comment faire pour résoudre les problèmes de redémarrage en mode minimal sous Windows 98
REMARQUE : Pour restaurer vos options de démarrage d'origine, cliquez sur Démarrage normal sous l'onglet Général de l'utilitaire de configuration système.

Si le problème persiste, passez à la méthode "Réparer Microsoft Internet Explorer".

Microsoft Windows 95

  1. Redémarrez l'ordinateur. Lorsque le message "Démarrage de Windows 95" s'affiche, appuyez sur la touche F8, puis sélectionnez Invite MS-DOS seulement à partir du menu Démarrer.
  2. À l'invite de commandes, tapez win, puis appuyez sur ENTRÉE.

    Maintenez la touche MAJ enfoncée jusqu'à la fin de la séquence de démarrage de Windows.
  3. Désactivez tous les programmes antivirus et les utilitaires de disque installés sur l'ordinateur.

    Pour plus d'informations sur la désactivation de ces programmes, consultez la documentation imprimée ou en ligne du programme.
  4. Appuyez sur CTRL+ALT+SUPPR.
  5. Dans la boîte de dialogue Fermer le programme, cliquez sur un programme à l'exception de Explorer ou de Systray (qui sont des composants de Microsoft Windows), puis cliquez sur Fin de tâche.

    Si un message vous avertit que le programme est occupé ou qu'il ne répond pas, cliquez à nouveau sur Fin de tâche.
  6. Répétez les étapes 1 et 2 pour fermer tous les programmes à l'exception de Explorer et de Systray.
Pour plus d'informations sur la procédure à suivre pour redémarrer Windows 95 en mode minimal, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
177604 Multimédia : Résolution des problèmes par redémarrage de Windows 95 en mode minimal
REMARQUE : pour restaurer vos options de démarrage d'origine, redémarrez l'ordinateur normalement, puis activez tous les programmes antivirus ou les utilitaires de disque installés sur l'ordinateur.

Pour plus d'informations sur l'activation de ces programmes, consultez la documentation imprimée ou en ligne du programme.

Si le problème persiste, passez à la méthode suivante.

Installation de DCOM pour Windows 95 (Windows 95 uniquement)

Pour installer l'un des programmes figurant dans la liste des produits concernés par cet article sur un ordinateur Windows 95, installez la version la plus récente de DCOM pour Windows 95 (Dcom95.exe) à partir du CD-ROM de Works ou du CD-ROM n°4 de Works Suite.

Pour installer l'un des programmes répertoriés au début de cet article sur un ordinateur Windows NT 4.0, Windows 98, Microsoft Windows Millennium Edition ou Windows 2000, poursuivez avec la méthode "Installation de MDAC en mode sans échec".

Pour installer la version la plus récente de DCOM pour Windows 95 (Dcom95.exe) à partir du CD-ROM de Works ou du CD-ROM n°4 de Works Suite :
  1. Insérez le CD-ROM de Works ou le CD-ROM n°4 de Works Suite dans le lecteur de CD-ROM. Maintenez la touche MAJ enfoncée tandis que vous insérez le CD-ROM, afin d'empêcher le programme d'installation de Works de démarrer automatiquement.
  2. Cliquez sur Démarrer, puis sur Exécuter.
  3. Dans la zone Ouvrir, tapez la ligne correspondant à votre version de Works, puis cliquez sur OK

    Works :

    cd-rom:\redist\ie5\dcom95.exe

    Works Suite :

    cd-rom:\mhp\redist\ie5\dcom95.exe

    cd-rom est la lettre du lecteur de CD-ROM.
  4. Suivez les instructions qui s'affichent à l'écran pour installer la mise à jour de DCOM95 pour Windows 95.

Installation de MDAC

Pour installer MDAC en mode sans échec, appliquez la méthode correspondant à votre version de Microsoft Windows.

Windows NT 4.0

Pour installer l'un des programmes figurant dans la liste des produits concernés par cet article sur un ordinateur Windows NT 4.0, téléchargez et installez la dernière version de la mise à jour de MDAC à partir du site Web de Microsoft à l'adresse suivante :
http://www.microsoft.com/france/msdn/donnees/default.mspx
Pour plus d'informations sur la façon de télécharger des fichiers du Support technique Microsoft, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft.
119591 Obtention des fichiers de support technique Microsoft auprès des services en ligne
Microsoft a analysé ce fichier en vue de détecter la présence de virus. Microsoft a utilisé les logiciels de détection de virus les plus récents disponibles à la date de publication de ce fichier. Le fichier est conservé sur des serveurs sécurisés qui empêchent toute modification non autorisée du fichier.

Windows 95, Windows 98, Windows Millennium Edition ou Windows 2000

Pour installer MDAC en mode sans échec :
  1. Insérez le CD-ROM de Works ou le CD-ROM n°1 de Works Suite dans le lecteur de CD-ROM. Maintenez la touche MAJ enfoncée tandis que vous insérez le CD-ROM, afin d'empêcher le programme d'installation de Works de démarrer automatiquement.
  2. Cliquez sur Démarrer, pointez sur Rechercher, puis cliquez sur Fichiers ou dossiers.
  3. Dans la zone Nommé, tapez mdac_typ.exe.
  4. Dans la zone Regarder dans, cliquez sur le lecteur de CD-ROM, puis sur Rechercher maintenant.
  5. Dans la liste des fichiers trouvés, cliquez avec le bouton droit sur Mdac_typ.exe, puis cliquez sur Copier.
  6. Cliquez avec le bouton droit sur une zone vide du Bureau de Windows, puis cliquez sur Coller.
  7. Fermez la fenêtre Rechercher : fichiers nommés mdac_typ.exe.
  8. Redémarrez votre ordinateur en mode sans échec. Pour cela, appliquez la méthode correspondant à votre version de Microsoft Windows.

    Microsoft Windows 98 :

    Redémarrez l'ordinateur, maintenez la touche CTRL enfoncée jusqu'à ce que l'ordinateur ait terminé le test POST (Power On Self Test), puis choisissez le Mode sans échec dans le menu Démarrer.

    Microsoft Windows 95 :

    Redémarrez l'ordinateur. Lorsque le message "Démarrage de Windows 95" s'affiche, appuyez sur la touche F8, puis sélectionnez Mode sans échec dans le menu de démarrage.
  9. Lorsque Windows démarre en mode Sans échec, cliquez sur OK.
  10. Sur le Bureau, double-cliquez sur le fichier Mdac_typ.exe et suivez les instructions qui s'affichent à l'écran pour installer la mise à jour MDAC.
  11. Redémarrez l'ordinateur en mode normal.
REMARQUE : si vous ne pouvez pas installer MDAC en mode sans échec, téléchargez et installez la version la plus récente de la mise à jour MDAC à partir du site Web de Microsoft. Pour cela, reportez-vous à la méthode "Windows NT 4.0".

Réparation de Microsoft Internet Explorer

Pour réparer votre installation d'Internet Explorer, procédez comme suit :

  1. Cliquez sur Démarrer, pointez sur Paramètres, puis cliquez sur Panneau de configuration.
  2. Double-cliquez sur Ajout/Suppression de programmes.
  3. Double-cliquez sur Microsoft Internet Explorer version.
  4. Cliquez sur Réparer l'installation actuelle de Internet Explorer, puis sur OK.
REMARQUE : Internet Explorer 6 est fourni avec Windows XP. Pour ajouter ou supprimer Internet Explorer 6, vous devez cliquer sur Démarrer, cliquer sur Panneau de configuration, cliquer sur Ajouter/supprimer, puis sélectionner Ajouter/supprimer des composants Windows. Si vous utilisez la version de Internet Explorer qui est fournie avec votre système d'exploitation, réinstallez ou réparez votre système d'exploitation.

Pour plus d'informations, cliquez le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
318378Comment faire pour réinstaller Internet Explorer et Outlook Express dans Windows XP
Pour plus d'informations, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissance Microsoft :
315341 Comment faire pour réinstaller Windows XP


Si le problème persiste, passez à la méthode suivante.

Désinstallation et réinstallation d'Internet Explorer

Si vous ne réussissez pas à réparer votre installation d'Internet Explorer, désinstallez l'application, puis réinstallez-la. Pour cela, appliquez les méthodes suivantes en respectant l'ordre dans lequel elles sont présentées.

Désinstallation d'Internet Explorer

REMARQUE : vous devez disposer de privilèges d'administrateur pour installer ou désinstaller Internet Explorer dans Windows NT et Windows 2000. Vous devez notamment disposer de ces privilèges la première fois que vous démarrez l'ordinateur après avoir installé ou désinstallé Internet Explorer 5.5.

Pour désinstaller Internet Explorer :
  1. Cliquez sur Démarrer, pointez sur Paramètres, puis cliquez sur Panneau de configuration.
  2. Double-cliquez sur Ajout/Suppression de programmes.
  3. Sous l'onglet Installation/Désinstallation, cliquez sur Microsoft Internet Explorer et Outils Internet dans la liste des programmes installés, puis cliquez sur Ajouter/Supprimer.

    REMARQUE : si Microsoft Internet Explorer et Outils Internet n'apparaît pas dans la liste des programmes installés, exécutez Setup.exe à partir du dossier Internet Explorer\Setup. Si vous exécutez Windows 2000, exécutez la commande w2kexcp.exe /u à partir de votre dossier "Internet Explorer\IE Uninstall".
  4. Cliquez sur Rétablir la configuration précédente de Windows, puis sur OK.
  5. Dans la boîte de dialogue Installation de Internet Explorer et des outils Internet, cliquez sur OK pour restaurer la version précédente de Internet Explorer.
  6. Lorsque le système vous demande de confirmer la restauration de la version précédente, cliquez sur Oui.
  7. Redémarrez votre ordinateur lorsque vous y êtes invité.
Pour plus d'informations, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
243266 La désinstallation de Microsoft Internet Explorer 5.01 supprime Microsoft Outlook Express

Réinstallation d'Internet Explorer 5.5

Pour réinstaller Internet Explorer 5.5, procédez comme suit :
  1. Insérez le CD-ROM de Works ou le CD-ROM n°1 de Works Suite dans le lecteur de CD-ROM. Tandis que vous insérez le CD-ROM, maintenez la touche MAJ enfoncée pour éviter le démarrage automatique du CD-ROM.
  2. Cliquez sur Démarrer, puis sur Exécuter.
  3. Dans la zone Ouvrir, tapez la ligne correspondant à votre version de Works, puis cliquez sur OK

    Works :

    cd-rom:\redist\ie\ie5setup.exe

    Works Suite :

    cd-rom:\msword\ie5\en\ie5setup.exe

    cd-rom est la lettre du lecteur de CD-ROM.
  4. Suivez les instructions qui s'affichent à l'écran pour installer Internet Explorer.
Si le problème persiste, passez à la méthode suivante.

Installation de Works ou de Works Suite

Installez Works ou Works Suite.

Si le problème persiste, redémarrez l'ordinateur en mode minimal, puis installez Works ou Works Suite. Pour plus d'informations sur le démarrage de l'ordinateur en mode minimal, reportez-vous à la méthode "Installation de MDAC".

Plus d'informations

Pour plus d'informations, cliquez sur les numéros ci-dessous pour afficher les articles correspondant dans la Base de connaissances Microsoft :
270592 Le programme d'installation ne peut pas inscrire de tâches dans le Registre ou ne trouve pas le fichier Work Services
247532 Message d'erreur Works : L'exécution du programme d'installation a pris fin prématurément
248263 Works Suite : Erreur 1305 lors de l'installation
218617 Comment faire pour résoudre les problèmes de lecture de CD-ROM
242323 « Erreur interne... » Message d'erreur au cours de l'installation
242913 Works/HP 2000 : "Erreur 1305" lors de l'installation

Propriétés

Numéro d'article: 279625 - Dernière mise à jour: lundi 23 janvier 2006 - Version: 6.1
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Works Suite 2005
  • Microsoft Works Suite 2004 Standard Edition
  • Microsoft Works Suite 2003 Standard
  • Microsoft Works Suite 2002 Standard
  • Microsoft Works Suite 2001 Standard
  • Microsoft Works 8.0
  • Microsoft Works 7.0 Standard
  • Microsoft Works 6.0 Standard
  • Microsoft Works Suite 2006
Mots-clés : 
kberrmsg kbimu kbprb kbsetup KB279625
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