Windows 8 or Windows Server 2012 installation may fail with error message: The product key entered does not match any of the Windows images available for installation. Enter a different product key

Article ID: 2796988 - View products that this article applies to.
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Symptoms

During the installation of Windows 8 or Windows Server 2012, the setup may fail after prompting for Language and Keyboard selections. Additionally, you may receive the following error message:

The product key entered does not match any of the Windows images available for installation. Enter a different product key.

Cause

This problem can occur if the supplied product key does not match the media that is being used to install Windows. The supplied product key may be in an unattended file, in the EI.CFG file, in the PID.txt file or in the firmware of the BIOS. Windows 8 OEM machines ship with the product key in the firmware, and if that product key does not match the media then you will see the error message from above.

For example: Installing a Windows Server 2012 on a Windows 8 OEM machine is likely to cause this problem.

Resolution

To resolve this problem, use one of the following methods that applies to the scenario:

  1. If there is an Unattend file, Edition Configuration (EI.cfg) file or the Product ID (PID.txt) file on the system, change the product key to the correct one for the media you are trying to install.
  2. If the system has an Product key in the Motherboard (O. A. 3.0 [OEM Activation] supplies an OEM product key in the firmware) you should use an Unattend file, Edition Configuration (EI.cfg) file or the Product ID (PID.txt) file.

More information

When installing Windows 8 and Window Server 2012, setup.exe uses the following priority logic for product keys:

  1. Answer file (Unattended file, EI.cfg, or PID.txt)
  2. OA 3.0 product key in the BIOS/Firmware
  3. Product key entry screen
If a key is supplied, the key is attempted to be use with the image that are available on the media being installed. If the supplied product key does not match step 1 from above logic, an image in the WIM file, then the setup will fail with the error message mentioned in Symptoms section. If there is no product key supplied in the step 1 and step 2, you will get the product key prompt during setup.

Notes:
  • Volume License media supplies a product key with the media so it succeeds with step 1 logic.
  • You should not see this issue with Volume License media unless you are using an Unattend file or have modified files on the media to change or replace the EI.cfg or PID.txt.
  • How to drop a PID.txt with the product key specified: http://technet.microsoft.com/en-us/library/hh824952.aspx

Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use for other considerations.

Properties

Article ID: 2796988 - Last Review: October 17, 2013 - Revision: 2.0
Applies to
  • Windows 8
  • Windows 8 N
  • Windows 8 Pro
  • Windows 8 Pro N
  • Windows Server 2012 Foundation
  • Windows Server 2012 Standard
  • Windows Server 2012 Datacenter
  • Microsoft Hyper-V Server 2012
  • Windows 8.1
  • Windows 8.1 N
  • Windows 8.1 Pro
  • Windows 8.1 Pro N
Keywords: 
kbtshoot KB2796988

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