Help and Support
 

powered byLive Search

Internet Explorer stops responding for five minutes while it accesses dynamic content in frames

Article ID:279745
Last Review:January 29, 2007
Revision:3.3
This article was previously published under Q279745

SYMPTOMS

When you download dynamic content that is generated through ASP pages or through a Common Gateway Interface (CGI), Internet Explorer may stop responding (hang) for up to five minutes, and you may receive the following error message:
2147012894 Internet Client Error: Request Timeout

Back to the top

CAUSE

This behavior occurs because Internet Explorer is limited to two open connections in HTTP 1.1. If an application thread starts to download two content pages and then starts a synchronous download of an object, Wininet.dll tries to obtain a socket for this third download request. However, WinInet.dll has already hit the connection limit because of the previous requests. Therefore, WinInet.dll blocks the application thread with a call to the WaitforSingleObject function. Meanwhile, the first content page is downloaded by using one of the first two download requests and tries to indicate a completion status. However, the application thread is blocked in WaitforSingleObject. The thread resumes after 5 minutes and finishes its execution. The synchronous download request is canceled because it could not obtain a socket during the WaitForSingleObject call. Because the object was not downloaded, the content of the Web page may not appear as the author intended.

Back to the top

WORKAROUND

To work around this issue on the client computer, you can modify the registry to increase the connection limit. For more information about how to change the connection limits, click the following article number to view the article in the Microsoft Knowledge Base:
183110 (http://support.microsoft.com/kb/183110/) WinInet limits connections per server

Back to the top

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Back to the top


APPLIES TO
Microsoft Internet Explorer 5.5 Service Pack 1
Microsoft Internet Explorer 6.0, when used with:
  Microsoft Windows 2000 Advanced Server
  Microsoft Windows 2000 Datacenter Server
  Microsoft Windows 2000 Professional Edition
  Microsoft Windows 2000 Server
  Microsoft Windows NT Server 4.0 Standard Edition
  Microsoft Windows NT Server 4.0, Terminal Server Edition
  Microsoft Windows NT Workstation 4.0 Developer Edition
  Microsoft Windows Millennium Edition
  Microsoft Windows 98 Second Edition
  Microsoft Windows 98 Standard Edition

Back to the top

Keywords: 
kbenv kbprb KB279745

Back to the top

Article Translations

 

Related Support Centers

Other Support Options

  • Need More Help?
    Contact a Support professional by E-mail, Online or Phone.
  • Customer Service
    For non-technical assistance with product purchases, subscriptions, online services, events, training courses, corporate sales, piracy issues, and more.
  • Newsgroups
    Pose a question to other users. Discussion groups and Forums about specific Microsoft products, technologies, and services.