Article ID: 2803743 - View products that this article applies to.
Not sure what release of Office 365 you're using? Go to the following Microsoft website:
Am I using Office 365 after the service upgrade?
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PROBLEM

When an Office 365 pre-upgrade user tries to add new delegates or change existing delegates in his or her mailbox in Microsoft Outlook for Mac, the attempt fails. For example, when a user tries to change an existing delegate in Outlook for Mac, the user receives the following error message:
Could not get delegate information from the server. Please try again later.

CAUSE

This issue occurs if the following conditions are true:
  • The user's mailbox was migrated from Microsoft Business Productivity Online Standard Suite (BPOS-S) to Office 365 pre-upgrade.
  • The user's mailbox in BPOS-S had delegates assigned to it.
New users who you add to Office 365 pre-upgrade don't experience this issue. This issue occurs only with users who assigned delegates to their mailbox in BPOS-S and who then were migrated to Office 365 pre-upgrade.

SOLUTION

To work around this issue, remove the delegate from the user's mailbox by using the Remove-MailboxPermission Windows PowerShell cmdlet in Exchange Online PowerShell. Then, reassign the delegate to the user's mailbox in Outlook for Mac. To do this, follow these steps:
  1. Connect to Exchange Online by using remote PowerShell. For more information about how to do this, go to the following Microsoft website:
    Connect to Exchange Online Using Remote PowerShell
  2. Run the Get-MailboxPermission command to discover who has permissions to the user's mailbox and what those permissions are.

    For example, to discover who has permissions to Cassie Hick's mailbox and what those permissions are, run the following command:
    Get-MailboxPermission -Identity cassiehicks@contoso.com | FL
  3. Run the Remove-MailboxPermission command to remove the relevant permissions from the user's mailbox.

    For example, to remove John Smith's Full Access permissions to Cassie Hick's mailbox, run the following command:
    Remove-MailboxPermission -Identity cassiehickscontoso.com -User johnsmith@contoso.com –AccessRights FullAccess
  4. Reassign the delegate to the user's mailbox in Outlook for Mac.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about how to use the Get-MailboxPermission and Remove-MailboxPermission cmdlets, go to the following Microsoft TechNet websites:
Get-MailboxPermission
Remove-MailboxPermission
Still need help? Go to the Office 365 Community website.

Properties

Article ID: 2803743 - Last Review: May 17, 2013 - Revision: 4.0
Applies to
  • Microsoft Office 365 for enterprises (pre-upgrade)
  • Microsoft Office 365 for education  (pre-upgrade)
  • Microsoft Office 365 for small businesses  (pre-upgrade)
  • Microsoft Exchange Online
Keywords: 
o365 o365e o365p o365a o365062011 pre-upgrade KB2803743

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