Récupération après un ID d'événement 1034 sur un cluster de serveurs

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Numéro d'article: 280425 - Voir les produits auxquels s'applique cet article
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Symptômes

Une ressource de disque physique peut ne pas se mettre en ligne, ou le service Cluster peut ne pas démarrer. Le message suivant est généré dans le journal des événements système :

ID de l'événement : 1034
Source : Clusdisk
Description : Le disque associé à la ressource disque du cluster lettre_lecteur n'a pas été trouvé. La signature attendue pour ce disque était signature_disque.

Cause

Ces problèmes se produire généralement lorsque l'une des conditions suivantes est remplie :
  • Un disque est devenu indisponible ou inaccessible, et par conséquent, le service Cluster ne peut pas le trouver.
  • La signature sur le disque a été modifiée.
Le service Cluster reconnaît et identifie des disques par leurs signatures de disque. Les signatures de disque sont stockées sur le disque physique dans l'enregistrement de démarrage principal (MBR, Master Boot Record). L'enregistrement de démarrage principal est un enregistrement conservé par le service Cluster pour tous les disques qu'il gère. Il utilise l'enregistrement de démarrage principal pour suivre les disques. Au cours des opérations du service Cluster (démarrage, redémarrage, basculement, etc.), si le service Cluster ne peut pas trouver un disque qui est identifié par une signature particulière, il ne parvient pas à le mettre en ligne. Le composant de cluster qui détecte spécifiquement cette condition et consigne l'erreur est le pilote de filtre de disque en cluster (Clusdisk.sys). Le message d'erreur fournit des informations sur le « disque manquant » mais n'indique pas les raisons pour lesquelles cette condition a pu se produire.

Résolution

Pour résoudre ce problème, procédez comme suit :
  1. Assurez-vous que le disque est réellement exposé via les interconnexions partagées et qu'il est visible par le système d'exploitation. Pour cela, procédez comme suit :
    1. Cliquez sur Démarrer, puis sur Exécuter, tapez CompMgmt.msc, puis cliquez sur OK.
    2. Dans Gestion de l'ordinateur, sous Outils système, Gestionnaire de périphériques, consultez tous les disques logiques qui sont présentés au n?ud sous Lecteurs de disque.

      Tous les n?uds dans un cluster peuvent voir le même nombre de lecteurs de disques pour les disques qui sont gérés par le cluster. Par exemple, s'il y a 10 disques qui sont gérés par le cluster, tous les 10 sont visibles pour tous les n?uds dans le cluster. Si vous connaissez l'ID cible et le numéro d'unité logique du disque, vous pouvez les valider en cliquant sur Propriétés pour chaque disque.
    Si le compte ne correspond pas, le disque n'est pas accessible à ce n?ud. Dépannez votre solution de stockage afin de vous assurer que le disque est accessible et qu'il peut être monté par le système d'exploitation. Lorsque la solution de stockage fonctionne correctement, vous pouvez relancer le bus en cliquant avec le bouton droit sur les disques du Gestionnaire de périphériques.

    Si le compte correspond, et si le service Cluster est opérationnel, réduisez la complexité, si possible, en déplaçant toutes les ressources de disque (groupe qui hébergent les ressources) sur un seul n?ud. Si le service Custer a échoué, arrêtez tous les n?uds et redémarrez-en un seul.
  2. Si les signatures de disque ont changé, utilisez Dumpcfg.exe pour réécrire la signature attendue sur le disque.

    Les signatures des disques telles qu'elles sont énumérées par dumpcfg doivent correspondre à la liste qui est dérivée de la sous-clé de Registre suivante :
    HKLM/System/CurrentControlSet/Services/Clusdisk/Parameters
    Clusdisk utilise ces informations pour se lier aux disques qui sont gérés par le service Cluster.
  3. Si les signatures de la liste ne correspondent pas à la liste de sous-clé de Registre, vous devez identifier correctement les disques dont les signatures ont été modifiées et restaurer les signatures attendues. Pour cela, procédez comme suit :
    1. Mettez tous les n?uds hors tension sauf un.
    2. Indiquez le nombre de disques :
      1. Ouvrez Gestion de l'ordinateur, double-cliquez sur Stockage, puis cliquez sur Gestion de disque.
      2. Dans Gestionnaire de disque logique, notez le numéro de disque et l'étiquette associée au disque défaillant. Ces informations figurent à gauche des informations de partition. Par exemple : Disque 0.
      Comparez les informations qui sont affichées avec le message dans la section « Description » de l'ID d'événement 1034.

      Par exemple : « Le disque associé à la ressource disque du cluster 'Disque Q: \'  ». L'étiquette de disque ne doit pas être modifiée même si la signature l'a été. L'étiquette de disque vous permet d'identifier correctement le disque défaillant. Une fois que le disque a été correctement identifié, sa signature peut encore être vérifiée pour valider la non correspondance.
    3. Si vous ne pouvez pas afficher les disques dans DiskMgmt.msc, définissez le service de disque en cluster sur Manuel, puis redémarrez le n?ud (tous les autres n?uds doivent rester arrêtés). Pour cela, procédez comme suit :

      REMARQUE Cette étape peut ne pas être nécessaire.
      1. Cliquez sur Démarrer, pointez sur Programmes, sur Outils d'administration, puis cliquez sur Gestion de l'ordinateur.
      2. Cliquez sur Gestionnaire de périphériques dans le volet gauche, puis sur Afficher les périphériques cachés dans le menu Affichage.
      3. Dans le volet droit, consultez la section relative aux lecteurs non Plug and Play, puis double-cliquez sur le pilote Clusdisk.
      4. Sous l'onglet Pilote, remplacez la valeur Système par Désactivé pour l'option Type de démarrage
      5. Dans le volet gauche, double-cliquez sur « Services et applications », puis cliquez sur « Services ».
      6. Dans le volet droit, double-cliquez sur le service Cluster, puis cliquez sur Désactivé dans la zone Type de démarrage.
      7. Redémarrez le n?ud, puis répétez l'étape 2 si nécessaire.
    4. Écrivez la signature attendue par le service Cluster sur le disque :
      1. Obtenez la signature attendue dans la section « Description » du message d'erreur de l'ID d'événement 1034 . Par exemple : « La signature attendue pour ce disque était 12345678 ».
      2. Copiez Dumpcfg.exe du Kit de ressources Windows 2000 sur le n?ud local. À l'invite de commandes, tapez dumpcfg.exe. Sous la section [DISKS], le nombre de disques et la signature de tous les disques disponibles sont affichés. Validez la signature de disque par rapport à ce qui est attendu par le service Cluster.
      3. Écrivez la signature attendue sur le disque en utilisant la commande suivante, où 12345678 est la signature de disque en hexadécimal, et 0 est le numéro du disque que vous avez remplacé (lequel a été obtenu à l'étape précédente) :
        dumpcfg.exe - s 12345678 0
        Pour plus d'informations sur l'utilisation de Dumpcfg.exe, tapez dumpcfg /? à l'invite de commandes.
    5. Redéfinissez le service Cluster sur Automatique, puis le périphérique Disque en cluster sur Système sur le n?ud. Démarrez le périphérique Disques en cluster, puis démarrez le service Cluster.
    6. Ouvrez l'Administrateur de cluster, puis mettez le disque en ligne.
    7. Activez tous les autres n?uds, un par un, puis testez le basculement.

Plus d'informations

Si vous rencontrez des difficultés pour mettre les disques en ligne sur un cluster Windows NT 4.0, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft.
243195 ID d'événement 1034 pour le disque partagé MSCS après le remplacement d'un disque


Les logiciels multichemins défectueux sont une cause fréquente de modification des signatures de disque. Pour plus d'informations sur les logiciels multichemins défectueux dans Windows 2000, contactez les services de support technique Microsoft pour obtenir le correctif logiciel qui est décrit dans l'article suivant de la Base de connaissances Microsoft :

293778 Les logiciels à chemins multiples peuvent provoquer la modification de la signature de disque

Propriétés

Numéro d'article: 280425 - Dernière mise à jour: vendredi 26 octobre 2007 - Version: 3.8
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows 2000 Datacenter Server
  • Microsoft Windows 2000 Advanced Server
Mots-clés : 
kberrmsg kbprb kbproductlink KB280425
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