サーバー クラスタでイベント ID 1034 から回復する

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文書番号: 280425 - 対象製品
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現象

物理ディスク リソースがオンラインにならないことや、クラスタ サービスを開始できないことがあります。この場合、システム イベント ログに以下のメッセージが記録されます。

イベント ID : 1034
ソース : ClusDisk
説明 : クラスタ ディスク リソース DriveLetter に関連付けられたディスクを見つけられませんでした。ディスクの予期された署名は、DiskSignature です。

原因

これらの問題は、通常以下のいずれかの条件に該当する場合に発生します。
  • ディスクが使用できなくなったかアクセスできなくなったために、クラスタ サービスがそのディスクを見つけられない場合
  • ディスクの署名が変更されている場合
クラスタ サービスでは、ディスク署名によってディスクを認識して識別します。ディスク署名は、物理ディスクのマスタ ブート レコード (MBR) に格納されています。MBR とは、クラスタ サービスで管理されるすべてのディスクについて保持されているレコードです。クラスタ サービスは、MBR を使用してディスクを追跡します。クラスタ サービスが、開始、再開、フェールオーバーなどの操作中に、特定の署名によって識別されるディスクを検出できない場合、ディスクはオンラインになりません。特に、この状況を検出してエラーのログを記録するクラスタ コンポーネントは、クラスタ ディスク フィルタ ドライバ (Clusdisk.sys) です。エラー メッセージには、ディスクが見つからないことに関する情報は表示されますが、このような状況になった理由については示されません。

解決方法

この問題を解決するには、以下の手順を実行します。
  1. ディスクが共有の相互接続を介して実際に公開されていて、オペレーティング システムから認識されることを確認します。この操作を行うには、次の手順を実行します。
    1. [スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします。CompMgmt.msc と入力し、[OK] をクリックします。
    2. コンピュータの管理スナップインの [システム ツール] の [デバイス マネージャ] で、[ディスク ドライブ] の下に、そのノードに存在している論理ディスクがすべて表示されます。

      そのクラスタで管理されているディスクの数は、クラスタ内のどのノードで表示しても同じです。たとえば、クラスタで管理されているディスクが 10 台ある場合、クラスタのすべてのノードでこれら 10 台すべてのディスクを表示することができます。ディスクのターゲット ID および LUN がわかっている場合は、各ディスクの [プロパティ] をクリックして、これらの妥当性を検証することができます。
    数が一致しない場合、ディスクはそのノードからアクセスできません。ストレージ ソリューションのトラブルシューティングを行い、そのディスクがアクセス可能であることと、オペレーティング システムによってそのディスクをマウントできることを確認します。ストレージ ソリューションが正しく機能しない場合は、デバイス マネージャのディスクを右クリックしてそのバスを再スキャンすることができます。

    数が一致し、クラスタ サービスが開始して実行されている場合は、可能であれば、すべてのディスク リソース (リソースをホストしているグループ) を単一のノードに移動して単純化します。クラスタ サービスでエラーが発生している場合は、すべてのノードをシャットダウンし、1 つのノードを再起動します。
  2. ディスク署名が変更されている場合は、Dumpcfg.exe を使用して、予期された署名をディスクに書き込みます。

    dumpcfg によって列挙されたディスクの署名は、以下のレジストリ サブキーから得た一覧と一致する必要があります。
    HKLM/System/CurrentControlSet/Services/Clusdisk/Parameters
    Clusdisk はこの情報を使用して、クラスタ サービスによって管理されるディスクにバインドします。
  3. この一覧に示された署名がレジストリ サブキーの一覧と一致しない場合は、署名が変更されているディスクを正しく識別し、予期された署名にリセットする必要があります。この操作を行うには、以下の手順を実行します。
    1. 1 つのノードを除いて、すべてのノードの電源を切ります。
    2. ディスク番号をメモします。
      1. コンピュータの管理スナップインを開き、[記憶域] をダブルクリックし、[ディスクの管理] をクリックします。
      2. 論理ディスク マネージャで、障害が発生したディスクと関連付けられているディスク番号およびラベルをメモします。この情報は、"ディスク 0" などのように、パーティション情報の左側に表示されます。
      この情報を、イベント ID 1034 の "説明" 部分のメッセージと比較します。

      例 : "クラスタ ディスク リソース 'Disk Q:\' に関連付けられたディスク"

      署名が変わっても、ディスク ラベルは変わりません。ディスク ラベルは、問題のあるディスクを正しく識別するために役立ちます。ディスクを正しく特定できれば、その署名を再び確認して、不一致を検証することができます。
    3. DiskMgmt.msc にディスクが表示されない場合は、クラスタ サービスおよびクラスタ ディスク デバイスを [手動] に設定し、ノードを再起動します (他のノードはすべてシャットダウンしたままにします)。この操作を行うには、以下の手順を実行します。

      : この手順が不要な場合もあります。
      1. [スタート] ボタンをクリックし、[プログラム]、[管理ツール] を順にポイントし、[コンピュータの管理] をクリックします。
      2. 左側のウインドウで [デバイス マネージャ] をクリックし、[表示] メニューの [非表示のデバイスの表示] をクリックします。
      3. 右側のウインドウで [プラグ アンド プレイではないドライバ] を表示し、[Clusdisk] ドライバをダブルクリックします。
      4. [ドライバ] タブで、[スタートアップ] の下の [種類] オプションを [システム] から [無効] に変更します。
      5. 左側のウインドウで [サービスとアプリケーション] をダブルクリックし、[サービス] をダブルクリックします。
      6. 右側のウインドウで [Cluster] サービスをダブルクリックし、[スタートアップの種類] ボックスの一覧の [無効] をクリックします。
      7. ノードを再起動し、必要に応じて手順 2. を繰り返します。
    4. クラスタ サービスで予期された署名をディスクに書き込みます。
      1. イベント ID 1034 エラー メッセージの "説明" 部分から、予期された署名を取得します。

        例 : "ディスクの予期された署名は、12345678 です。"
      2. DumpCfg.exe を Windows 2000 リソース キットからローカル ノードにコピーします。コマンド プロンプトで、dumpcfg.exe と入力します。[DISKS] の下に、使用可能なすべてのディスクのディスク番号および署名が表示されます。クラスタ サービスで予期された署名と実際のディスク署名を比較して検証します。
      3. 以下のコマンドを使用して、予期された署名をディスクに書き込みます。コマンド内の 12345678 は 16 進数のディスク署名、0 は置き換えたディスク番号 (上記の手順で取得したディスク番号) です。
        dumpcfg.exe -s 12345678 0
        Dumpcfg.exe の使用方法の詳細については、コマンド プロンプトで dumpcfg /? と入力してください。
    5. ノードで、クラスタ サービスを [自動] に戻し、クラスタ ディスク デバイスを [システム] に戻します。クラスタ ディスク デバイスを起動し、次に、クラスタ サービスを開始します。
    6. クラスタ アドミニストレータを開き、ディスクをオンラインにします。
    7. 他のすべてのノードの電源を 1 つずつ入れ、フェールオーバーをテストします。

詳細

Windows NT 4.0 クラスタでディスクをオンラインにする際に問題が発生した場合は、以下の「サポート技術情報」 (Microsoft Knowledge Base) を参照してください。
243195 ディスクの交換後、MSCS の共有ディスクに関してイベント ID 1034 が記録される


通常は、マルチパス ソフトウェアの誤動作が原因で、ディスク署名が変更されます。Windows 2000 クラスタでのマルチパス ソフトウェアの誤動作に関する詳細については、マイクロソフトのサポートに問い合わせて、以下の「サポート技術情報」 (Microsoft Knowledge Base) に記載されている修正プログラムを入手してください。

293778 マルチパス ソフトウェアによってディスク署名が変更される

関連情報

この資料は米国 Microsoft Corporation から提供されている Knowledge Base の Article ID 280425 (最終更新日 2005-03-24) を基に作成したものです。

プロパティ

文書番号: 280425 - 最終更新日: 2007年10月26日 - リビジョン: 3.5
この資料は以下の製品について記述したものです。
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows 2000 Datacenter Server
  • Microsoft Windows 2000 Advanced Server
キーワード:?
kberrmsg kbprb kbproductlink KB280425
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