การกู้คืนจาก 1034 มี ID ของเหตุการณ์บนเซิร์ฟเวอร์คลัสเตอร์

การแปลบทความ การแปลบทความ
หมายเลขบทความ (Article ID): 280425 - ผลิตภัณฑ์ที่เกี่ยวข้องในบทความนี้
ขยายทั้งหมด | ยุบทั้งหมด

อาการ

ทรัพยากรดิสก์ทางกายภาพอาจล้มเหลวมาออนไลน์ หรือบริการคลัสเตอร์อาจล้มเหลวในการเริ่มการทำงาน มีสร้างข้อความต่อไปนี้ในแฟ้มบันทึกเหตุการณ์ของระบบ:

รหัสเหตุการณ์: 1034
แหล่งที่มา: ClusDisk
คำอธิบาย: ดิสก์เกี่ยวข้องกับทรัพยากรดิสก์คลัสเตอร์อักษรชื่อไดรฟ์ไม่พบ ลายเซ็นที่คาดไว้ของดิสก์ได้DiskSignature.

สาเหตุ

เกิดปัญหาเหล่านี้โดยทั่วไปได้หากเงื่อนไขใด ๆ ต่อไปนี้เป็นจริง:
  • ดิสก์มีจะไม่พร้อมใช้งาน หรือไม่สามารถเข้าถึง และดังนั้น บริการคลัสเตอร์ไม่สามารถพบ
  • ลายเซ็นบนดิสก์มีการเปลี่ยนแปลง
บริการคลัสเตอร์รู้จัก และระบุดิสก์ ด้วยลายเซ็นของดิสก์ ลายเซ็นดิสก์จะถูกเก็บไว้บนดิสก์ทางกายภาพในมาสเตอร์บูตเรกคอร์ด (MBR) MBR มีระเบียนที่บริการคลัสเตอร์เก็บดิสก์ทั้งหมดที่จะจัดการ ใช้ MBR เพื่อติดตามดิสก์ ในระหว่างการจัดหลักสูตรของคลัสเตอร์บริการดำเนิน (เริ่มต้น การรีสตาร์ท failover และอื่น ๆ forth), ถ้าบริการคลัสเตอร์ไม่พบดิสก์ที่ระบุ โดยลายเซ็นเฉพาะ มันจะล้มเหลวเพื่อนำดิสก์ทางออนไลน์ คอมโพเนนต์ของคลัสเตอร์ที่ตรวจพบเงื่อนไขนี้ และล็อกข้อผิดพลาดเฉพาะอยู่คลัสเตอร์ดิสก์ฟิลเตอร์ไดรเวอร์ (Clusdisk.sys) ข้อความแสดงข้อผิดพลาดแสดงข้อมูลใน "ไม่พบดิสก์" แต่บ่งชี้ว่า เงื่อนไขนี้อาจเกิดจากสาเหตุใดสาเหตุไม่

การแก้ไข

เมื่อต้องการแก้ปัญหานี้ ให้ทำตามขั้นตอนต่อไปนี้:
  1. ตรวจสอบให้แน่ใจว่า ดิสก์ถูกเปิดเผยจริงผ่าน interconnects และปรากฏให้เห็นถึงระบบปฏิบัติการที่ใช้ร่วมกัน ด้วยวิธีการดังนี้::
    1. คลิกเริ่มการทำงานคลิกเรียกใช้ประเภท:CompMgmt.mscแล้ว คลิกตกลง.
    2. ในคอมพิวเตอร์จัดการภายใต้เครื่องมือระบบ,ตัวจัดการอุปกรณ์ดูภายใต้ดิสก์ไดรฟ์และคุณสามารถดูดิสก์แบบลอจิคัลทั้งหมดที่มีการแสดงโหนด

      โหนทั้งหมดในคลัสเตอร์สามารถดูหมายเลขเดียวกันของไดรฟ์ดิสก์สำหรับดิสก์ที่จะถูกจัดการ โดยคลัสเตอร์ ตัวอย่างเช่น ถ้าไม่มีดิสก์ 10 ที่จะถูกจัดการ โดยคลัสเตอร์ 10 ทั้งหมดจะสามารถมองเห็นโหนทั้งหมดในคลัสเตอร์ ถ้าคุณทราบหมายเลขเป้าหมายและ LUN ของดิสก์ คุณสามารถตรวจสอบได้ โดยการคลิกคุณสมบัติสำหรับแต่ละดิสก์
    ถ้ามีการตรวจนับไม่ตรงกับ ดิสก์ไม่สามารถเข้าถึงโหนนั้น แก้ไขโซลูชันการเก็บข้อมูลของคุณเพื่อให้แน่ใจว่า ดิสก์ไม่สามารถเข้าถึง และเมาท์ โดยระบบปฏิบัติการ เมื่อทำการแก้ไขปัญหาการเก็บข้อมูลทำงานอย่างถูกต้อง คุณสามารถ rescan บัส โดยการคลิกขวาที่ดิสก์ตัวจัดการอุปกรณ์

    ถ้าการตรงกับการตรวจนับ และถ้าบริการคลัสเตอร์ขึ้น และทำงาน ลดความซับซ้อน ถ้าเป็นไปได้ ด้วยการย้ายทั้งหมดในดิสก์ทรัพยากร (กลุ่มที่โฮสต์ทรัพยากร) ไปยังโหนดเดี่ยว ถ้าบริการ Custer ล้มเหลว ปิดโหนทั้งหมด และรีสตาร์โหนหนึ่ง
  2. ถ้ามีการเปลี่ยนแปลงลายเซ็นของดิสก์ ใช้ Dumpcfg.exe เขียนลายเซ็นที่คาดไว้กลับไปยังดิสก์

    ลายเซ็นของดิสก์ตามที่ระบุโดยdumpcfgควรตรงกับรายการที่ได้รับมาจากคีย์ย่อยของรีจิสทรีต่อไปนี้:
    HKLM/ระบบ/CurrentControlSet/บริการ/Clusdisk/พารามิเตอร์
    Clusdisk ใช้ข้อมูลนี้ในการผูกกับดิสก์ที่จะถูกจัดการ โดยบริการคลัสเตอร์
  3. หากลายเซ็นในรายการไม่ตรงกับรายการคีย์ย่อยของรีจิสทรี อย่างถูกต้องคุณต้องระบุดิสก์ที่มีลายเซ็นของการเปลี่ยนแปลง และการตั้งค่าลายเซ็นที่คาดไว้ ด้วยวิธีการดังนี้::
    1. การใช้พลังงานลงทั้งหมด แต่หนึ่งโหนด
    2. หมายเลขดิสก์ของเอกสาร:
      1. เปิดการจัดการคอมพิวเตอร์ คลิกสองครั้งเก็บข้อมูลแล้ว คลิกการจัดการดิสก์.
      2. ในแบบลอจิคัล Disk Manager จดหมายเลขของดิสก์และป้ายชื่อที่เกี่ยวข้องกับดิสก์ failing ข้อมูลนี้อยู่ทางด้านซ้ายของข้อมูลพาร์ติชัน ตัวอย่างเช่น: ดิสก์ 0
      เปรียบเทียบข้อมูลที่แสดง ด้วยข้อความในส่วน "คำอธิบาย" 1034 ID ของเหตุการณ์

      ตัวอย่างเช่น: "ดิสก์เกี่ยวข้องกับการทรัพยากรคลัสเตอร์ดิสก์ 'ดิสก์ Q:\' " ป้ายชื่อดิสก์ไม่ควรเปลี่ยนแม้ว่าลายเซ็นได้ ป้ายชื่อดิสก์จะช่วยให้คุณระบุปัญหาดิสก์ได้อย่างถูกต้อง หลังจากที่ดิสก์มีการระบุไว้อย่างถูกต้อง ของลายเซ็นสามารถมีการตรวจสอบอีกครั้งเพื่อตรวจสอบที่ไม่ตรงกัน
    3. ถ้าคุณมองไม่เห็นดิสก์ใน DiskMgmt.msc การตั้งค่าบริการคลัสเตอร์และอุปกรณ์ของคลัสเตอร์ดิสก์เป็นแมนวล แล้ว รีสตาร์ทโหน (โหนอื่น ๆ ทั้งหมดจะยังคงปิดลง) โดยให้ทำตามขั้นตอนต่อไปนี้:

      หมายเหตุ:: ขั้นตอนนี้อาจไม่จำเป็น
      1. คลิกเริ่มการทำงานชี้ไปที่โปรแกรมชี้ไปที่เครื่องมือการดูแลระบบแล้ว คลิกการจัดการคอมพิวเตอร์.
      2. คลิกตัวจัดการอุปกรณ์ในบานหน้าต่างด้านซ้าย แล้วคลิกแสดงอุปกรณ์ที่ซ่อนอยู่ในการมุมมองเมนู
      3. ในบานหน้าต่างด้านขวา ให้ดูส่วนของไดรฟ์ที่ไม่ใช่-Plug and Play และจากนั้น คลิกสองครั้งClusdiskไดรเวอร์
      4. ในการไดรเวอร์แท็บ การเปลี่ยนแปลงนั้นชนิดการเริ่มต้นตัวเลือกจากระบบ:เมื่อต้องการที่ปิดใช้งาน.
      5. ในบานหน้าต่างด้านซ้าย คลิกสองครั้งที่โปรแกรม "บริการและประยุกต์" และจากนั้น คลิก "บริการ"
      6. ในบานหน้าต่างด้านขวา คลิกสองครั้งคลัสเตอร์บริการ แล้วคลิกที่ปิดใช้งานในการชนิดการเริ่มต้นกล่อง
      7. รีสตาร์โหน และจากนั้น ทำซ้ำขั้นตอนที่ 2 ถ้าจำเป็น
    4. เขียนลายเซ็นบริการคลัสเตอร์ expects ไปยังดิสก์:
      1. Obtain the expected signature from the "Description" section of the Event ID 1034 error message. For example: "The expected signature of the disk was 12345678."
      2. Copy DumpCfg.exe from the Windows 2000 Resource Kit to the local node. ที่พรอมต์คำสั่ง พิมพ์:dumpcfg.exe. ภายใต้การ[DISKS]section, the disk number and signature for all available disks is displayed. Validate the actual disk signature with what the Cluster service expects.
      3. Write the expected signature to the disk by using by using the following command, where12345678is the disk signature in hexadecimal, and0is the disk number that you replaced (which was obtained from the previous step):
        dumpcfg.exe -s12345678 0
        For more information about using Dumpcfg.exe, typedumpcfg /?at the command prompt.
    5. Set the Cluster service back toโดยอัตโนมัติ, and set the Cluster Disk device back toระบบ:on the node. Start the Cluster Disk device, and then start the Cluster service.
    6. Open Cluster Administrator, and then bring the disk online.
    7. Turn on all other nodes, one at a time, and then test failover.

ข้อมูลเพิ่มเติม

If you are having problems bringing disks online on a Windows NT 4.0 cluster, click the following article number to view the article in the Microsoft Knowledge Base:
243195Event ID 1034 for MSCS Shared Disk After Disk Replacement


Malfunctioning multi-path software is a common cause for disk signatures to change. For more information about malfunctioning multi-path software in Windows 2000 clusters, please contact Microsoft support to obtain the hotfix that is described in the following Microsoft Knowledge Base article:

293778เส้นทางหลายซอฟต์แวร์อาจทำให้ลายเซ็นดิสก์การเปลี่ยนแปลง

คุณสมบัติ

หมายเลขบทความ (Article ID): 280425 - รีวิวครั้งสุดท้าย: 8 มกราคม 2554 - Revision: 2.0
ใช้กับ
  • Microsoft Windows Server 2003 Enterprise Edition
  • Microsoft Windows Server 2003 Datacenter Edition
  • Microsoft Windows 2000 Advanced Server
Keywords: 
kbproductlink kberrmsg kbprb kbmt KB280425 KbMtth
แปลโดยคอมพิวเตอร์
ข้อมูลสำคัญ: บทความนี้แปลโดยซอฟต์แวร์การแปลด้วยคอมพิวเตอร์ของ Microsoft แทนที่จะเป็นนักแปลที่เป็นบุคคล Microsoft มีบทความที่แปลโดยนักแปลและบทความที่แปลด้วยคอมพิวเตอร์ เพื่อให้คุณสามารถเข้าถึงบทความทั้งหมดในฐานความรู้ของเรา ในภาษาของคุณเอง อย่างไรก็ตาม บทความที่แปลด้วยคอมพิวเตอร์นั้นอาจมีข้อบกพร่อง โดยอาจมีข้อผิดพลาดในคำศัพท์ รูปแบบการใช้ภาษาและไวยากรณ์ เช่นเดียวกับกรณีที่ชาวต่างชาติพูดผิดเมื่อพูดภาษาของคุณ Microsoft ไม่มีส่วนรับผิดชอบต่อความคลาดเคลื่อน ความผิดพลาดหรือความเสียหายที่เกิดจากการแปลเนื้อหาผิดพลาด หรือการใช้บทแปลของลูกค้า และ Microsoft มีการปรับปรุงซอฟต์แวร์การแปลด้วยคอมพิวเตอร์อยู่เป็นประจำ
ต่อไปนี้เป็นฉบับภาษาอังกฤษของบทความนี้:280425

ให้ข้อเสนอแนะ

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com