Client side scripts no longer work in Microsoft Dynamics CRM Online after the December 2012 Service Update

Article ID: 2804561 - View products that this article applies to.
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Symptoms

If your forms use the V4.0 client API (crmForm), you may encounter script errors after your Microsoft Dynamics CRM Online organization is updated to the December 2012 Service Update. You may see a dialog appear that says "Undefined", or you may see an error in the bottom left corner of the form that says "Error on page". Other various script errors may appear.

Cause

The December 2012 Service Update for Microsoft Dynamics CRM introduced a new System Setting that controls whether or not HTML Components (HTC) are included in Microsoft Dynamics CRM forms. This setting is disabled by default in Microsoft Dynamics CRM Online. 

The following crmForm properties require HTC:


Collapse this tableExpand this table
.Save(
.SaveAndClose(
.FormType
.ObjectTypeCode
.ObjectId
.ObjectTypeName
.RequiredLevel
.SetFocus(
.FireOnChange
.Min
.Max
.DataValue
.isDirty
.Disabled
.SelectedOption
.SelectedText
.SortingEnum
.Sort
.SelectedIndex
.InnerText
.OptionsXml
.Precision
.DataXml
.Text
.Value
.DisplayValue
.WillSubmit
.DataChangeHandler
.BypassValidation
.AllowFormFocus
._bSaving
._htcInitCompleted
.SubmitFormId
.NO_DATA
.RefreshOnSave
.Visible
.ForceSubmit
.Form
.TimeControl
.isInitialized
.allowblankdate
.IsMoney
.IsBaseCurrency
.CurrencySymbol
.CurrencyPrecision
.IgnoreCurrencySymbol
.IgnoreRange
.PrecisionChangeHandler
.TrimValue
.MaxLength
Enumerator

Resolution

1. Log into the Microsoft Dynamics CRM web application as a System Administrator.

2. Click Settings, click Administration, and then click System Settings.

3. Click the Customization tab.

4. Click the checkbox next to the setting labeled "Include HTC Support in Microsoft Dynamics CRM forms"

5. Click OK.

More information

The crmForm API was deprecated with the Microsoft Dynamics CRM 2011 release. For more information on this topic and other potential causes of script errors after the December 2012 Service Update, refer to the following Blog posts:

Resolve Breaking Script Issues When Upgrading Microsoft Dynamics CRM
http://blogs.msdn.com/b/crm/archive/2012/05/29/resolve-breaking-script-issues-when-upgrading-to-the-next-release-of-microsoft-dynamics-crm.aspx

Microsoft Dynamics CRM 2011 Custom Code Validation Tool Released
http://blogs.msdn.com/b/crm/archive/2012/06/21/microsoft-dynamics-crm-2011-custom-code-validation-tool-released.aspx
Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use for other considerations.

Properties

Article ID: 2804561 - Last Review: January 18, 2013 - Revision: 2.0
Applies to
  • Microsoft Dynamics CRM Online Professional Edition
  • Microsoft Dynamics CRM Online Professional Plus
  • CRM Online via Office 365 E Plans
Keywords: 
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