Cannot enter UEFI firmware setup when in native UEFI mode on Windows 7 and Windows 8

Article ID: 2804597 - View products that this article applies to.
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Symptoms

Consider the following scenario:
  • You enter UEFI F/W setup by pressing F1 key during POST
  • Navigate to "Startup" page and change the "UEFI/Legacy Boot" setting from "Both" to UEFI Only"
  • Exit UEFI F/W setup using F10 key to save your changes
  • You then boot the system from the Windows 7/Windows 8 installation DVD and perform a normal installation
After Windows 7/Windows 8 setup completes, you are no longer able to enter the UEFI F/W setup option when using the F1 key during POST.

NOTE: This only impacts certain OEM systems that shipped with Windows 7/Windows 8 preinstalled in BIOS Legacy Boot mode.

Cause

During Windows 7/Windows 8 setup, certain BCDEdit commands will be executed to configure the new installation. These commands may delete information in the BCD store that is necessary for the UEFI boot manager to load the UEFI firmware menu. Also, Vista, Windows Server 2008, Windows 7, Windows 8 or Windows Server 2008 R2 and Windows Server 2012 may modify the BCD store in a way that prevents the UEFI firmware menu from loading.

Resolution

Contact your hardware vendor to see if there is a firmware update available to resolve this issue.

More information

LOAD_OPTION_CATEGORY_APP bit of Attributes in Boot#### is deleted by bcdedit.exe /export, then bcdedit.exe /import /clean process. It may also be cleared by installing Windows Vista or later. This can cause the UEFI Boot Manager failure to enter UEFI firmware menu.
Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use for other considerations.

Properties

Article ID: 2804597 - Last Review: March 20, 2013 - Revision: 3.0
Applies to
  • Windows 7 Enterprise
  • Windows 7 Professional
  • Windows 7 Ultimate
  • Windows 8
  • Windows 8 Pro
Keywords: 
KB2804597

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