Word の起動、印刷、文書の読み込みが遅い

文書翻訳 文書翻訳
文書番号: 280821 - 対象製品
Microsoft Word 97 およびそれ以前のバージョンについては、次の資料を参照してください。123210

重要 : この資料には、レジストリの編集方法が記載されています。万一に備えて、編集の前には必ずレジストリをバックアップし、レジストリの復元方法を理解しておいてください。バックアップ、復元、および編集方法の詳細を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
256986 Microsoft Windows レジストリの説明
すべて展開する | すべて折りたたむ

目次

現象

Microsoft Word の起動が非常に遅いことがあります。また、文書を開く操作、印刷する操作など他の操作も非常に遅いことがあります。

原因

この現象は、次のいずれかの条件に該当する場合に発生することがあります。
  • Microsoft Windows で、ハード ディスク上のローカル プリンタ ドライバではなく、ネットワーク プリント サーバー上にあるプリンタ ドライバが使用されています。リモートのプリンタ ドライバを使用する場合、デフォルトのプリンタ設定を変更するのに時間がかかり、Word での文書の印刷が予想よりも遅くなることがあります。
  • 現在はコンピュータに Word がインストールされているが、以前ネットワークから Word を実行していました。コンピュータがネットワークに接続されていないときに文書を開くと、処理に時間がかかります。
  • Word 文書で使用されているフォントが破損しているか、システムに存在せず、文書内のフォントを他のフォントで置き換えることができません。
Word を起動すると、文書の書式設定や印刷操作に使用する情報が収集されます。ファイル、ドライバ、フォントが破損している場合、存在しない場合、またはリモート サーバー上にある場合、Word でサーバーに接続して必要な情報を収集するために、長い時間が必要になることがあります。

解決方法

この問題を解決するには、以下のいずれかの方法を使用します。

方法 1 : ローカル ポートを使用してプリンタ ドライバを再インストールする

プリンタ ドライバを削除してから、ローカル ポートを使用して再インストールします。これを行うには、以下の手順を実行します。
  1. すべての Windows プログラムを終了します。
  2. [スタート] ボタンをクリックし、[設定] をポイントして [プリンタ] をクリックします。または、[スタート] ボタンをクリックし、[プリンタと FAX] をクリックします。
  3. プリンタを右クリックし、ショートカット メニューの [削除] をクリックします。以下のメッセージが表示されます。
    プリンタ 'printer name' を削除してもよろしいですか??
    printer name は、インストールされているデフォルトのプリンタ名です。
  4. [はい] をクリックします。
  5. プリンタ ドライバを削除すると、さらに次のメッセージが表示されることがあります。
    このプリンタだけが使っていたファイルがいくつかあります。これらのファイルはもう必要ありません。削除しますか?
    このメッセージが表示されたら、[はい] をクリックします。
  6. インストールされているデフォルトのプリンタと関連ファイルが削除されたら、プリンタを再インストールします。これを行うには、使用している Windows のバージョンに応じて、以下のいずれかの手順を実行します。

    Microsoft Windows XP
    1. [スタート] ボタンをクリックし、[コントロール パネル] をクリックします。[プリンタとその他のハードウェア] をクリックし、[プリンタと FAX] をクリックします。
    2. [プリンタの追加] をダブルクリックしてプリンタの追加ウィザードを起動し、[次へ] をクリックします。
    3. [このコンピュータに接続されているローカル プリンタ] をクリックし、[プラグ アンド プレイ対応プリンタを自動的に検出してインストールする] チェック ボックスをオフにして、[次へ] をクリックします。
    4. [新しいポートの作成] をクリックし、[ポートの種類] の [Local Port] をクリックします。
    5. [ポート名を入力してください] ボックスに、次の形式でプリンタのパスを入力します。server はプリント サーバーの名前で、printer はプリンタの名前です。
      \\ server \ printer
    6. [次へ] をクリックし、プリンタの Windows 2000 または Windows XP ドライバを選択します。
    7. [次へ] をクリックし、指示に従ってウィザードを完了します。
    Microsoft Windows 2000
    1. [プリンタ] ダイアログ ボックス ([スタート] ボタンをクリックし、[設定] をポイントし、[プリンタ] をクリックします) の [プリンタの追加] をダブルクリックします。プリンタ ウィザードが表示されたら、[次へ] をクリックします。
    2. [ローカル プリンタ] をクリックし、[次へ] をクリックします。
    3. [新しいポートの作成] をクリックし、[種類] ボックスの一覧の [Local Port] をクリックし、[次へ] をクリックします。
    4. [ポート名を入力してください] ボックスにプリンタのネットワーク共有名を入力します。たとえば、\\Server name\My printer と入力し、[OK] をクリックします。
    5. [次へ] をクリックし、一覧からプリンタの製造元とモデルを選択します。次に、ウィザードの残りの手順を実行して、Windows プリンタ ドライバを再インストールします。
      [次へ] をクリックして、プリンタの製造元から提供されたディスクを使用し、インストールの指示に従ってインストールします。プリンタに付属のプリンタ ドライバをインストールする方法の詳細については、プリンタの製造元にお問い合わせください。
プリンタの製造元の問い合わせ先を参照するには、以下のうち該当する「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
65416 ハードウェア関連およびソフトウェア関連のサードパーティ ベンダの問い合わせ先一覧 (A 〜 K)

60781 ハードウェア関連およびソフトウェア関連のサードパーティ ベンダの問い合わせ先一覧 (L 〜 P)

60782 ハードウェア関連およびソフトウェア関連のサードパーティ ベンダの問い合わせ先一覧 (Q 〜 Z)
印刷の問題解決の参考となるトラブルシューティング手順の関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
870968 Office 製品の使用中に Windows Server 2003 で発生する一般的な印刷の問題のトラブルシューティング方法
870622 Windows XP で Office プログラムからローカル プリンタに印刷する際に発生する問題のトラブルシューティング方法
871146 Office 製品の使用中に Windows 2000 で発生する一般的な印刷の問題のトラブルシューティング方法
826864 Word 文書が破損している場合のトラブルシューティング方法

方法 2 : Windows レジストリで Word キーの Data サブキーをリセットする

警告 : レジストリ エディタの使い方を誤ると、深刻な問題が発生することがあります。最悪の場合、オペレーティング システムの再インストールが必要になることがあります。マイクロソフトは、レジストリ エディタの誤用により発生した問題に関しては、一切責任を負わないものとします。レジストリ エディタは、自己の責任においてご使用ください。
現在はコンピュータに Word がインストールされているが、以前ネットワークから Word を実行していて、コンピュータがネットワークに接続されていないときに文書を開くと処理に時間がかかる場合、以下の手順を実行します。

Word キーの Data サブキーには、インストールしているプリンタに固有の情報が保存されます。Word からこのプリンタ情報を削除するには、Windows レジストリで Word キーの Data サブキーの名前を変更するか削除します。Microsoft Word を再起動すると、Word キーに Data サブキーが自動的に再作成されます。

: Word キーの Data サブキーの名前を変更するか削除すると、Microsoft Word 内の一部の設定がデフォルト設定にリセットされます。

Windows レジストリで Word キーの Data サブキーの名前を変更するか削除するには、以下の手順を実行します。
  1. すべての Windows プログラムを終了します。
  2. [スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします。
  3. [名前] ボックスに Regedit と入力し、[OK] をクリックします。
  4. 使用している Word のバージョンに応じて次のレジストリ キーを展開します。

    Word 2003
    HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Word

    Word 2002
    HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Word
    Word 2000
    HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\Word
  5. Word キーの下の Data サブキーをクリックします。
  6. [編集] メニューの [名前の変更] をクリックして Data サブキーの名前を変更するか、または [削除] をクリックします。
  7. 以下のメッセージが表示されたら [はい] をクリックします。
    このキーを削除してよろしいですか?
  8. [レジストリ] メニューの [レジストリ エディタの終了] をクリックします。
  9. Word を起動します。

方法 3 : 破損しているフォントや存在しないフォントを修復または置換する

破損しているフォントや存在しないフォントによって、「現象」に記載した問題が発生している可能性があります。この問題を修正するには、使用している Microsoft Windows のバージョンのフォントを削除するか再インストールします。

関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
234749 Windows のデフォルトのフォントを復元する方法
314960 Windows でフォントをインストールまたは削除する方法
306870 Windows Me ベースのコンピュータに新しいフォントを追加する方法
131943 Windows 95/98 における TrueType フォントの最大数

詳細

他社テクニカル サポートのお問い合わせ窓口は、ユーザーの便宜のために提供されているものであり、将来予告なしに変更されることがあります。マイクロソフトは、掲載している情報に対して、いかなる責任も負わないものとします。

プロパティ

文書番号: 280821 - 最終更新日: 2010年5月13日 - リビジョン: 5.0
この資料は以下の製品について記述したものです。
  • Microsoft Office Word 2003
  • Microsoft Word 2002
  • Microsoft Word 2000
キーワード:?
kbperformance kbopenfile kbstartprogram kbtshoot kbprb kbprint KB280821
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"

フィードバック

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com