Não é possível instalar um Exchange Server 2010 ou o Exchange Server 2013 update rollup ou service pack quando uma política de execução de script do Windows PowerShell é definida na política de grupo

Traduções de Artigos Traduções de Artigos
Artigo: 2810617 - Ver produtos para os quais este artigo se aplica.
Expandir tudo | Reduzir tudo

Sintomas

Considere o seguinte cenário:

  • Definir uma política de execução de script do Windows PowerShell aplicando um objecto de política de grupo ou aplicar uma política de grupo local.
  • Tenta instalar um Microsoft Exchange Server 2010 orMicrosoft 2013 de servidor do Exchange update rollup ou service pack.
  • O processo de configuração falha depois de concluir o passo de remover ficheiros do Exchange.
Neste cenário, o Serverdoes do Exchange não funcionar no servidor afectado. Além disso, não conseguir reiniciar o processo de configuração.

Causa

Este problema ocorre porque o serviço Windows Management Instrumentation (WMI) requerido pára durante o processo de instalação. O serviço WMI é necessária a consulta nos serviços de domínio do Active Directory (AD DS) para verificar a política de execução do script de Windows PowerShell que tem de ser executado como parte da configuração.

Resolução

Para evitar este problema, siga estes passos:
  • Desactive a execução de política de grupo, utilizando a consola de gestão de políticas de grupo (GPMC. msc) ou o Editor de política de grupo (gpedit. msc) Local. Objectos de política de grupo para a execução de política de grupo tem de ser definidos comoindefinido.
  • Instale o Exchange Server 2010 ou o Exchange Server 2013 update conjunto de actualizações ou service pack.
  • Volte a activar a política de execução de script do Windows PowerShell previamente definida na consola de gestão de políticas de grupo ou Editor de política de Grupo Local.

    NotaO problema descrito na secção "Sintomas" foi resolvido no SP3 do Exchange Server 2010. No Exchange Server 2010 SP3 e versões posteriores, as políticas de execução de script do Windows PowerShell são verificadas correctamente. Por conseguinte, não é necessário que desactivar as políticas de execução de script quando instala uma actualização do conjunto de actualizações ou service pack.
Para mais informações sobre o Exchange Server 2010 SP3, clique no número de artigo seguinte para visualizar o artigo na Microsoft Knowledge Base:
2808208 Descrição do Exchange Server 2010 Service Pack 3

Ponto Da Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na secção "Aplica-se a".

Mais Informação

Para verificar as políticas de execução antes de começar o processo de instalação, execute o cmdlet seguinte do Windows PowerShell:
Get-ExecutionPolicy-lista

A saída deve ser semelhante ao seguinte:
Scope ExecutionPolicy 
----- --------------- 
MachinePolicy Undefined
UserPolicy Undefined 
Process Undefined 
CurrentUser Undefined 
LocalMachine Undefined
Se nenhuma das políticas de execução estão definidas para um Estado diferente de indefinido, consulte os passos na secção "Resolução" antes de instalar um pacote de conjunto de actualizações ou o serviço de actualização do Exchange Server.

Para obter informações sobre um problema que pode ocorrer quando runa configuração e ocorrer um erro, clique no número de artigo seguinte para visualizar o artigo na Microsoft Knowledge Base:
2668686 Mensagem de erro quando tenta instalar o Exchange Server 2010 SP2: "Verificação de AuthorizationManager falhou"
Para obter informações sobre um problema que pode ocorrer quando tenta instalar o conjunto de actualizações 1 para Microsoft Exchange Server 2010, vá para o seguinte artigo na Microsoft Knowledge Base:
981474 Recebe o erro 1603 quando tenta instalar o Exchange Server 2010 RU1
Para obter informações sobre um problema que pode ocorrer quando tenta instalar um update rollup para Microsoft Exchange Server 2010, vá para o seguinte artigo na Microsoft Knowledge Base:
2467565 Não é possível instalar um conjunto de actualizações para o Exchange Server 2010 com um GPO implementado que define uma política de execução de PowerShell para o servidor para ser actualizado

Propriedades

Artigo: 2810617 - Última revisão: 27 de fevereiro de 2014 - Revisão: 3.0
A informação contida neste artigo aplica-se a:
  • Microsoft Exchange Server 2013 Enterprise
  • Microsoft Exchange Server 2013 Standard
  • Microsoft Exchange Server 2010 Enterprise
  • Microsoft Exchange Server 2010 Standard
Palavras-chave: 
kbqfe kbfix kbsurveynew kbexpertiseinter kbmt KB2810617 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 2810617

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com