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Symptoms

When you try to install a service pack for Microsoft Forefront Unified Access Gateway (UAG) 2010, the installation fails. This problem may occur because a time-out value is exceeded during the Schema Upgrade operation.

To confirm that this is the problem that you're experiencing, run the service pack installation while verbose logging is enabled. To enable verbose logging, run a command that resembles the following:

UAG_SP_Executible /l*vx ExtraVerbose.logIf you see the following lines in the verbose log file (ExtraVerbose.log), this confirms that the installation has failed because a time-out was exceeded during the Schema Upgrade operation:

UAG CA (Info): System.TimeoutException: Transaction Timeout
at Microsoft.UAG.Transformer.Core.SchemaConversionRuntime.Run()
at UAG.CustomActions.ConfigurationSchemaConvert.InstallTask()

Cause

The following time-outs are involved in the Schema Upgrade process:

  • The .NET Framework System Transaction MaxTimeout property. Has a default value of 10 minutes.

  • The UAG Schema Upgrade Transaction time-out property. Has a default value of 60 minutes.


In this situation, one of these time-outs was exceeded.

Resolution

To resolve this problem, use one of the following methods, as appropriate for your situation.

Method 1

If the service pack installation fails during the 10-to-60-minute range, increase the .NET Framework System Transaction MaxTimeout value. To do this, follow these steps:

  1. Use administrator permissions to start a text editor such as Notepad.

  2. Open the Machine.config file. You can find this file in the following location:

    C:\Windows\Microsoft.NET\Framework64\v2.0.50727\CONFIG

  3. Near the end of the file, locate the closing "</configuration>" tag.

  4. Add the following lines just before the closing "</configuration>" tag:

    <system.transactions>
    <machineSettings maxTimeout="01:00:00" />
    </system.transactions>


  5. Save the file, and then exit the text editor.


This change increases the default MaxTimeout value from 10 minutes to 1 hour.

For more information about the MaxTimeout property, go to the following MSDN website:

MachineSettingsSection.MaxTimeout Property
Note If this problem occurs in less than 60 minutes, the .NET Framework System Transaction MaxTimeout property should be increased. However, you should not have to increase the UAG Schema Upgrade Transaction time-out value.

Important After the service pack installation has finished successfully, change the .NET Framework System Transaction MaxTimeout value back to its default value of "00:10:00."

Method 2

If the service pack installation fails after more than 60 minutes, the .NET Framework System Transaction MaxTimeout property must be increased in addition to increasing the UAG Schema Upgrade Transaction time-out value.

To resolve this problem, install the service pack that is described in the following Microsoft Knowledge Base article:

2744025 Description of Forefront Unified Access Gateway 2010 Service Pack 3
If Service Pack 3 installation fails, perform the steps in Method 1. Additionally, increase the .NET Framework System Transaction time-out property to a value that is greater than the elapsed time at which the installation fails. For example, if the installation fails after 90 minutes, increase the Schema Upgrade Transaction time-out value to a value of greater than 90 minutes.

To increase the UAG Schema Upgrade Transaction time-out value, UAG 2010 Service Pack 3 introduces a new MSI parameter. To use this MSI parameter, use the following command to pass the new time-out value in the service pack installation package:

UAG_SP_Executible SCHEMA_UPGRADE_TRANS_TIMEOUT=7200 /l*vx ExtraVerbose.logThis command sets the SCHEMA_UPGRADE_TRANS_TIMEOUT value to 7200 seconds (default = 3600 seconds).

Note This parameter is supported only in UAG 2010 Service Pack 3 and later versions.

If you have a UAG 2010 Service Pack 1 or UAG 2010 Service Pack 2 installation that fails because of a Schema Upgrade time-out after 60 minutes or more, open a support case with Microsoft Support Services to discuss resolution options.

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

References

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

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