Accedi con Microsoft
Accedi o crea un account.
Salve,
Seleziona un altro account.
Hai più account
Scegli l'account con cui vuoi accedere.

Sintomi

Si consideri lo scenario seguente:

  • Un server web viene pubblicato mediante Microsoft Forefront Unified Access Gateway (UAG) 2010.

  • Forefront UAG 2010 utilizza ticket Kerberos vincolato delega (KCD) per delegare le credenziali utente al server web pubblicato.

  • Il server web pubblicato rifiuta il ticket KCD viene fornito da Forefront UAG 2010 e restituisce un errore 401.

In questo scenario, Forefront UAG 2010 entra in un ciclo di retry richiesta. Inoltre, possono verificarsi le seguenti condizioni per il processo di lavoro di Forefront UAG w3wp.exe durante il ciclo di retry richiesta:

  • Un rapido incremento del consumo di memoria

  • Utilizzo elevato della CPU

Causa

Questo problema è in genere causato da un problema che riguarda l'installazione KCD o un problema che esiste nel server web pubblicato.

Se è stato ottenuto un ticket KCD al server pubblicato Forefront UAG ha autenticato l'utente, il programma non prevede di ricevere un errore 401 dal server web pubblicato durante la negoziazione di KCD con il server pubblicato. In queste condizioni, Forefront UAG tenta di gestire l'errore 401 ottenendo un nuovo ticket KCD e quindi ripetere la richiesta al server web pubblicato. Questa attività comporta il ciclo di retry richiesta si verifica.

Importante Il nuovo tentativo della richiesta/ciclo problema in Forefront Unified Access Gateway 2010 Service Pack 3 (SP3). Forefront UAG 2010 SP3 non affronta il problema di autenticazione sottostante poiché che non si verifica in Forefront UAG. Se Forefront UAG riceve l'errore 401 imprevisto dal server web pubblicato perché non è riuscita la negoziazione di KCD con il server web pubblicato, al client viene restituito l'errore 401. Quindi, il client riceve una richiesta di autenticazione. Tuttavia, il client sarà in grado di completare l'autenticazione a causa del problema sottostante.

Nota: Vedere la sezione "Informazioni" per ulteriori informazioni su alcune delle cause dell'errore imprevisto di autenticazione al server web pubblicato.

Risoluzione

Per risolvere questo problema, installare il service pack che è descritta nel seguente articolo della Microsoft Knowledge Base:

2744025 descrizione di Forefront Unified Access Gateway 2010 Service Pack 3

Stato

Microsoft ha confermato che questo è un problema dei prodotti Microsoft elencati nella sezione "Si applica a".

Ulteriori informazioni

Supporto tecnico clienti Microsoft ha registrato diverse occorrenze di questo problema in Outlook Anywhere scenari di pubblicazione. In questi casi, il problema è causato l'autenticazione KCD al server di accesso Client (CAS) non riesca per RPC sul traffico HTTP. Per ulteriori informazioni su un problema analogo, fare clic sul numero seguente per visualizzare l'articolo della Microsoft Knowledge Base:

2545850 Impossibile accedere un sito Web di hosting in IIS dopo avere modificata la password per il server in Windows 7 o Windows Server 2008 R2Note

  • L'hotfix descritto in KB 2545850 deve essere installato nella CA, non sul server Forefront UAG.

  • Per aggirare il problema senza installare l'hotfix 2545850, riavviare la CA. Questa soluzione rimarrà attiva fino alla successiva in cui viene rilevato il problema.

Il web server può anche restituire un errore 401 causa un problema di autorizzazioni o se KCD non impostato correttamente. Ad esempio, il principale nome servizio (SPN) che i delegati Forefront UAG potrebbe non essere registrato contro l'account server web di destinazione o l'account di processo del servizio. Per ulteriori informazioni sull'installazione di delega vincolata Kerberos, andare al seguente sito Web Microsoft TechNet:

Configurazione servizio single sign-on con Kerberos delega vincolata

Riferimenti

Per ulteriori informazioni sulla terminologia degli aggiornamenti software, fare clic sul seguente numero di articolo per visualizzare l'articolo della Microsoft Knowledge Base:

824684 descrizione della terminologia standard utilizzata per descrivere gli aggiornamenti software Microsoft

Serve aiuto?

Vuoi altre opzioni?

Esplorare i vantaggi dell'abbonamento e i corsi di formazione, scoprire come proteggere il dispositivo e molto altro ancora.

Le community aiutano a porre e a rispondere alle domande, a fornire feedback e ad ascoltare gli esperti con approfondite conoscenze.

Queste informazioni sono risultate utili?

Come valuti la qualità della lingua?
Cosa ha influito sulla tua esperienza?
Premendo Inviare, il tuo feedback verrà usato per migliorare i prodotti e i servizi Microsoft. L'amministratore IT potrà raccogliere questi dati. Informativa sulla privacy.

Grazie per il feedback!

×