Dizin eşitleme raporunda bir hata görüntülüyor: Bu şirket eşitlenebilen nesne sayısını aştı

Bu makalede, Office 365, Azure veya Microsoft Intune ortamında dizin eşitlemesi için Active Directory dizin hizmeti kotasının nasıl artırıldığı açıklanır.

Özgün ürün sürümü: Cloud Services (Web rolleri/Çalışan rolleri), Microsoft Entra ID, Microsoft Intune, Azure Backup Office 365 Kullanıcı ve Etki Alanı Yönetimi
Özgün KB numarası: 2812409

Belirtiler

Şu MSOnlineServicesTeam@MicrosoftOnline.com hata iletisini içeren bir e-posta iletisi alırsınız:

Hata 016: Eşitleme durduruldu. Bu şirket eşitlenebilen nesne sayısını aştı. Microsoft Online Services Desteği'ne başvurun.

Not

Microsoft bulut hizmetinde Office 365, Azure veya Microsoft Intune gibi izin verilen nesne sayısından fazla nesne olmasını planlıyorsanız ve Active Directory eşitlemesini kullanmıyorsanız dizin hizmeti kotasını artırma isteğinde bulunmak istiyorsanız da bu makale kullanılabilir. Microsoft Entra ID'daki geçerli dizin hizmeti kotası 50.000 nesnedir.

Neden

Bu sorun, Microsoft Entra ID oluşturduğunuz nesne sayısının dizin hizmeti sınırınızı aşması nedeniyle oluşur. Microsoft Entra ID her kuruluş tarafından oluşturulabilecek nesne sayısını sınırlar. Microsoft Entra kuruluşunuzdaki gruplar, kişiler ve kullanıcı nesneleri, kuruluşunuzun dizin kullanımının bir parçası olarak sayılır.

Varsayılan dizin hizmeti kotanız aşağıdaki yönergelere göre hesaplanır:

  • Doğrulanmış etki alanınız yoksa, Microsoft Entra ID'deki geçerli dizin hizmeti kotası 50.000 nesnedir.

    1. Kuruluşunuz 5 Ekim 2011'e kadar oluşturulduysa, varsayılan dizin hizmeti kotanız 10.000 nesnedir.
    2. Kuruluşunuz 5 Ekim 2011'de ve Mayıs 2012'de oluşturulduysa, varsayılan dizin hizmeti kotanız 20.000 nesnedir.
    3. Kuruluşunuz Mayıs 2012'de oluşturulduysa, varsayılan dizin hizmeti kotanız 50.000 nesnedir.
  • En az bir doğrulanmış etki alanınız varsa, Microsoft Entra ID'daki varsayılan dizin hizmeti kotası 300.000 nesnedir.

Çözüm

şirket içi Active Directory'nizdeki grup, kişi ve kullanıcı nesnesi sayısı dizin hizmeti kotanızı aştığında, şirketiniz için dizin hizmeti kotası sınırlamasında artış isteyebilirsiniz. Bu artış, dizin eşitlemesini kullandığınızda geçerli varsayılan sınırdan daha fazla nesneyi eşitlemenize olanak tanır.

Kuruluşunuzda nesne oluşturmaya devam etmek için bir etki alanı eklemeniz veya dizin hizmeti kotanıza bir artış istemeniz gerekir. Bunu yapmak için aşağıdaki yöntemleri kullanın.

Yöntem 1

Doğrulanmış bir etki alanınız yoksa, kota sınırınızı 300.000 nesneye yükseltmek için bir etki alanı eklemeniz gerekir. Daha fazla bilgi için bkz. Etki alanınızı ekleme.

Yöntem 2

şirket içi Active Directory dizin hizmetinizde 300.000'den fazla nesne varsa, eşitlenebilen nesne sayısını 300.000'den fazla artırmak için Microsoft Desteği başvurun.

Daha fazla bilgi

Dizin hizmeti kotası, tek bir güvenlik sorumlusu tarafından oluşturulabilecek ve sahip olunabilecek en fazla nesne sayısını sınırlamak için bir yöntem olarak bulut hizmeti kullanılarak uygulanır. Dizin eşitlemesi kullanılarak bir şirketle eşitlenen tüm nesnelerin oluşturucu/sahip değeri bu şirket için varsayılan yöneticiler grubuna ayarlanmıştır. Örneğin, yöneticiler grubu aşağıdaki gibi ayarlanır: admins@contoso1.microsoftonline.com. Bu nedenle, bu yapılandırma kullanıcıların dizin eşitlemesini kullanarak sınırsız sayıda nesne oluşturmasını engeller. Bir şirketin dizin hizmeti kota sınırından daha fazla eşitlemeye ihtiyacı varsa, teknik desteğe bir hizmet isteği gönderin.

Sık sorulan sorular

Soru 1: Bulut hizmeti portalı veya Exchange Online PowerShell gibi bulut hizmeti API'si aracılığıyla el ile eklenen nesneler çevrimiçi şirket kotama göre sayılır mı?

Yanıt 1: Evet.

Soru 2: Silinen nesneler çevrimiçi şirket kotama göre sayılır mı?

Yanıt 2: Evet. Bulut hizmeti müşterisi çevrimiçi bir şirketten bir nesneyi sildiğinde, silinen nesne dizin hizmetindeki silinmiş nesneler kapsayıcısına yerleştirilir. Nesne silinmiş nesneler kapsayıcısında kalır ve kaldırılma taşı yaşam süresi dolana kadar kalır. Süre sonu şu anda 30 gün olarak ayarlanmıştır.

Örneğin, şu senaryoyu inceleyin: Çevrimiçi bir şirket, üretim dışı bir şirket içi Active Directory ortamı kullanarak bulut hizmetini değerlendiriyor. Bulut hizmeti kuruluşu 5 Ekim 2011'de oluşturulmuştur ve varsayılan eşitleme sınırı 10.000 nesnedir. Şirket, Dizin Eşitleme aracını kullanarak 8.000 grup nesnesinin ve kişi nesnesinin toplu eşitlemesini gerçekleştirir. Daha sonra, çevrimiçi şirket aşağıdakileri yapmaya karar verir:

  1. Bu grup nesnelerini ve kişi nesnelerini şirketin şirket içi üretim dışı Active Directory DS ortamından silin.
  2. Şirket içi üretim dışı Active Directory DS ortamına 8.000 kullanıcı nesnesi ekleyin.
  3. Güncelleştirmeleri çevrimiçi şirketiyle eşitleyin.

8.000 grup nesnesi ve kişi nesnesi dizin hizmetindeki silinmiş nesneler kapsayıcısına taşınır. Ayrıca bu nesneler, 30 günlük kaldırılma süresinden sonra kalıcı olarak kaldırılana kadar çevrimiçi şirket kotasının yüzde 25'ini tüketmeye devam eder. (Bu yüzde 2.000 nesneye veya yüzde 8.000 × 25'e eşittir.) Bu nedenle, 5.000 yeni kullanıcı nesnesini eşitledikten sonra, çevrimiçi şirket kullanılabilir Active Directory kotasından 10.000 nesne, silinen nesnelerden 2.000 ve yeni kullanıcı nesnelerinden 8.000 nesne tüketir. 30 günlük mezar taşı dönemi boyunca (ve bu süre çevrimiçi şirket değerlendirme dönemiyle çakışabilir), çevrimiçi şirket dizin eşitlemesini kullanarak ek nesne ekleyemeyebilir. Bu koşul, çevrimiçi şirketin dizin hizmeti kotasının ulaşılmış olması nedeniyle oluşur.

Bu senaryoda, bulut hizmetinin değerlendirmesini yapan çevrimiçi şirketin ürün değerlendirmesini tamamlamak için üretim dışı şirket içi Active Directory DS ortamındaki nesne sayısını azaltması gerekir. Ancak, çevrimiçi şirket nesne sayısını azaltamıyorsa, şirket dizin hizmeti kotasında bir artış istemelidir.

Soru 3: Birden fazla doğrulanmış etki alanına sahip olmak, 300.000 nesneden daha yüksek bir kotaya sahip olabileceğim anlamına mı geliyor?

Yanıt 3: Hayır. Bir veya daha fazla doğrulanmış etki alanınız varsa size 300.000 nesneden oluşan bir dizin kotası verilir. Kaydettiğiniz her doğrulanmış etki alanı için size 300.000 nesne kotası verilmez.

Yardım için bize ulaşın

Sorularınız veya yardıma ihtiyacınız varsa bir destek isteği oluşturun veya Azure topluluk desteği isteyin. Ürün geri bildirimini Azure geri bildirim topluluğuna da gönderebilirsiniz.