Error when you try to move a mailbox in Exchange Server 2016: The migration mailbox for the organization is either missing or invalid

Original KB number:   2812509

Symptoms

When you try to move a mailbox by using the New-MigrationBatch cmdlet in Exchange Server 2016, you may receive an error message that resembles the following one:

The migration mailbox for the organization is either missing or invalid.

Cause

This issue occurs if the migration mailbox isn't enabled or was deleted.

Note

To move a mailbox by using the New-MigrationBatch cmdlet, the migration mailbox must be present and enabled.

Resolution

To resolve this issue, follow these steps:

  1. Start the Active Directory Users and Computers snap-in.

  2. Click Users, and then verify that the following account doesn't exist:

    Migration.8f3e7716-2011-43e4-96b1-aba62d229136

    Note

    If this account exists in the Users container, go to step 4.

  3. Run the following cmdlet:

    Setup /PrepareAD /IAcceptExchangeServerLicenseTerms
    
  4. Run the following cmdlets:

    Enable-Mailbox -Arbitration -Identity "Migration.8f3e7716-2011-43e4-96b1-aba62d229136"
    
    Set-Mailbox "Migration.8f3e7716-2011-43e4-96b1-aba62d229136" -Arbitration -Management:$true
    

References