Una solicitud de certificado que utiliza una nueva plantilla es incorrecta

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importante : este artículo contiene información acerca de cómo modificar el registro. Antes de modificar el Registro, asegúrese de hacer una copia de seguridad del mismo y de que sabe cómo restaurarlo si ocurre algún problema. Para obtener información sobre cómo realizar una copia de seguridad, restaurar y modificar el Registro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
256986Definición del Registro de Microsoft Windows
Expandir todo | Contraer todo

Síntomas

Cuando intenta inscribir un certificado contra una entidad de empresa (CA), puede recibir uno de los mensajes de error siguientes:

Inscripción en Web:
Certificado Solicitud denegada

Se denegó su solicitud de certificado.

Póngase en contacto con su administrador para obtener más información.

Solicitud de certificado Asistente:
La entidad de certificación denegó su solicitud. Error no especificado.

Causa

Este comportamiento puede producirse si la solicitud de inscripción de certificados utiliza una plantilla de certificado recently-created. Cuando se agrega una nueva plantilla a la entidad emisora de CERTIFICADOS, inmediatamente se actualiza la caché
HKEY_CURRENT_USER
pero no se actualiza inmediatamente la caché
HKEY_LOCAL_MACHINE
. La caché
HKEY_LOCAL_ MACHINE
se actualiza en los próximos 15 minutos si la entidad emisora o el controlador de dominio están en el mismo equipo y, en los siguiente 10 minutos si la entidad emisora o el controlador de dominio está en una configuración distribuida.

Solución

Advertencia : si utiliza incorrectamente el Editor del registro, pueden surgir problemas graves que conlleven la reinstalación del sistema operativo. Microsoft no garantiza que pueda solucionar los problemas resultantes del uso incorrecto del Editor del Registro. Utilice el Editor del Registro bajo su responsabilidad.

Para resolver este comportamiento, si no puede esperar el intervalo aplicable de tiempo, puede actualizar manualmente la caché de plantilla de certificado. La caché de certificados de equipo se encuentra en
HKEY_LOCAL_MACHINE
y la caché de certificados de usuario se encuentra en
HKEY_CURRENT_USER
.
  • Para forzar la actualización de caché para una solicitud de certificado de usuario, elimine el valor de registro siguiente desde el cliente:
    HKEY_CURRENT_USER\Software\Microsoft\Cryptography\CertificateTemplateCache\Timestamp
Para forzar la actualización de caché para una solicitud de certificado de equipo:
  1. Elimine el valor del Registro siguiente desde el cliente:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Cryptography\CertificateTemplateCache\Timestamp
  2. Elimine el valor del Registro siguiente de la entidad emisora de CERTIFICADOS:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Cryptography\CertificateTemplateCache\Timestamp
  3. Reiniciar los servicios certificados en la entidad emisora de CERTIFICADOS.

Más información

In Addition to el mensaje de error anterior, la entidad emisora registra el siguiente mensaje de evento en el registro del programa:

Tipo de suceso: advertencia
Origen del suceso: CertSvc
Categoría del suceso: ninguna
ID. de suceso: 53
Fecha: 14/08/2000
Hora: 05: 13: 00
Usuario: N/d
Equipo: computername
Descripción:
Certificado Services denegados solicitan 4 porque la plantilla de certificado solicitado no es compatible con esta CA. 0x80094800 (-2146875392). La solicitud era para domain \ user. Obtener información adicional: denegado por el módulo de directivas

Propiedades

Id. de artículo: 281260 - Última revisión: lunes, 03 de diciembre de 2007 - Versión: 7.5
La información de este artículo se refiere a:
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Small Business Server 2003 Premium Edition
  • Microsoft Windows Small Business Server 2003 Standard Edition
Palabras clave: 
kbmt kberrmsg kbprb KB281260 KbMtes
Traducción automática
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Haga clic aquí para ver el artículo original (en inglés): 281260

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