Numéro d'article: 281307 - Dernière mise à jour: lundi 3 décembre 2007 - Version: 3.5

Windows XP and Windows Server 2003 n'est pas publié comme des serveurs Terminal Services

A noterCet article s'applique à un système d'exploitation différent de celui que vous utilisez. Le contenu de l'article qui ne vous concerne peut-être pas est désactivé.
Agrandir tout | Réduire tout

Symptômes

Lorsque vous recherchez des ordinateurs en utilisant l'outil Bureau à distance ou l'outil Client des services Terminal Server, ordinateurs Windows XP et DNS Windows Server 2003 avec Bureau à distance activé ne peuvent pas apparaître dans la liste d'ordinateurs disponibles. Ordinateurs Windows XP et DNS Windows Server 2003 avec Bureau à distance activé ne peuvent pas en outre apparaître à Microsoft Windows 2000 et Windows Server 2003 Terminal Services Manager.

Cause

Par défaut les serveurs seuls de services Terminal Server Windows Server 2003 et serveur Windows 2000 avec services Terminal Server installés dans une mode Serveur d'applications ou le mode d'administration à distance les annoncent comme des serveurs Terminal Services. Ce comportement facilite l'utilisation de la liste de parcours dans Bureau à distance et client des services Terminal Server et vérifie que les serveurs seuls de services Terminal Server s'affichent dans Windows 2000 et Gestionnaire des services Terminal Server Windows Server 2003.

Résolution

Important la section, la méthode ou la tâche contiennent les étapes qui indiquent à vous comment modifier le Registre. Problèmes graves peuvent se produire toutefois si vous modifiez de manière incorrecte le Registre. Vérifiez par conséquent que procède comme suit attentivement. Pour la protection ajoutée, sauvegardez le Registre avant de le modifier. Vous pouvez puis restaurer le Registre si un problème se produit. Pour plus d'informations sur sauvegarder et comment sur restaurer le Registre, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
322756  (http://support.microsoft.com/kb/322756/ ) Comment sauvegarder et restaurer le Registre dans Windows

Pour provoquer un ordinateur qui exécute Windows XP Professionnel ou Windows Server 2003, mais non configuré comme un serveur Terminal Services pour l'annoncer comme un serveur Terminal Services :
  1. Démarrez Éditeur du Registre (Regedit.exe).
  2. Recherchez la clé du Registre suivante et cliquez dessus
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Terminal Server
  3. Vous modifiez la valeur the
    TSAdvertise
    Valeur DWORD entre 0 sur 1.
  4. Quittez l'Éditeur du Registre
  5. Redémarrer l'ordinateur.
Remarque ordinateurs Windows Server 2003 configuré comme des serveurs Terminal Services, des serveurs Server ou serveurs Windows 2000 Advanced Server-based avec services Terminal Server installés dans une mode Serveur d'applications ou qui ont en mode déjà d'administration à distance the
TSAdvertise
Valeur de Registre a défini sur 1. Ces serveurs les annoncent par conséquent comme des serveurs Terminal Services.

Statut

Ce problème est inhérent à conception.

Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Tablet PC Edition
  • Microsoft Windows XP 64-Bit Edition Version 2002
  • Microsoft Windows XP 64-Bit Edition Version 2003
  • Microsoft Windows Server 2003, 64-Bit Datacenter Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Small Business Server 2003 Premium Edition
  • Microsoft Windows Small Business Server 2003 Standard Edition
Mots-clés : 
kbenv kbinfo KB281307 KbMtfr kbmt
Traduction automatiqueTraduction automatique
IMPORTANT : Cet article est issu du système de traduction automatique mis au point par Microsoft (http://support.microsoft.com/gp/mtdetails). Un certain nombre d?articles obtenus par traduction automatique sont en effet mis à votre disposition en complément des articles traduits en langue française par des traducteurs professionnels. Cela vous permet d?avoir accès, dans votre propre langue, à l?ensemble des articles de la base de connaissances rédigés originellement en langue anglaise. Les articles traduits automatiquement ne sont pas toujours parfaits et peuvent comporter des erreurs de vocabulaire, de syntaxe ou de grammaire (probablement semblables aux erreurs que feraient une personne étrangère s?exprimant dans votre langue !). Néanmoins, mis à part ces imperfections, ces articles devraient suffire à vous orienter et à vous aider à résoudre votre problème. Microsoft s?efforce aussi continuellement de faire évoluer son système de traduction automatique. Si vous relevez des erreurs graves et souhaitez contribuer à l?amélioration du système, vous pouvez compléter l?enquête à votre disposition dans le bas des articles.
La version anglaise de cet article est la suivante: 281307  (http://support.microsoft.com/kb/281307/en-us/ )
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.