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Connecting to SMB share on a Windows 2000-based computer or a Windows Server 2003-based computer may not work with an alias name

Article ID:281308
Last Review:February 21, 2007
Revision:1.11
This article was previously published under Q281308
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SYMPTOMS

When a client computer connects to a Microsoft Windows 2000-based computer or a Microsoft Windows Server 2003-based computer by using an alias name, the client may receive the following error message:
System error 52 has occurred.
A duplicate name exists on the network.

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CAUSE

This problem can occur when you try to connect to the server by using a CNAME alias that is created in the DNS zone. For example, this problem may occur with a command similar to the following sample command
net view \\alias.domain name.com
where alias is a CNAME record that is created for the server in the domain name.com zone. The server is not "listening" on the alias, and therefore is not accepting connections to that name.

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RESOLUTION

Windows 2000 Server

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 (http://support.microsoft.com/kb/322756/) How to back up and restore the registry in Windows
To resolve this problem, obtain and install the latest Windows 2000 service pack, and then edit the registry.To resolve this problem, obtain the latest service pack for Windows 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
260910 (http://support.microsoft.com/kb/260910/EN-US/) How to Obtain the Latest Windows 2000 Service Pack

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

File information

The English version of this fix should have the following file attributes or later:
   Date         Time   Version        Size       File name
   ----------------------------------------------------------
   02-Jul-2001  22:52  5.0.2195.3804  1,685,632  Ntkrnlmp.exe
   02-Jul-2001  22:53  5.0.2195.3804  1,685,312  Ntkrnlpa.exe
   02-Jul-2001  22:53  5.0.2195.3804  1,705,984  Ntkrpamp.exe
   02-Jul-2001  22:51  5.0.2195.3804  1,663,424  Ntoskrnl.exe
   02-Jul-2001  23:44  5.0.2195.3805    237,072  Srv.sys
   02-Jul-2001  23:53  5.0.2195.3805     73,488  Srvsvc.dll
				

Additionally, to resolve this problemin Windows 2000 Server you must complete all of the following steps:
1.Create the CNAME record for the file server on the appropriate DNS server, if the CNAME record is not already present.
2.Apply the hotfix to the computer for which the CNAME record was created, not the DNS server. (Unless the DNS server and file server in question is the same computer, and then all of the changes is applied is to that server.) This hotfix affects the LAN Manager Server Service and does not affect DNS functionality.
3.Apply the following registry change to the file server to which you installed the hotfix. To do so:
a. Start Registry Editor (Regedt32.exe).
b. Locate and click the following key in the registry:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\LanmanServer\Parameters
c. On the Edit menu, click Add Value, and then add the following registry value:
Value name: DisableStrictNameChecking
Data type: REG_DWORD
Radix: Decimal
Value: 1
d. Quit Registry Editor.
4.Restart your computer.

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Windows Server 2003

To resolve this problem in Windows Server 2003, complete the following steps:
1.Create the CNAME record for the file server on the appropriate DNS server, if the CNAME record is not already present.
2.Apply the following registry change to the file server. To do so, follow these steps:
a. Start Registry Editor (Regedt32.exe).
b. Locate and click the following key in the registry:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\LanmanServer\Parameters
c. On the Edit menu, click Add Value, and then add the following registry value:
Value name: DisableStrictNameChecking
Data type: REG_DWORD
Radix: Decimal
Value: 1
d. Quit Registry Editor.
3.Restart your computer.

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STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Windows 2000 Service Pack 3.

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MORE INFORMATION

For additional information about how to obtain a hotfix for Windows 2000 Datacenter Server, click the article number below to view the article in the Microsoft Knowledge Base:
265173 (http://support.microsoft.com/kb/265173/EN-US/) The Datacenter Program and Windows 2000 Datacenter Server Product
For additional information about how to install multiple hotfixes with only one reboot, click the article number below to view the article in the Microsoft Knowledge Base:
296861 (http://support.microsoft.com/kb/296861/EN-US/) Use QChain.exe to Install Multiple Hotfixes with One Reboot
This hotfix corrects the problem that is described in the following article in the Microsoft Knowledge Base: For additional information about how to install Windows 2000 and Windows 2000 hotfixes at the same time, click the article number below to view the article in the Microsoft Knowledge Base:
249149 (http://support.microsoft.com/kb/249149/EN-US/) Installing Microsoft Windows 2000 and Windows 2000 Hotfixes

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APPLIES TO
Microsoft Windows 2000 Server
Microsoft Windows 2000 Advanced Server
Microsoft Windows 2000 Professional Edition
Microsoft Windows Server 2003, Standard Edition

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Keywords: 
kbautohotfix kbhotfixserver kbqfe kbbug kbfix kboswin2000fix kbwin2000presp3fix kbwin2000sp3fix KB281308

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