Virtual Machine in einen angehaltenen Zustand wechselt oder ein CSV-Volume offline geschaltet wird, wenn Sie versuchen, eine Sicherung des virtuellen Computers auf einem Windows Server 2012-basierten Failover-Cluster erstellen

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Artikel-ID: 2813630 - Produkte anzeigen, auf die sich dieser Artikel bezieht
Wichtig: Das Hotfix, das die 2813630 KB entspricht wurde hinzugefügt, mit dem Hotfix KB-2878635 enthält alle Updates, die zuvor in KB 2813630 enthalten waren.
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Problembeschreibung

Betrachten Sie das folgende Szenario:
  • Sie aktivieren das Feature Cluster freigegebenen Volumes (CSV) auf einem Windows Server 2012-basierten Failover-Cluster.
  • Sie erstellen einen virtuellen Computer auf einem CSV-Volume auf einem Clusterknoten.
  • Sie können den virtuellen Computer starten.
  • Sie versuchen, eine Sicherung des virtuellen Computers mithilfe von Microsoft System Center Data Protection Manager (DPM) auf dem CSV-Volume erstellen.
In diesem Szenario tritt eines der folgenden Probleme:
  • Die Sicherung wird erstellt, und der virtuelle Computer wird angehalten.
  • Das CSV-Volume wird offline geschaltet. Aus diesem Grund der virtuelle Computer offline geschaltet wird und die Sicherung wird nicht erstellt.
Darüber hinaus werden die folgenden Ereignisse jeweils in dem Cluster und Systemprotokoll protokolliert:

Snapshot-Erstellung auf dem freigegebenen Cluster-Datenträger-Software ('Volume-Positionen") mit Snapshot-Id festlegen"Snapshot-id' Fehler bei 'HrError(0x80042308)(2147754760)'. Überprüfen Sie den Status der CSV-Ressourcen und die Systemereignisse Der Besitzerknoten der Ressource.

Protokollname: System
Quelle: Microsoft-Windows-FailoverClustering
Datum: Datum und Uhrzeit
Ereignis-ID: 5120
Aufgabenkategorie: Freigegebene Datenträger
Stufe: Fehler
Schlüsselwörter:
Benutzer: SYSTEM
Computer: Computername
Beschreibung: Das freigegebene Clustervolume 'Volume1' ('Name') ist wegen 'STATUS_IO_TIMEOUT(c00000b5)' nicht mehr auf diesem Knoten verfügbar. Alle i/o wird vorübergehend in die Warteschlange werden erst ein Pfad auf dem Datenträger wiederhergestellt ist.


Protokollname: System
Quelle: Microsoft-Windows-FailoverClustering
Datum: Datum und Uhrzeit
Ereignis-ID: 5142
Aufgabenkategorie: Freigegebene Datenträger
Stufe: Fehler
Schlüsselwörter:
Benutzer: SYSTEM
Computer: Computername
Beschreibung: Freigegebenes Clustervolume 'Volume3' ('Cluster Disk 4') ist aufgrund von Fehler 'ERROR_TIMEOUT(1460)' nicht mehr von diesem Cluster-Knoten zugänglich. Verwenden Sie zur Problembehandlung des Knotens an das Speichergerät und Netzwerkkonnektivität.


Hinweis Dieses Problem tritt auf, wenn Sie versuchen, mithilfe von Sicherungssoftware, die Microsoft Software Shadow Copy Provider verwendet einen Snapshot des virtuellen Computers zu erstellen.

Darüber hinaus wird auch folgende Verhalten beobachtet:
  • Wenn ein Administrator einen Snapshot eines Volumes CSV gestartet wird, möglicherweise ein Anstieg der Speicherauslastung auf den Knoten besitzen die CSV-Ressource. Dies entspricht der Anzahl von Bytes, die das Snapshot-Volumen von nicht besitzende Knoten gelesen werden. Installieren von diesem KB entfällt die Speicherverwendung.

Ursache

Der virtuelle Computer gibt angehalten, da der Ntfs.sys-Treiber bei die backup-Software versucht, einen Snapshot des CSV-Volumes erstellen der verfügbare Speicherplatz auf dem Volume CSV fälschlicherweise meldet. Darüber hinaus wird das CSV-Volume offline geschaltet, weil es nicht nach einem angehaltenen Status fortgesetzt wird, nachdem ein e/a-Verzögerungen Problem oder Fehler auftritt.

Hinweis Das CSV-Volume ist stabil.

Lösung

Hotfix-Informationen

Dieser Hotfix hält einen CSV-Failover durch die Festlegung eines zugrunde liegenden Problems in NTFS und Steigerung der allgemeinen Stabilität der Clusterdienst und CSV-während der erwarteten Pause Staaten.

Um CSV-Failover zu vermeiden, müssen Sie möglicherweise zusätzliche Änderungen am Computer vornehmen, nachdem Sie den Hotfix installieren. Beispielsweise können Sie das aufgrund mangelnder Hardwareunterstützung für abgeladenen Data Transfer (ODX) im Abschnitt "Problembeschreibung" beschriebene Problem vorliegen. Dadurch entstehen Verzögerungen, wenn die Betriebssystem-Abfragen für Hardware bei e/a-Anforderungen unterstützen.

Deaktivieren Sie in diesem Fall ODX durch Ändern des Werts " FilterSupportedFeaturesMode " für das Speichergerät, das ODX 1nicht unterstützt. Weitere Informationen zum Deaktivieren von ODX finden Sie auf der folgenden Microsoft-Website:
Allgemeine Informationen zum Bereitstellen von ODX
Ein unterstützter Hotfix ist von Microsoft erhältlich. Dieser Hotfix behebt jedoch nur das Problem, welches in diesem Artikel beschrieben wird. Wenden Sie diesen Hotfix nur auf Systeme an, bei denen dieses spezielle Problem auftritt.

Wenn der Hotfix zum Download zur Verfügung steht, ist gibt es ein Abschnitt "Hotfix Download Available" am oberen Rand dieser Knowledge Base-Artikel. Wenn dieser Link nicht angezeigt wird, senden Sie eine Anforderung an Microsoft Customer Service and Support, um den Hotfix zu erhalten.

Hinweis Falls weitere Probleme auftreten oder andere Schritte zur Problembehandlung erforderlich sind, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Die üblichen Support-Kosten gelten für zusätzliche Supportfragen und Probleme, die für diesen speziellen Hotfix nicht qualifizieren. Eine vollständige Liste der Microsoft-Kundendienst und Support-Telefonnummern bzw. Informationen zum Stellen einer separaten Serviceanfrage finden Sie auf der folgende Microsoft-Website:
http://support.Microsoft.com/contactus/?WS=Support
Hinweis Das Formular "Hotfix Download Available" zeigt die Sprachen an, für die der Hotfix verfügbar ist. Wenn Ihre Sprache nicht angezeigt wird, liegt es daran, dass kein Hotfix für diese Sprache verfügbar ist.

Erforderliche Komponenten

Um diesen Hotfix anwenden zu können, müssen Sie Windows Server 2012 ausgeführt werden.

Registrierungsinformationen

Um den Hotfix in diesem Paket verwenden zu können, müssen Sie keine Änderungen an der Registrierung vornehmen.

Ist ein Neustart erforderlich?

Sie müssen den Computer neu starten, nachdem Sie diesen Hotfix anwenden.

Ersetzte Hotfixes

Das Hotfix, der die 2813630 KB entspricht wurde ersetzt durch Hotfix KB 2878635.Hotfix KB 2878635contains alle Updates, die in KB-2813630 enthalten waren. Hotfix KB 2878635 verwenden Sie zum Beheben der Probleme, die in KB2813630 beschrieben werden. Weitere Informationen finden Sie im folgenden Artikel der Microsoft Knowledge Base:
2878635Update steht zur Verfügung, verbessert die Stabilität von Cloud-Dienstanbieter in Windows Server 2012: Dezember 2013

Dateiinformationen

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Die internationale Version dieses Hotfixes installiert Dateien mit den Attributen, die in den folgenden Tabellen aufgeführt sind. Die Datumsangaben und Uhrzeiten für diese Dateien werden in Coordinated Universal Time (UTC) aufgeführt. Die Datums- und Uhrzeitangaben für diese Dateien auf dem lokalen Computer werden in Ihrer lokalen Zeit zusammen mit Berücksichtigung der aktuellen Daylight Saving Time (DST) angezeigt. Darüber hinaus können die Datums- und Uhrzeitangaben ändern, wenn Sie bestimmte Operationen auf die Dateien anwenden.
Hinweise zu den Dateiinformationen für Windows Server 2012
Wichtig: Windows 8-Updates und Hotfixes für Windows Server 2012 sind im selben Paket enthalten. Allerdings nur "Windows 8" wird auf der Seite "Hotfix-Anforderung" aufgeführt. Um das Hotfix-Paket anzufordern, das für eines der oder beide Betriebssysteme gilt, wählen Sie den Hotfix, der unter "Windows 8" auf der Seite aufgeführt wird. Bezieht sich immer auf den Abschnitt "Beziehen sich auf" in Artikel, um das aktuelle Betriebssystem bestimmen, dem jeden Hotfix gilt.
  • Welche Dateien für bestimmte Produkte, Meilensteine (RTM, SPn), und Servicebereiche (LDR, GDR) identifiziert werden kann, durch die Versionsnummern der Datei untersuchen, wie in der folgenden Tabelle dargestellt:
    Tabelle minimierenTabelle vergrößern
    VersionProduktMeilensteinServicebereich
    6.2.920 0.20 XxxWindows Server 2012RTMLDR
  • Die MANIFEST-Dateien (. manifest) und MUM-Dateien (.mum), die installiert werden für jede Umgebung sind. separat aufgeführt in der "Weitere Dateiinformationen für und von Windows Server 2012" Section. MUM- und MANIFEST-Dateien sowie die zugehörigen Sicherheitskatalogdateien (.cat) sind sehr wichtig, um den Status der aktualisierten Komponenten beizubehalten. Die Sicherheitskatalogdateien, für die die Attribute nicht aufgelistet sind, sind mit einer digitalen Microsoft-Signatur signiert.
Für alle unterstützten X 64-basierten Versionen von Windows Server 2012
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DateinameDateiversionDateigrößeDatumUhrzeitPlattform
Csvflt.sys6.2.9200.20626205,82406-Feb-201323:17x64
ClusSvc.exe6.2.9200.206237,217,15207-Feb-201301:49x64
"NTFS.sys"6.2.9200.206231,933,54407-Feb-201303:15x64
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Status

Microsoft hat bestätigt, dass dieses Problem auf die im Abschnitt "Gilt für" aufgeführten Microsoft-Produkten zutrifft.

Weitere Informationen

Weitere Informationen zur Terminologie für Softwareupdates finden Sie im folgenden Artikel der Microsoft Knowledge Base:
824684 Beschreibung der Standardterminologie, die zum Beschreiben von Microsoft-Softwareupdates verwendet wird

Weitere Dateiinformationen

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Weitere Dateiinformationen für Windows Server 2012

Weitere Dateien für alle unterstützten X 64-basierten Versionen von Windows Server 2012
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DateinameAmd64_40330c5c9c42ac33c5f9fdeb46929af3_31bf3856ad364e35_6.2.9200.20626_none_c6d93c67e479d949.Manifest
DateiversionNicht zutreffend
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Datum (UTC)08-Feb-2013
Zeit (UTC)03:30
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DateiversionNicht zutreffend
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Datum (UTC)08-Feb-2013
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DateiversionNicht zutreffend
Dateigröße696
Datum (UTC)08-Feb-2013
Zeit (UTC)03:30
PlattformNicht zutreffend
DateinameAmd64_microsoft-Windows-f...Cluster-Csvflt-core_31bf3856ad364e35_6.2.9200.20626_none_1699369f5a54a7d6.manifest
DateiversionNicht zutreffend
Dateigröße4,685
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Zeit (UTC)03:58
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Eigenschaften

Artikel-ID: 2813630 - Geändert am: Freitag, 10. Januar 2014 - Version: 7.0
Die Informationen in diesem Artikel beziehen sich auf:
  • Windows Server 2012 Datacenter
  • Windows Server 2012 Standard
Keywords: 
kbautohotfix kbqfe kbhotfixserver kbfix kbsurveynew kbexpertiseadvanced kbmt KB2813630 KbMtde
Maschinell übersetzter Artikel
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Den englischen Originalartikel können Sie über folgenden Link abrufen: 2813630
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