Affichage d'un message d'erreur lorsque vous installez une mise à jour de produit ou un Service Pack Windows 2000

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Symptômes

Lorsque vous installez un Service Pack ou une mise à jour de produit (par exemple, une mise à jour critique, une mise à jour de sécurité, une mise à jour ou un correctif) sur un ordinateur Windows 2000, un message d'erreur semblable au suivant peut s'afficher :
Erreur d'installation du Service Pack
Impossible d'installer les fichiers catalogue
OK


Erreur d'installation KB123456
Le programme d'installation n'a pas pu vérifier l'intégrité du fichier Update.inf. Assurez-vous que le service cryptographique s'exécute sur cet ordinateur.
OK

Cause

Ce problème peut se produire lorsque l'une des conditions suivantes est remplie :

L'option 10, "Only trust items found in the trust DB" (Approuver seulement les éléments trouvés dans la base de données approuvée) des valeurs de clé d'état de publication logicielle a été modifiée sur la valeur TRUE (le paramètre par défaut est FALSE).

REMARQUE : pour vérifier le paramètre pour l'option 10, tapez setreg à une invite de commandes. ou

Le certificat "Microsoft Root Authority" ou "NO LIABILITY ACCEPTED, (c)97 VeriSign, Inc." sous les autorités de certification racines de confiance a été supprimé. ou

Le fichier %SYSTEMROOT%\system32\CatRoot\{F750E6C3-38EE-11D1-85E5-00C04FC295EE}\NT5INF.CAT est corrompu.

Résolution

Pour résoudre le problème si l'option 10 a été modifiée, tapez setreg 10 FALSE à une invite de commandes.

Pour résoudre le problème, si des certificats ont été supprimés, procédez comme suit :

  • Sur un ordinateur intégrant le certificat Microsoft Root Authority, procédez comme suit :
    1. Démarrez Microsoft Internet Explorer.
    2. Dans le menu Outils, cliquez sur Options Internet.
    3. Cliquez sur l'onglet Contenu, puis cliquez sur Certificats.
    4. Cliquez sur l'onglet Autorités principales de confiance.
    5. Faites défiler vers le bas jusqu'à ce que vous trouviez le certificat Microsoft Root Authority.
    6. Cliquez sur Exporter.
    7. Suivez les invites pour exporter le certificat vers le fichier binaire codé DER x.509 (.CER)
  • Sur l'ordinateur sur lequel vous ne pouvez pas installer le Service Pack ou le correctif, importez le certificat que vous avez enregistré dans les autorités de certification racines de confiance.
Pour résoudre le problème si le fichier NT5INF.CAT est endommagé ou corrompu, procédez comme suit :
  1. Utilisez l'outil EXPAND pour développer NT5INF.CA_ vers NT5INF.CAT.
  2. Redémarrez en mode sans échec, puis remplacez %SYSTEMROOT%\system32\CatRoot\{F750E6C3-38EE-11D1-85E5-00C04FC295EE}\NT5INF.CAT et %SYSTEMROOT%\system32\dllcache\nt5inf.cat par le fichier développé.REMARQUE : Pour afficher %SYSTEMROOT%\system32\dllcache\nt5inf.cat, dans l'Explorateur Windows, dans le menu Outils, cliquez sur Options des dossiers, puis cliquez sur l'onglet Affichage. Activez la case à cocher Afficher les fichiers et dossiers cachés, puis désactivez les cases à cocher Cacher les extensions des fichiers dont le type est connu et Masquer les fichiers protégés du système d'exploitation.

Propriétés

Numéro d'article: 281458 - Dernière mise à jour: jeudi 3 juin 2004 - Version: 2.0
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Datacenter Server
  • Microsoft Windows 2000 Professionel
  • Microsoft Windows 2000 Server
Mots-clés : 
kberrmsg kbsetup kbprb KB281458
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