Windows 2000 Service Pack または製品の更新インストール時のエラー メッセージ

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文書番号: 281458 - 対象製品
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現象

Windows 2000 ベース コンピュータに Service Pack または製品の更新 (たとえば、重要な更新、セキュリティ修正プログラム、更新、または修正プログラムなど) をインストールした場合、以下と同様のエラー メッセージが表示されることがあります。
Service Pack セットアップ エラー
Failed to install catalog files
OK


KB123456 セットアップ エラー
Update.inf の整合性を確認できませんでした。暗号化サービスがこのコンピュータで実行されていることを確認してください。
OK

原因

この現象は、以下のいずれかの条件に該当する場合に発生する可能性があります。

ソフトウェア発行状態キー値のオプション 10 [Only trust items found in the trust DB] が TRUE に変更された (デフォルト設定は FALSE です)。

: オプション 10 の設定を確認するには、コマンド プロンプトで setreg と入力します。

[信頼されたルート証明機関] の下の [Microsoft Root Authority] 証明書または [NO LIABILITY ACCEPTED, (c)97 VeriSign, Inc.] 証明書が削除された。

%SYSTEMROOT%\system32\CatRoot\{F750E6C3-38EE-11D1-85E5-00C04FC295EE}\NT5INF.CAT ファイルが破損している。

解決方法

オプション 10 が変更されている場合にこの問題を解決するには、コマンド プロンプトで setreg 10 FALSE と入力します。

証明書が削除されている場合にこの問題を解決するには、次の手順に従います。

  • [Microsoft Root Authority] 証明書がインストールされているコンピュータで、次の手順に従います。
    1. Microsoft Internet Explorer を起動します。
    2. [ツール] メニューの [インターネット オプション] をクリックします。
    3. [コンテンツ] タブをクリックし、[証明書] をクリックします。
    4. [信頼されたルート証明機関] タブをクリックします。
    5. スクロールして [Microsoft Root Authority ] 証明書を探します。
    6. [エクスポート] をクリックします。
    7. 指示に従って、証明書を DER encoded binary x.509(.CER) ファイルにエクスポートします。
  • Service Pack または修正プログラムをインストールできないコンピュータ上で、保存した証明書を [信頼されたルート証明機関] にインポートします。
NT5INF.CAT ファイルが破損している場合に問題を解決するには、以下の手順に従います。
  1. EXPAND ツールを使用して NT5INF.CA_ を NT5INF.CAT に展開します。
  2. セーフ モードで再起動し、%SYSTEMROOT%\system32\CatRoot\{F750E6C3-38EE-11D1-85E5-00C04FC295EE}\NT5INF.CAT および %SYSTEMROOT%\system32\dllcache\nt5inf.cat を展開されたファイルと置き換えます。. : %SYSTEMROOT%\system32\dllcache\nt5inf.cat をエクスプローラで表示するには、[ツール] メニューで [フォルダ オプション] をクリックし、[表示] タブをクリックします。次に [すべてのファイルとフォルダを表示する] をクリックしてオンにし、[登録されているファイルの拡張子は表示しない] および [保護されたオペレーティング システム ファイルを表示しない] チェック ボックスをクリックしてオフにします。

関連情報

この資料は米国 Microsoft Corporation から提供されている Knowledge Base の Article ID 281458 (最終更新日 2003-07-29) を基に作成したものです。

プロパティ

文書番号: 281458 - 最終更新日: 2003年10月1日 - リビジョン: 2.0
この資料は以下の製品について記述したものです。
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Datacenter Server
  • Microsoft Windows 2000 Professional
  • Microsoft Windows 2000 Server
キーワード:?
kberrmsg kbsetup kbprb KB281458
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"

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