Mensagem de erro quando instala um Service Pack ou uma actualização de produto do Windows 2000

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Sintomas

Quando instala um Service Pack ou uma actualização de produto (por exemplo, uma actualização crítica, um patch de segurança, uma actualização ou uma correcção) num computador baseado no Windows 2000, poderá receber uma mensagem de erro semelhante à seguinte:
Erro de configuração do Service Pack
Falha ao instalar ficheiros de catálogo
OK

[Service Pack Setup Error
Failed to install catalog files
OK]


Erro de configuração do KB123456
O programa de configuração não conseguiu verificar a integridade do ficheiro Update.inf. Certifique-se de que o serviço criptográfico está em execução neste computador.
OK

[KB123456 Setup Error
Setup could not verify the integrity of the file Update.inf. Make sure the cryptographic service is running on this computer.
OK]

Causa

Este comportamento pode ocorrer caso se verifique uma das seguintes condições:

A opção 10, "Only trust items found in the trust DB", dos valores da chave do estado de publicação do software foi alterada para TRUE (a predefinição é FALSE).

NOTA: para verificar a definição da opção 10, escreva setreg numa linha de comandos. - ou -

Foi removido o certificado "Microsoft Root Authority" ou o certificado "NO LIABILITY ACCEPTED, (c)97 VeriSign, Inc." das autoridades de certificação de raiz fidedigna. - ou -

O ficheiro %SYSTEMROOT%\system32\CatRoot\{F750E6C3-38EE-11D1-85E5-00C04FC295EE}\NT5INF.CAT está danificado.

Resolução

Para resolver este problema se a opção 10 tiver sido alterada, escreva setreg 10 FALSE numa linha de comandos.

Para resolver o problema se tiverem sido removidos certificados, siga estes passos:

  • Num computador com o certificado Microsoft Root Authority instalado, siga estes passos:
    1. Inicie o Microsoft Internet Explorer.
    2. No menu Ferramentas (Tools), clique em Opções da Internet (Internet Options).
    3. Clique no separador Conteúdo (Content) e clique em Certificados (Certificates).
    4. Clique no separador Autoridades de certificação de raiz fidedigna (Trusted Root Certification Authorities).
    5. Desloque o ecrã para baixo até localizar o certificado Microsoft Root Authority.
    6. Clique em Exportar (Export).
    7. Siga as informações apresentadas para exportar o certificado como um ficheiro binário codificado X.509 DER (.CER).
  • No computador no qual não consegue instalar o Service Pack ou a correcção, importe o certificado guardado para as autoridades de certificação de raiz fidedigna.
Para resolver o problema se o ficheiro NT5INF.CAT estiver danificado, siga estes passos:
  1. Utilize a ferramenta EXPAND para expandir NT5INF.CA_ para NT5INF.CAT.

    Nota: o ficheiro Nt5inf.ca_ encontra-se no disco de instalação do Windows 2000, na pasta i386.
  2. Reinicie no modo de segurança e substitua %SYSTEMROOT%\system32\CatRoot\{F750E6C3-38EE-11D1-85E5-00C04FC295EE}\NT5INF.CAT e %SYSTEMROOT%\system32\dllcache\nt5inf.cat pelo ficheiro expandido.NOTA: para ver %SYSTEMROOT%\system32\dllcache\nt5inf.cat, no Explorador do Windows (Windows Explorer), no menu Ferramentas (Tools), clique em Opções de pastas (Folder Options) e clique no separador Ver (View). Clique para seleccionar Mostrar ficheiros e pastas ocultos (Show hidden files and folders) e clique para desmarcar Ocultar extensões de ficheiros de tipos de ficheiro conhecidos (Hide extensions for known file types) e Ocultar ficheiros protegidos do sistema operativo (Hide protected operating system files).

Propriedades

Artigo: 281458 - Última revisão: 3 de fevereiro de 2006 - Revisão: 2.1
A informação contida neste artigo aplica-se a:
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Datacenter Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Server
Palavras-chave: 
kberrmsg kbprb kbsetup KB281458

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