Enabling Debug mode causes Windows to hang if no Debugger is connected

Article ID: 2816225 - View products that this article applies to.
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Symptoms

On a computer that is running Windows 7 or Windows Server 2008 R2, after installing Debugging Tools for Windows, the Operating System with debug mode enabled may hang if an application throws user-mode exception.

Cause

When Debug mode is enabled and the debugger has not connected due to the user mode exception, the system will hang waiting for a debugger to intervene from the breakpoint.

Resolution

To resolve this problem, disable Debug mode using one of the methods below:

  • Using System Configuration settings
  1. Using keyboard press, Windows Key+R to open Run box
  2. Type MSCONFIG and then press Enter
  3. Select Boot tab and then select Advanced options
  4. Uncheck on the Debug check box
  5. Click on OK
  6. Click on Apply and then OK
  7. Restart the computer
  • Using Command Line Interface
  1. Open an elevated Command prompt
  2. Type the following command and press Enter:
    bcdedit -debug off

  3. Restart the computer

More Information

Note that Windows should not be run in Debug mode permanently. Debug mode is enabled for connecting to Kernel Debug using Debuggers like Debugging Tools for Windows (WinDbg) and must be turned off once the purpose is accomplished.

Some Windows 7 systems might be shipped with DEBUG switch enabled, ensure to disable it.

To download Debugging Tools for Windows and more information, visit the following Microsoft Website:

http://msdn.microsoft.com/en-us/windows/hardware/gg463009.aspx

Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use for other considerations.

Properties

Article ID: 2816225 - Last Review: February 20, 2013 - Revision: 1.0
Applies to
  • Windows 7 Enterprise
  • Windows 7 Home Premium
  • Windows 7 Professional
  • Windows Server 2008 R2 Enterprise
  • Windows Server 2008 R2 Standard
Keywords: 
KB2816225

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