Make New Connection Wizard Selections Are Unavailable and Other Issues Occur with the Network Connections Folder

Article translations Article translations
Article ID: 281625 - View products that this article applies to.
This article was previously published under Q281625
Expand all | Collapse all

On This Page

SYMPTOMS

When you use the Network Connections folder, you may experience any of the following issues:
  • When you are using the Make New Connection Wizard, only the Dial-up to the Internet option is available.
  • When you right-click a connection in the Network and Dial-Up Connections folder, you cannot open the connection properties.
  • When you use the Make New Connection Wizard, only the Dial-up to the Internet option and the Accept Incoming connections option are available.

CAUSE

These issues may occur if any of the following conditions are true:
  • A program has installed a duplicate Rasapi32.dll file in either the Winnt folder or the %SystemRoot% folder, or an Rasapi32.dll file is present on the desktop.
  • The Telephony service is stopped.
  • The Remote Access Connection Manager service is stopped.
  • The users profile is corrupted.

RESOLUTION

To resolve these issues, the methods that are described in this section.

Rename Duplicate Rasapi32.dll Files

Windows 2000 has one Rasapi32.dll file and it is located in the %SystemRoot%\System32 folder. To determine if you have more than one Rasapi32.dll file:
  1. Click Start, and then click Find Files and Folders.
  2. Type rasapi32.dll in the Find files or folders named box, and then click Find now.
  3. Rename any Rasapi32.dll file that is not located in the %SystemRoot%\System32 folder.
If you do not find any duplicates or if you rename the duplicate files and the issue still occurs, perform the following procedure.

Start the Telephony Service Using the Computer Management Snap In

  1. Right-click My Computer, and then click Manage.
  2. Click Services.
  3. In the right pane, right-click Telephony, and then click Properties.
  4. Under Service Status, click Start, and then click OK.
If you restart the Telephony service and this issue still occurs, follow steps 1 to 4 to start the Remote Access Connection Manager service.

Edit the Registry

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 How to back up and restore the registry in Windows
  1. Start Registry Editor.
  2. Make a backup copy of the following registry key:
    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Telephony\Cards\Next
  3. Delete the following value:
    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Telephony\Cards\Next
  4. Quit and then restart the Make New Connection Wizard. All of the network connection options are now available.

    NOTE: The Accept Incoming Calls option is dependent on the user's assigned user rights.
  5. Perform steps 1 to 4 for all the users who are logged on to the workstation.
To prevent this behavior from occurring with new users, modify the default user profile:
  1. Use Regedt32.exe to load the Ntuser.dat hive from the C:\Documents and Settings\Default User folder.
  2. Delete the following value:
    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Telephony\Cards\Next
  3. Unload the hive.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
254370 ISP Client Software Compatibility with Windows 2000

Properties

Article ID: 281625 - Last Review: January 29, 2007 - Revision: 4.3
APPLIES TO
  • Microsoft Windows 2000 Standard Edition
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
Keywords: 
kbprb KB281625

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com