Help and Support

Id. de artículo: 281679 - Última revisión: martes, 04 de marzo de 2008 - Versión: 7.13

No puede abrir una ventana nueva de Internet Explorer o no sucede nada cuando hace clic en un vínculo

Este artículo se publicó anteriormente con el número E281679

En esta página

Expandir todo | Contraer todo

Síntomas

Cuando se hace clic en un hipervínculo en un mensaje de correo electrónico o en una página web, o se hace clic con el botón secundario del mouse en un hipervínculo en una página web y, a continuación, se hace clic en Abrir en una ventana nueva, es posible que se produzcan uno o varios de los síntomas siguientes:
  • No ocurre nada.
  • La nueva ventana puede estar en blanco.
  • Puede aparecer también un mensaje de error de scripting similar al siguiente:
    No se admite esa interfaz.
  • Internet Explorer puede no responder cuando se hace clic en Imprimir o en Vista preliminar en el menú Archivo.
Cuando se intenta conectar con carpetas web, es posible que aparezca el siguiente mensaje de error:
No se pudo completar la operación actual debido a un error inesperado.

Causa

Este comportamiento puede ocurrir por uno o más de los motivos siguientes:
  • La configuración de valor (Predeterminado) de una o varias de las siguientes claves del Registro apunta a una ubicación incorrecta para el archivo Urlmon.dll:
    [HKEY_CLASSES_ROOT\CLSID\{79eac9e0-baf9-11ce-8c82-00aa004ba90b}\InprocServer32]
    [HKEY_CLASSES_ROOT\CLSID\{79eac9f1-baf9-11ce-8c82-00aa004ba90b}\InprocServer32]
    [HKEY_CLASSES_ROOT\CLSID\{79eac9f2-baf9-11ce-8c82-00aa004ba90b}\InprocServer32]
    Este comportamiento se puede producir si instala una versión personalizada de Internet Explorer que se creó con el Kit de administración de Internet Explorer (IEAK) versión 5.01 Service Pack 1, (SP1) 5.5 SP1 o 6.0.
  • La siguiente clave del Registro no está o está dañada:
    HKLM\SOFTWARE\Classes\Interface\{00020400-0000-0000-C000-000000000046}
  • Uno o más de los siguientes archivos falta, está dañado o está incorrectamente registrado:
    • Urlmon.dll
    • Mshtml.dll
    • Actxprxy.dll
    • Oleaut32.dll
    • Shell32.dll
    • Shdocvw.dll

Solución

Para resolver el problema en Internet Explorer, siga estos pasos:
  1. Salga de todos los programas que haya en ejecución.
  2. Haga clic en Inicio y, a continuación, en Ejecutar.
  3. Escriba regsvr32 urlmon.dll y, a continuación, haga clic en Aceptar.
  4. Cuando aparezca el mensaje "DllRegisterServer and DllInstall in urlmon.dll succeeded", haga clic en Aceptar.
Si esto no resuelve el problema, repita los pasos 2 a 4 para cada uno de los archivos siguientes (en el paso 3, reemplace Urlmon.dll por cada uno de los nombres de archivo siguientes):
  • Shdocvw.dll
  • Actxprxy.dll
  • Oleaut32.dll
  • Mshtml.dll
  • Browseui.dll
  • Shell32.dll

Windows XP y Windows 2000 únicamente

Reinicie el equipo para que los cambios surtan efecto.

Si el problema sigue sin resolverse, compruebe que los siguientes valores del Registro existen y son correctos:
HKLM\SOFTWARE\Classes\Interface\{00020400-0000-0000-C000-000000000046}
Nombre: (predeterminado)
Valor: IDispatch
HKLM\SOFTWARE\Classes\Interface\{00020400-0000-0000-C000-000000000046}\ProxyStubClsid
Nombre: (predeterminado)
Valor: {00020420-0000-0000-C000-000000000046}
HKLM\SOFTWARE\Classes\Interface\{00020400-0000-0000-C000-000000000046}\ProxyStubClsid32
Nombre: (predeterminado)
Valor: {00020420-0000-0000-C000-000000000046}


Si con esto tampoco se resuelve el problema, reinstale Internet Explorer. Si utiliza la versión de Internet Explorer incluida con el sistema operativo, instale de nuevo o repare el sistema operativo.

Usuarios del Kit de administración de Internet Explorer

Si este problema se produce después de instalar una versión personalizada de Internet Explorer que se creó con el Kit de administración de Internet Explorer (IEAK) versión 5.01 Service Pack 1 (SP1), 5.5 SP1 ó 6.0, y se resuelve al volver a registrar el archivo Urlmon.dll, póngase en contacto con los Servicios de soporte técnico de Microsoft para obtener la revisión apropiada de las siguientes.

IEAK para Internet Explorer 6

Hay disponible una revisión para la que Microsoft proporciona soporte técnico. Sin embargo, esta revisión sólo se diseñó para corregir el problema descrito en este artículo. Aplíquela solamente en los sistemas que experimenten este problema específico.

Para resolver este problema, envíe una solicitud a los servicios al cliente en línea de Microsoft con el fin de obtener la revisión. Para enviar una solicitud en línea y obtener la revisión, visite el siguiente sitio web de Microsoft:
http://go.microsoft.com/?linkid=6294451 (http://go.microsoft.com/?linkid=6294451)
Nota: si se producen más problemas o si hay que solucionarlos, es posible que tenga que crear una solicitud de servicio independiente. Se aplicarán los costos de soporte técnico habituales a las preguntas y problemas de soporte técnico adicionales que no reúnan las condiciones necesarias para esta revisión en cuestión. Para crear una solicitud de servicio independiente, visite el siguiente sitio web de Microsoft:
http://support.microsoft.com/default.aspx?scid=fh;[LN];CNTACTMS (http://support.microsoft.com/default.aspx?scid=fh;%5Bln%5D;cntactms)


La versión en inglés de esta revisión tiene los atributos de archivo enumerados en la siguiente tabla u otros posteriores. Las fechas y las horas de estos archivos se muestran según la hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para ver la diferencia entre la hora UTC y la hora local, utilice la ficha Zona horaria de la herramienta Fecha y hora del Panel de control.
Contraer esta tablaAmpliar esta tabla
FechaHoraVersiónTamañoNombre de archivo
11-oct-0119:456.0.2710.1100189.440Ie6wzd.exe
Nota: esta revisión no se distribuye mediante un paquete de instalación, sino que se trata de una revisión real binaria que debe reemplazarse de forma manual. Para ello, cambie el nombre del archivo Ie6wzd.exe antiguo en la carpeta Instalación de IEAK\Iebin\Optional\EN, copie manualmente la revisión en esa carpeta y, a continuación, vuelva a crear el paquete IEAK para que se incluya en él.

Importante: si aplica AVS (Automatic Version Synchronization, Sincronización automática de versión) a la instalación de IEAK después de utilizar esta corrección, deberá aplicar de nuevo la revisión de forma manual.

IEAK para Internet Explorer 5.5

Ahora hay disponible una revisión para la que Microsoft proporciona soporte técnico, pero sólo se diseñó para corregir el problema que describe este artículo. Aplíquelo sólo a sistemas que experimenten este problema específico.

Para resolver el problema, póngase en contacto con los Servicios de soporte técnico de Microsoft con el fin de obtener la revisión. Para obtener una lista completa de los números de teléfono de los Servicios de soporte técnico de Microsoft, así como información acerca de los costos de soporte técnico, visite el siguiente sitio web de Microsoft:
http://support.microsoft.com/default.aspx?scid=fh;[LN];CNTACTMS (http://support.microsoft.com/default.aspx?scid=fh;%5Bln%5D;cntactms)
Nota: en casos especiales, los costos derivados de las llamadas al soporte técnico pueden cancelarse si un profesional de soporte técnico de Microsoft determina que una actualización específica resolverá el problema. Se aplicarán los costos habituales de soporte técnico a las consultas y problemas de soporte técnico adicionales que no guarden relación con la actualización en cuestión.

La versión en inglés de esta revisión tiene los atributos de archivo enumerados en la siguiente tabla u otros posteriores. Las fechas y las horas de estos archivos se muestran según la hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para ver la diferencia entre la hora UTC y la hora local, utilice la ficha Zona horaria de la herramienta Fecha y hora del Panel de control.
Contraer esta tablaAmpliar esta tabla
FechaHoraVersiónTamañoNombre de archivo
18-dic-0017:225.50.4612.1800183.056Ie5wzd.exe
Nota: esta revisión no se distribuye mediante un paquete de instalación, sino que se trata de una revisión real binaria que debe reemplazarse de forma manual. Para ello, cambie el nombre del archivo Ie5wzd.exe antiguo en la carpeta Instalación de IEAK\Iebin\Optional\EN, copie manualmente la revisión en esa carpeta y, a continuación, vuelva a crear el paquete IEAK para que la revisión se incluya en él.

Importante: si aplica AVS a la instalación de IEAK después de utilizar esta corrección, deberá aplicarla de nuevo de forma manual.

IEAK para Internet Explorer 5.01

Ahora hay disponible una revisión para la que Microsoft proporciona soporte técnico, pero sólo se diseñó para corregir el problema que describe este artículo. Aplíquelo sólo a sistemas que experimenten este problema específico.

Para resolver el problema, póngase en contacto con los Servicios de soporte técnico de Microsoft con el fin de obtener la revisión. Para obtener una lista completa de los números de teléfono de los Servicios de soporte técnico de Microsoft, así como información acerca de los costos de soporte técnico, visite el siguiente sitio web de Microsoft:
http://support.microsoft.com/default.aspx?scid=fh;[LN];CNTACTMS (http://support.microsoft.com/default.aspx?scid=fh;%5Bln%5D;cntactms)
Nota: en casos especiales, los costos derivados de las llamadas al soporte técnico pueden cancelarse si un profesional de soporte técnico de Microsoft determina que una actualización específica resolverá el problema. Se aplicarán los costos habituales de soporte técnico a las consultas y problemas de soporte técnico adicionales que no guarden relación con la actualización en cuestión.

La versión en inglés de esta revisión tiene los atributos de archivo enumerados en la siguiente tabla u otros posteriores. Las fechas y las horas de estos archivos se muestran según la hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para ver la diferencia entre la hora UTC y la hora local, utilice la ficha Zona horaria de la herramienta Fecha y hora del Panel de control.
Contraer esta tablaAmpliar esta tabla
FechaHoraVersiónTamañoNombre de archivo
01-nov-0011:01a5.0.3210.3100177.424Ie5wzd.exe
Nota: esta revisión no se distribuye mediante un paquete de instalación, sino que se trata de una revisión real binaria que debe reemplazarse de forma manual. Para ello, cambie el nombre del archivo Ie5wzd.exe antiguo en la carpeta Instalación de IEAK\Iebin\Optional\EN, copie manualmente la revisión en esa carpeta y, a continuación, vuelva a crear el paquete IEAK para que la revisión se incluya en él.

Importante: si aplica AVS a la instalación de IEAK después de utilizar esta corrección, deberá aplicar de nuevo la revisión de forma manual.


La información de este artículo se refiere a:
  • Microsoft Internet Explorer 6.0
  • Microsoft Internet Explorer 5.5
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.0
Palabras clave: 
kbhotfixserver kbqfe kbbug kbenv kbfix kbie550presp2fix kbie600presp1fix kbie600sp1fix KB281679

Seleccione idioma

 

Related Support Centers