Non accade nulla quando si fa clic su un collegamento in Internet Explorer

Avviso

L'applicazione desktop Internet Explorer 11, ritirata e fuori supporto, è stata disabilitata in modo permanente tramite un aggiornamento di Microsoft Edge su alcune versioni di Windows 10. Per altre informazioni, vedere Domande frequenti sul ritiro delle app desktop di Internet Explorer 11.

Questo articolo consente di risolvere il problema di una pagina Web che si apre quando si fa clic su un collegamento ipertestuale in Internet Explorer.

Versione originale del prodotto: Internet Explorer 9
Numero originale della Knowledge Base: 175775

Sintomi

Quando si fa clic su un collegamento ipertestuale in una pagina Web o in un messaggio di posta elettronica, non accade nulla. Internet Explorer non apre la pagina Web.

Nota

Questa informazione si applica a Internet Explorer 9, Internet Explorer 8, and Internet Explorer 7.

Causa

Questo può verificarsi per uno o più dei seguenti motivi:

  • L'impostazione in cui si sceglie il Web browser da usare è danneggiata. Ciò può far sì che Windows interpreti erroneamente quale browser è impostato come browser predefinito nel computer.
  • Dopo l'installazione del software, le impostazioni sono state modificate e questo può causare l'errato funzionamento dei collegamenti alle pagine Web.
  • Un browser o un componente aggiuntivo installato in precedenza potrebbe interferire con altri software nel computer.
  • Le chiavi del Registro di sistema sono state modificate o sono state danneggiate.

Risoluzione

Questo articolo è destinato a utenti di livello principiante e intermedio. Se questi metodi non consentono di risolvere il problema, è possibile provare quelli indicati nella sezione Risoluzione dei problemi avanzata Per risolvere il problema, utilizzare i metodi descritti di seguito nell'ordine in cui vengono presentati.

Metodo 1: controllare l'impostazione predefinita del Web browser

In Microsoft Windows è possibile selezionare il Web browser da usare. Per rendere Internet Explorer il Web browser predefinito, seguire questi passaggi:

  1. Per aprire Internet Explorer fare clic su Start e quindi su Internet Explorer.
  2. Se viene richiesto di confermare che Internet Explorer deve essere il browser predefinito, fare clic su .
  3. Scegliere Opzioni Internet dal menu Strumenti.
  4. Fare clic su Programmi>Rendi predefinito>OK e quindi chiudere Internet Explorer.

Nota

Le modifiche saranno applicate al prossimo avvio di Internet Explorer.

Verificare se il problema è stato risolto. Se il problema è risolto, si può interrompere la lettura dell'articolo. Se il problema persiste, provare il metodo successivo.

Metodo 2: modificare i tipi di file aperti da Internet Explorer per impostazione predefinita

Per Windows 7 e Windows Vista.

  1. Chiudere tutte le finestre di Internet Explorer.
  2. Fare clic sul pulsante Start e quindi scegliere Pannello di controllo.
  3. Fare clic su Programmi e quindi su Imposta programmi predefiniti.
  4. Dal menu Programmi, fare clic su Internet Explorer poi scegliere Scegli i valori predefiniti per questo programma.
  5. Assicurarsi che le caselle di controllo per .htm, .html e urls siano selezionate e quindi fare clic su Salva.
  6. Fare clic su OK.

Nota

Le modifiche saranno applicate al prossimo avvio di Internet Explorer.

Per Windows XP

  1. Per aprire Windows Explorer, fare clic con il pulsante destro del mouse su Start e quindi scegliere Risorse del computer.

  2. Fare clic su Opzioni cartella nel menu Strumenti, quindi fare clic sulla scheda Tipi di file.

  3. Individuare e selezionare il tipo di file HTM.

  4. Assicurarsi che Internet Explorer sia selezionato come programma Apri con. Se Internet Explorer non è selezionato, fare clic su Modifica, selezionare Internet Explorer come programma consigliato e quindi fare clic su OK.

  5. Ripetere i passaggi 3 e 4 per i seguenti tipi di file:

    • HTML
    • ITS
    • MHT
    • MTHML
    • XML
    • XSL

Verificare se il problema è stato risolto. Se il problema è risolto, si può interrompere la lettura dell'articolo. Se il problema persiste, procedere al metodo successivo.

Metodo 3: usare la modalità Nessun componente aggiuntivo di Internet Explorer

Sebbene i componenti aggiuntivi possano migliorare l'esperienza utente, talvolta interferiscono o creano conflitti con altri software sul computer. Tuttavia, tenere presente che alcune pagine Web, o Internet Explorer stesso, potrebbero non essere visualizzate correttamente se un componente aggiuntivo è disabilitato. Per prima cosa, avviare Internet Explorer con i componenti aggiuntivi temporaneamente disabilitati per verificare se il problema si risolve. I componenti aggiuntivi verranno disabilitati solo fino al riavvio di Internet Explorer nel modo consueto. A tal fine, attenersi alla seguente procedura:

  • Fare clic sul pulsante Start, digitare Internet Explorer nella casella di ricerca e quindi fare clic su Internet Explorer (Nessun componente aggiuntivo).

    Nota

    Per Windows XP, fare clic su Start, fare clic con il pulsante destro del mouse sull'icona di Internet Explorer e quindi scegliere Sfoglia senza componenti aggiuntivi.

Se la modalità Internet Explorer Nessun componente aggiuntivo risolve il problema, seguire questa procedura per identificare il componente aggiuntivo del browser che causa il problema:

  1. Per avviare Internet Explorer, fare clic su Start, quindi fare clic su Internet Explorer.
  2. Fare clic sul pulsante Strumenti, quindi fare clic su Gestione componenti aggiuntivi.
  3. Fare clic su un componente aggiuntivo nell'elenco Nome e quindi su Disabilita. Provare Internet Explorer.
  4. Ripetere il passaggio 3 fino a identificare il componente aggiuntivo che causa il problema.

Verificare se il problema è stato risolto. Se il problema è risolto, si può interrompere la lettura dell'articolo. Se il problema persiste, provare il metodo successivo.

Metodo 4: ripristinare le impostazioni di Internet Explorer

Se il problema è causato da impostazioni o componenti aggiuntivi di Internet Explorer danneggiati o incompatibili, è in genere possibile risolvere il problema riportando Internet Explorer alle impostazioni predefinite.

Quando si ripristinano le impostazioni di Internet Explorer, tutte le impostazioni precedenti vengono perse e non possono essere recuperate. Quando si ripristinano le impostazioni predefinite di Internet Explorer, alcune pagine Web che si basano su cookie precedentemente memorizzati, dati di moduli, password o componenti aggiuntivi del browser precedentemente installati potrebbero non funzionare correttamente. Il ripristino delle impostazioni predefinite di Internet Explorer non elimina i preferiti, i feed e diverse altre impostazioni personalizzate.

Per ripristinare Internet Explorer, attenersi alla seguente procedura:

  1. Chiudere tutte le finestre di Internet Explorer.

  2. Fare clic su Start, digitare inetcpl.cpl nella casella di ricerca, quindi fare clic su inetcpl.cpl nell'elenco Programmi. Verrà visualizzata la finestra di dialogo Opzioni Internet.

    Nota

    In Windows XP, fare clic su Start, scegliere Esegui, digitare inetcpl.cpl nella casella Apri, quindi fare clic su OK.

  3. Fare clic sulla scheda Avanzate.

  4. In Reimposta Internet Explorer, fare clic su Reimposta. Quindi fare di nuovo clic su Reimposta.

  5. Al termine della reimpostazione di Internet Explorer, fare clic su Chiudi nella finestra di dialogo Reimposta Internet Explorer.

  6. Riavviare Internet Explorer. Le modifiche saranno applicate quando si apre Internet Explorer la volta successiva.

Metodo 5: registrare nuovamente i file DLL di Internet Explorer necessari

Nota

Queste informazioni si applicano a Windows XP

Per registrare nuovamente i file DLL, attenersi alla seguente procedura:

  1. Fare clic su Start, scegliere Tutti i programmi, fare clic su Accessori, fare clic con il pulsante destro del mouse su cmd e scegliere Esegui come amministratore. Se viene chiesto di immettere la password dell'amministratore o di confermare, digitare la password o fornire la conferma.

  2. Digitare regsvr32 urlmon.dll nella casella Apri, quindi selezionare OK.

  3. Scegliere OK quando si riceve la conferma.

  4. Ripetere i passaggi 2 e 3 per i seguenti comandi:

    • regsvr32 mshtml.dll
    • regsvr32 shdocvw.dll
    • regsvr32 browseui.dll
    • regsvr32 msjava.dll

Verificare se il problema è stato risolto. Se il problema è risolto, si può interrompere la lettura dell'articolo. Se il problema persiste, procedere alla sezione successiva.

Risoluzione avanzata dei problemi

Questa sezione è riservata agli utenti più esperti.

Metodo 1: creare un nuovo account utente

Per altre informazioni sui profili utente, vedere Informazioni sui profili utente.

Per dettagli su questo metodo, visitare i seguenti siti Web Microsoft:

Metodo 2: utilizzare Ripristino configurazione di sistema

Ripristino configurazione di sistema usa i punti di ripristino per restituire i file di sistema e le impostazioni a un momento precedente senza influire sui file personali. I punti di ripristino vengono creati automaticamente ogni settimana e immediatamente prima di eventi di sistema significativi, ad esempio l'installazione di un programma, un dispositivo o un driver.

Prima di avviare Ripristino configurazione di sistema, salvare tutti i file aperti e chiudere tutti i programmi. In seguito alla conferma del punto di ripristino, Ripristino configurazione di sistema riavvia il computer. Per eseguire Ripristino configurazione di sistema, attenersi alla seguente procedura:

Per Windows 7 e Windows Vista

  1. Fare clic su Start, scegliere Tutti i programmi, quindi Accessori, fare clic su Utilità di sistema, quindi su Ripristino configurazione di sistema. Se viene chiesto di immettere la password dell'amministratore o di confermare, digitare la password o fornire la conferma.

  2. Fare clic su Avanti nella pagina Ripristino configurazione di sistema.

  3. Selezionare la data di ripristino del sistema o la descrizione desiderata.

    Nota

    Se non viene visualizzata la data specifica desiderata, selezionare Mostra altre date e quindi selezionare la data desiderata.

  4. Nella finestra di conferma fare clic su Fine. Il computer verrà riavviato. Al termine del processo, si riceverà un messaggio di conferma.

Per Windows XP

  1. Accedere a Windows utilizzando un account con diritti di amministratore.
  2. Fare clic su Start, scegliere Tutti i programmi, quindi Accessori, fare clic su Utilità di sistema, quindi su Ripristino configurazione di sistema.
  3. Nella pagina Benvenuti in Ripristino configurazione di sistema, fare clic per selezionare l'opzione Ripristina il computer alle impostazioni di sistema precedenti, quindi fare clic su Avanti.
  4. Nella pagina Seleziona un punto di ripristino, fare clic sul punto di ripristino del sistema più recente in questo elenco, fare clic su elenco punto di ripristino, quindi fare clic su Avanti.
  5. Nella pagina Conferma selezione del punto di ripristino, fare clic su Avanti. Ripristino configurazione di sistema ripristina la configurazione di Windows XP precedente e quindi riavvia il computer.
  6. Accedere al computer come amministratore. Quindi, fare clic su OK nella pagina Ripristino configurazione di sistema completato. Il computer verrà riavviato. Al termine del processo, si riceverà un messaggio di conferma.

Se si usa Ripristino configurazione di sistema ma il problema persiste o si verificano altri problemi, è possibile annullare l'operazione di ripristino. Dopo aver annullato l'operazione, è possibile provare a usare un punto di ripristino diverso. Per annullare un'operazione di ripristino del sistema, seguire questa procedura:

  1. Fare clic su Start, scegliere Tutti i programmi, quindi Accessori, fare clic su Utilità di sistema, quindi su Ripristino configurazione di sistema.
  2. Fare clic su Annulla Ripristino configurazione di sistema, quindi su Avanti.
  3. Rivedere le selezioni, quindi fare clic su Fine.

Il computer verrà riavviato. Al termine del processo, si riceverà una conferma.

Risorse aggiuntive

Verificare se il problema è stato risolto. Se il problema è risolto, si può interrompere la lettura dell'articolo. Se il problema non è risolto si può utilizzare il Servizio Supporto Tecnico Clienti Microsoft per trovare altre soluzioni. Il Servizio Supporto Tecnico Clienti Microsoft include i metodi seguenti:

  • Ricerca nella Microsoft Knowledge Base: consente di cercare informazioni di supporto tecnico e strumenti di supporto in autonomia per i prodotti Microsoft.
  • Centri soluzioni: consentono di visualizzare domande frequenti specifiche per il prodotto e informazioni su aspetti importanti del supporto.
  • Microsoft Community: consente di consultare altri utenti e Microsoft MVP (Most Valuable Professional).
  • Altre opzioni di supporto: consente di porre una domanda, contattare il Servizio Supporto Tecnico Clienti Microsoft o lasciare un commento.