Internet Explorer'da bir bağlantıya tıkladığınızda hiçbir şey olmuyor
Uyarı
Kullanımdan kaldırılan, destek dışı Internet Explorer 11 masaüstü uygulaması, Windows 10'un belirli sürümlerinde Microsoft Edge güncelleştirmesi aracılığıyla kalıcı olarak devre dışı bırakılmıştır. Daha fazla bilgi için bkz. Internet Explorer 11 masaüstü uygulamasının kullanımdan kaldırılması hakkında SSS.
Bu makale, Internet Explorer'da bir köprüye tıkladığınızda web sayfasının açılamama sorununu çözmenize yardımcı olur.
Özgün ürün sürümü: Internet Explorer 9
Orijinal KB numarası: 175775
Belirtiler
Web sayfasındaki veya e-posta iletisindeki bir köprüye tıkladığınızda hiçbir şey olmuyor. Internet Explorer web sayfasını açamıyor.
Not
Bu bilgi, Internet Explorer 9, Internet Explorer 8 ve Internet Explorer 7 için geçerlidir.
Neden
Bu, aşağıdaki bir veya birkaç nedenden dolayı oluşabilir:
- Kullanmak istediğiniz web tarayıcısını seçtiğiniz ayar bozuktur. Bu, Windows'un hangi tarayıcının bilgisayarınızda varsayılan tarayıcı olarak ayarlandığını yanlış yorumlamasına neden olabilir.
- Yazılım yüklendikten sonra ayarlar değiştirildi; bu web sayfalarının bağlantılarının yanlış çalışmasına neden olabilir.
- Önceden yüklenmiş bir tarayıcı veya eklenti bilgisayarınızdaki diğer yazılımları engelliyor olabilir.
- Kayıt defteri anahtarları değiştirildi veya bozuldu.
Çözüm
Bu bölüm, bilgisayar kullanmaya yeni başlayan kullanıcılarla orta düzeyde bilgisayar kullanıcılarına yöneliktir. Bu yöntemler sorunu çözmezse Gelişmiş sorun giderme bölümündeki yöntemleri deneyebilirsiniz. Sorunu çözmek için aşağıdaki yöntemleri sunuldukları sırayla kullanın.
Yöntem 1: Varsayılan web tarayıcısı ayarınızı denetleme
Microsoft Windows'da kullanmak istediğiniz web tarayıcısını seçebilirsiniz. Internet Explorer'ı varsayılan web tarayıcınız yapmak için şu adımları izleyin:
- Internet Explorer'ı açmak için, Başlat'a tıklayın ve ardından Internet Explorer'a tıklayın.
- Internet Explorer'ın varsayılan tarayıcınız olmasını istediğinizi onaylamanız istenirse Evet'e tıklayın.
- Araçlar menüsünde Internet Seçenekleri'ne tıklayın.
- Programlar>Varsayılan yap>Tamam'a tıklayın ve ardından Internet Explorer'ı kapatın.
Not
Değişiklikler, Internet Explorer'ı bir sonraki başlatışınızda etkili olur.
Sorunun giderilip giderilmediğini denetleyin. Sorun giderildiyse bu makaleyle işiniz bitti demektir. Sorun çözülmediyse bir sonraki yöntemi deneyin.
Yöntem 2: Internet Explorer'ın varsayılan olarak açtığı dosya türlerini değiştirme
Windows 7 ve Windows Vista için.
- Tüm Internet Explorer pencerelerini kapatın.
- Başlat'a ve ardından Denetim Masası'na tıklayın.
- Programlar'a ve sonra Varsayılan programlarınızı ayarlayın'a tıklayın.
- Programlar menüsünde, Internet Explorer'a ve ardından Bu program için varsayılanları seç'e tıklayın.
.htm
,.html
veurls
için onay kutularının seçili olduğundan emin olun ve Kaydet'e tıklayın.- Tamam'a tıklayın.
Not
Değişiklikler, Internet Explorer'ı bir sonraki başlatışınızda etkili olur.
Windows XP için
Windows Gezgini'ni açmak için Başlat'a sağ tıklayın ve ardından Bilgisayarım'a tıklayın.
Araçlar menüsünde, Klasör Seçenekleri'ne ve sonra Dosya Türleri sekmesine tıklayın.
HTM dosya türünü bulup seçin.
Internet Explorer'ın Programla açılır olarak seçildiğinden emin olun. Internet Explorer seçili değilse, Değiştir'e tıklayın, önerilen program olarak Internet Explorer'ı seçin ve ardından Tamam'a tıklayın.
Aşağıdaki dosya türleri için 3. ve 4. adımları yineleyin:
HTML
ITS
MHT
MTHML
XML
XSL
Sorunun giderilip giderilmediğini denetleyin. Sorun giderildiyse bu makaleyle işiniz bitti demektir. Sorun çözülmezse, sonraki yönteme geçin.
Yöntem 3: Internet Explorer Eklenti Yok modunu kullanma
Tarayıcı eklentileri çevrimiçi deneyiminizi iyileştirse de ara sıra bilgisayarınızdaki diğer yazılımları engelleyebilir veya onlarla çakışabilir. Ancak, eklenti devre dışı bırakılırsa bazı web sayfalarının veya Internet Explorer'ın kendisinin düzgün görüntülenmeyebileceğini unutmayın. İlk olarak, sorunun çözülmüş olup olmadığını görmek için Internet Explorer'ı eklentiler geçici olarak devre dışı bırakılmış olarak başlatın. (Eklentiler yalnızca Internet Explorer'ı normal şekilde yeniden başlatana kadar devre dışı bırakılır). Bunu yapmak için şu adımları uygulayın:
Başlat'a tıklayın, Arama kutusuna Internet Explorer yazın ve ardından Internet Explorer (Eklenti Yok) seçeneğine tıklayın.
Not
Windows XP'de, Başlat'a tıklayın, Internet Explorer simgesine sağ tıklayın ve ardından Eklentiler olmadan gözat'a tıklayın.
Internet Explorer Eklenti Yok modu sorunu çözerse, soruna neden olan tarayıcı eklentisini belirlemek için şu adımları izleyin:
- Internet Explorer'ı başlatmak için, Başlat'a tıklayın ve ardından Internet Explorer'a tıklayın.
- Araçlar düğmesine tıklayın ve ardından Eklentileri yönet'e tıklayın.
- Listeyi adlandır'daki bir eklenti'ye ve ardından Devre Dışı Bırak'a tıklayın. Internet Explorer'ı sınayın.
- Soruna neden olan eklentiyi tanımlayana kadar 3. adımı yineleyin.
Sorunun giderilip giderilmediğini denetleyin. Sorun giderildiyse bu makaleyle işiniz bitti demektir. Sorun çözülmediyse bir sonraki yöntemi deneyin.
Yöntem 4: Internet Explorer ayarlarını sıfırlayın
Soruna bozuk veya uyumsuz Internet Explorer ayarları veya eklentileri neden oluyorsa, Internet Explorer ayarlarını varsayılan ayarlara sıfırlayarak genellikle sorunu çözebilirsiniz.
Internet Explorer ayarlarını sıfırladığınızda, önceki tüm ayarlar kaybolur ve kurtarılamaz. Internet Explorer'ın varsayılan ayarlarını geri yüklediğinizde, depolanmış tanımlama bilgilerini, form verilerini, parolaları veya önceden yüklenmiş olan tarayıcı eklentilerini kullanan bazı web sayfaları düzgün çalışmayabilir. Ancak, Internet Explorer'ı varsayılan ayarlarına sıfırlamak sık kullanılanları, akışları ve diğer birkaç kişisel ayarı silmez.
Internet Explorer Ayarlarını sıfırlamak için şu adımları izleyin:
Tüm Internet Explorer pencerelerini kapatın.
Başlat'a tıklayın, Ara kutusuna inetcpl.cpl yazın ve ardından Programlar listesinde inetcpl.cpl'ye tıklayın. İnternet Seçenekleri iletişim kutusu görünür.
Not
Windows XP'de, Başlat'a, ardından Çalıştır'a tıklayın, Aç kutusuna inetcpl.cpl yazın ve ardından Tamam'a tıklayın.
Gelişmiş sekmesi'ne tıklayın.
Internet Explorer Ayarlarını Sıfırla'nın altında Sıfırla'ya tıklayın. Ardından tekrar Sıfırla'ya tıklayın.
Internet Explorer sıfırlamayı bitirdiğinde, İnternet Explorer Ayarlarını Sıfırla iletişim kutusunda Kapat'a tıklayın.
Internet Explorer'ı yeniden başlatın. Yaptığınız değişiklikler Internet Explorer'ı bir sonraki açışınızda etkili olur.
Yöntem 5: Gerekli Internet Explorer DLL dosyalarını yeniden kaydetme
Not
Bu bilgi, Windows XP için geçerlidir.
DLL dosyalarını yeniden kaydetmek için şu adımları izleyin:
Başlat'a tıklayın, Tüm Programlar'a tıklayın, Donatılar'a tıklayın, cmd'ye sağ tıklayın ve ardından Yönetici olarak çalıştır'ı seçin. Sizden yönetici parolası veya onay istenirse, parola'yı yazın veya onay verin.
Aç kutusuna regsvr32 urlmon.dll yazın ve ardından Tamam'a tıklayın.
Onayı aldığınızda Tamam'a tıklayın.
Aşağıdaki komutlar için 2. ve 3. adımları yineleyin:
regsvr32 mshtml.dll
regsvr32 shdocvw.dll
regsvr32 browseui.dll
regsvr32 msjava.dll
Sorunun giderilip giderilmediğini denetleyin. Sorun giderildiyse bu makaleyle işiniz bitti demektir. Sorun düzelmezse, sonraki bölüme geçin.
Gelişmiş sorun giderme
Bu bölüm ileri düzey bilgisayar kullanıcılarına yöneliktir.
Yöntem 1: Yeni bir kullanıcı hesabı oluşturma
Kullanıcı profilleri hakkında daha fazla bilgi için bkz. Kullanıcı Profilleri Hakkında.
Yöntemin ayrıntıları için aşağıdaki Microsoft web sitelerine gidin:
Yöntem 2: Sistem Geri Yüklemeyi Kullanma
Sistem Geri Yükleme, kişisel dosyalarınızı etkilemeden sistem dosyalarınızı ve ayarlarınızı önceki bir zaman noktasına döndürmek için geri yükleme noktalarını kullanır. Geri yükleme noktaları, otomatik olarak her hafta ve program, cihaz veya sürücü yükleme gibi önemli sistem olaylarından hemen önce oluşturulur.
Sistem Geri Yükleme'yi başlatmadan önce tüm açık dosyaları kaydedin ve tüm programları kapatın. Siz geri yükleme noktanızı onayladıktan sonra Sistem Geri Yükleme bilgisayarınızı yeniden başlatır. Bir Sistem Geri Yükleme gerçekleştirmek için şu adımları izleyin:
Windows 7 ve Windows Vista'da
Başlat'a tıklayın, Tüm Programlar'a tıklayın, Donatılar'a tıklayın, Sistem Araçları'na tıklayın ve ardından Sistem Geri Yükleme'ye tıklayın. Sizden yönetici parolası veya onay istenirse, parola'yı yazın veya onay verin.
Sistem Geri Yükleme sayfasında İleri'ye tıklayın.
İstediğiniz sistem geri yükleme tarihini veya açıklamasını seçin.
Not
Aradığınız belirli tarihi görmüyorsanız, Daha fazla tarih göster'i seçin ve sonra da istediğiniz tarihi seçin.
Onay penceresinde Bitir'e tıklayın. Bilgisayarınız yeniden başlatılır. İşlem tamamlandığında bir onay iletisi alırsınız.
Windows XP için
- Yönetici izinleri olan bir hesap kullanarak Windows'da oturum açın.
- Başlat'a tıklayın, Tüm Programlar'a tıklayın, Donatılar'a tıklayın, Sistem Araçları'na tıklayın ve ardından Sistem Geri Yükleme'ye tıklayın.
- Sistem Geri Yüklemeye Hoş Geldiniz sayfasında, Bilgisayarımı önceki bir durumuna geri yükle seçeneğini belirleyin ve ardından İleri'ye tıklayın.
- Bir Geri Yükleme noktası seçin sayfasında, Bu Listede en son sistem geri yükleme noktası'na tıklayın, bir geri yükleme noktası listesi ne tıklayın ve ardından İleri'ye tıklayın.
- Geri Yükleme Noktası Seçimini Onayla sayfasında İleri'ye tıklayın. Sistem Geri Yükleme, önceki Windows XP yapılandırmasını geri yükler ve bilgisayarı yeniden başlatır.
- Bilgisayarda Yönetici olarak oturum açın. Ardından, Sistem Geri Yükleme Geri Yükleme Tamamlandı sayfasında Tamam'a tıklayın. Bilgisayarınız yeniden başlatılır. İşlem tamamlandığında bir onay iletisi alırsınız.
Sistem Geri Yükleme'yi kullanmanıza rağmen sorun yine de oluşursa veya başka sorunlar oluşursa geri yükleme işlemini geri alabilirsiniz. İşlemi geri aldıktan sonra farklı bir geri yükleme noktası kullanmayı deneyebilirsiniz. Sistem Geri Yükleme işlemini geri almak için şu adımları izleyin:
- Başlat'a tıklayın, Tüm Programlar'a tıklayın, Donatılar'a tıklayın, Sistem Araçları'na tıklayın ve ardından Sistem Geri Yükleme'ye tıklayın.
- Sistem Geri Yüklemeyi Geri Al'a ve sonra İleri'ye tıklayın.
- Seçimlerinizi gözden geçirin ve ardından Son'a tıklayın.
Bilgisayarınız yeniden başlatılır. İşlem tamamlandığında bir onay alırsınız.
Ek Kaynaklar
Sorunun giderilip giderilmediğini denetleyin. Sorun giderildiyse bu makaleyle işiniz bitti demektir. Sorun çözülmezse, başka çözümler bulmak için Microsoft Müşteri Destek Hizmetlerini de kullanabilirsiniz. Microsoft Destek hizmetleri aşağıdaki yöntemleri içerir:
- Microsoft Bilgi Bankasında Arama Yapma: Microsoft ürünleri hakkında teknik destek bilgileri ve kendi kendine yardım araçlarını bulun.
- Çözüm Merkezleri: Ürüne özgü sık sorulan soruları ve önemli destek konularını görüntüleyin.
- Microsoft Topluluğu: Meslektaşlara, eşdüzey çalışanlara ve Microsoft'un En Değerli Uzmanları'na (MVP) başvurun.
- Diğer destek seçenekleri: Soru sorun, Microsoft Müşteri Destek Hizmetleri'ne başvurun veya geri bildirim gönderin.
Geri Bildirim
https://aka.ms/ContentUserFeedback.
Çok yakında: 2024 boyunca, içerik için geri bildirim mekanizması olarak GitHub Sorunları’nı kullanımdan kaldıracak ve yeni bir geri bildirim sistemiyle değiştireceğiz. Daha fazla bilgi için bkz.Gönderin ve geri bildirimi görüntüleyin